dm-devel.redhat.com archive mirror
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Jens Axboe <axboe@kernel.dk>
Cc: linux-bcache@vger.kernel.org, Jan Kara <jack@suse.cz>,
	Mike Snitzer <snitzer@redhat.com>,
	linux-mm@kvack.org,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Jan Kara <jack@suse.com>, Josef Bacik <josef@toxicpanda.com>,
	Coly Li <colyli@suse.de>,
	linux-block@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	dm-devel@redhat.com, linux-mtd@lists.infradead.org,
	Johannes Thumshirn <johannes.thumshirn@wdc.com>,
	Tejun Heo <tj@kernel.org>
Subject: [dm-devel] [PATCH 15/45] block: change the hash used for looking up block devices
Date: Sat, 28 Nov 2020 17:14:40 +0100	[thread overview]
Message-ID: <20201128161510.347752-16-hch@lst.de> (raw)
In-Reply-To: <20201128161510.347752-1-hch@lst.de>

Adding the minor to the major creates tons of pointless conflicts. Just
use the dev_t itself, which is 32-bits and thus is guaranteed to fit
into ino_t.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Reviewed-by: Jan Kara <jack@suse.cz>
Acked-by: Tejun Heo <tj@kernel.org>
---
 fs/block_dev.c | 26 ++------------------------
 1 file changed, 2 insertions(+), 24 deletions(-)

diff --git a/fs/block_dev.c b/fs/block_dev.c
index c5755150c6be62..d707ab376da86e 100644
--- a/fs/block_dev.c
+++ b/fs/block_dev.c
@@ -863,35 +863,12 @@ void __init bdev_cache_init(void)
 	blockdev_superblock = bd_mnt->mnt_sb;   /* For writeback */
 }
 
-/*
- * Most likely _very_ bad one - but then it's hardly critical for small
- * /dev and can be fixed when somebody will need really large one.
- * Keep in mind that it will be fed through icache hash function too.
- */
-static inline unsigned long hash(dev_t dev)
-{
-	return MAJOR(dev)+MINOR(dev);
-}
-
-static int bdev_test(struct inode *inode, void *data)
-{
-	return BDEV_I(inode)->bdev.bd_dev == *(dev_t *)data;
-}
-
-static int bdev_set(struct inode *inode, void *data)
-{
-	BDEV_I(inode)->bdev.bd_dev = *(dev_t *)data;
-	return 0;
-}
-
 static struct block_device *bdget(dev_t dev)
 {
 	struct block_device *bdev;
 	struct inode *inode;
 
-	inode = iget5_locked(blockdev_superblock, hash(dev),
-			bdev_test, bdev_set, &dev);
-
+	inode = iget_locked(blockdev_superblock, dev);
 	if (!inode)
 		return NULL;
 
@@ -903,6 +880,7 @@ static struct block_device *bdget(dev_t dev)
 		bdev->bd_super = NULL;
 		bdev->bd_inode = inode;
 		bdev->bd_part_count = 0;
+		bdev->bd_dev = dev;
 		inode->i_mode = S_IFBLK;
 		inode->i_rdev = dev;
 		inode->i_bdev = bdev;
-- 
2.29.2

--
dm-devel mailing list
dm-devel@redhat.com
https://www.redhat.com/mailman/listinfo/dm-devel


  parent reply	other threads:[~2020-11-28 16:22 UTC|newest]

Thread overview: 98+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-28 16:14 [dm-devel] merge struct block_device and struct hd_struct v4 Christoph Hellwig
2020-11-28 16:14 ` [dm-devel] [PATCH 01/45] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats Christoph Hellwig
2020-11-28 16:14 ` [dm-devel] [PATCH 02/45] filemap: consistently use ->f_mapping over ->i_mapping Christoph Hellwig
2020-11-30  9:20   ` Johannes Thumshirn
2020-11-28 16:14 ` [dm-devel] [PATCH 03/45] fs: remove get_super_thawed and get_super_exclusive_thawed Christoph Hellwig
2020-11-28 16:14 ` [dm-devel] [PATCH 04/45] fs: simplify freeze_bdev/thaw_bdev Christoph Hellwig
2020-11-30 17:55   ` Darrick J. Wong
2020-11-28 16:14 ` [dm-devel] [PATCH 05/45] mtip32xx: remove the call to fsync_bdev on removal Christoph Hellwig
2020-11-30  7:07   ` Hannes Reinecke
2020-11-30 14:48   ` Johannes Thumshirn
2020-11-28 16:14 ` [dm-devel] [PATCH 06/45] zram: do not call set_blocksize Christoph Hellwig
2020-11-28 16:14 ` [dm-devel] [PATCH 07/45] loop: " Christoph Hellwig
2020-11-30  7:07   ` Hannes Reinecke
2020-11-30 11:26   ` Johannes Thumshirn
2020-11-28 16:14 ` [dm-devel] [PATCH 08/45] dm: simplify flush_bio initialization in __send_empty_flush Christoph Hellwig
2020-11-30  7:08   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 09/45] dm: remove the block_device reference in struct mapped_device Christoph Hellwig
2020-11-28 16:14 ` [dm-devel] [PATCH 10/45] block: remove a duplicate __disk_get_part prototype Christoph Hellwig
2020-11-28 16:14 ` [dm-devel] [PATCH 11/45] block: remove a superflous check in blkpg_do_ioctl Christoph Hellwig
2020-11-30  9:20   ` Johannes Thumshirn
2020-11-28 16:14 ` [dm-devel] [PATCH 12/45] block: add a bdev_kobj helper Christoph Hellwig
2020-11-28 16:14 ` [dm-devel] [PATCH 13/45] block: use disk_part_iter_exit in disk_part_iter_next Christoph Hellwig
2020-11-28 16:14 ` [dm-devel] [PATCH 14/45] block: use put_device in put_disk Christoph Hellwig
2020-11-30  7:09   ` Hannes Reinecke
2020-11-28 16:14 ` Christoph Hellwig [this message]
2020-11-30  7:10   ` [dm-devel] [PATCH 15/45] block: change the hash used for looking up block devices Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 16/45] block: switch bdgrab to use igrab Christoph Hellwig
2020-11-30  7:14   ` Hannes Reinecke
2020-11-30  9:09   ` Jan Kara
2020-11-30 14:52   ` Johannes Thumshirn
2020-11-28 16:14 ` [dm-devel] [PATCH 17/45] init: refactor name_to_dev_t Christoph Hellwig
2020-11-30  7:15   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 18/45] init: refactor devt_from_partuuid Christoph Hellwig
2020-11-30  7:16   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 19/45] init: cleanup match_dev_by_uuid and match_dev_by_label Christoph Hellwig
2020-11-30  7:17   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 20/45] block: refactor __blkdev_put Christoph Hellwig
2020-11-30  7:17   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 21/45] block: refactor blkdev_get Christoph Hellwig
2020-11-30  7:28   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 22/45] block: move bdput() to the callers of __blkdev_get Christoph Hellwig
2020-11-30  7:29   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 23/45] block: opencode devcgroup_inode_permission Christoph Hellwig
2020-11-30  7:30   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 24/45] block: remove i_bdev Christoph Hellwig
2020-11-30  7:31   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 25/45] block: simplify bdev/disk lookup in blkdev_get Christoph Hellwig
2020-11-30  7:36   ` Hannes Reinecke
2020-11-30  9:24   ` Jan Kara
2020-12-02 21:52   ` Tejun Heo
2020-11-28 16:14 ` [dm-devel] [PATCH 26/45] block: remove ->bd_contains Christoph Hellwig
2020-11-30  7:37   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 27/45] block: simplify the block device claiming interface Christoph Hellwig
2020-11-30  7:37   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 28/45] block: simplify part_to_disk Christoph Hellwig
2020-11-30  7:38   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 29/45] block: initialize struct block_device in bdev_alloc Christoph Hellwig
2020-11-30  7:38   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 30/45] block: remove the nr_sects field in struct hd_struct Christoph Hellwig
2020-11-30  7:39   ` Hannes Reinecke
2020-11-30  9:44   ` Jan Kara
2020-11-30 14:51     ` Christoph Hellwig
2020-11-30 15:17       ` Jan Kara
2020-11-28 16:14 ` [dm-devel] [PATCH 31/45] block: move disk stat accounting to struct block_device Christoph Hellwig
2020-11-30  7:40   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 32/45] block: move the start_sect field " Christoph Hellwig
2020-11-30  7:41   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 33/45] block: move the partition_meta_info " Christoph Hellwig
2020-11-30  7:41   ` Hannes Reinecke
2020-11-28 16:14 ` [dm-devel] [PATCH 34/45] block: move holder_dir " Christoph Hellwig
2020-11-30  7:42   ` Hannes Reinecke
2020-11-28 16:15 ` [dm-devel] [PATCH 35/45] block: move make_it_fail " Christoph Hellwig
2020-11-30  7:43   ` Hannes Reinecke
2020-11-28 16:15 ` [dm-devel] [PATCH 36/45] block: move the policy field " Christoph Hellwig
2020-11-30  7:44   ` Hannes Reinecke
2020-11-28 16:15 ` [dm-devel] [PATCH 37/45] block: allocate struct hd_struct as part of struct bdev_inode Christoph Hellwig
2020-11-30  7:46   ` Hannes Reinecke
2020-11-30  9:53   ` Jan Kara
2020-11-28 16:15 ` [dm-devel] [PATCH 38/45] block: switch partition lookup to use struct block_device Christoph Hellwig
2020-11-30  7:47   ` Hannes Reinecke
2020-11-28 16:15 ` [dm-devel] [PATCH 39/45] block: remove the partno field from struct hd_struct Christoph Hellwig
2020-11-30  7:47   ` Hannes Reinecke
2020-11-28 16:15 ` [dm-devel] [PATCH 40/45] block: pass a block_device to blk_alloc_devt Christoph Hellwig
2020-11-30  7:48   ` Hannes Reinecke
2020-11-28 16:15 ` [dm-devel] [PATCH 41/45] block: pass a block_device to invalidate_partition Christoph Hellwig
2020-11-30  7:49   ` Hannes Reinecke
2020-11-28 16:15 ` [dm-devel] [PATCH 42/45] block: switch disk_part_iter_* to use a struct block_device Christoph Hellwig
2020-11-30  7:50   ` Hannes Reinecke
2020-11-30 10:20   ` Jan Kara
2020-11-28 16:15 ` [dm-devel] [PATCH 43/45] f2fs: remove a few bd_part checks Christoph Hellwig
2020-11-30  7:50   ` Hannes Reinecke
2020-11-28 16:15 ` [dm-devel] [PATCH 44/45] block: merge struct block_device and struct hd_struct Christoph Hellwig
2020-11-30  7:51   ` Hannes Reinecke
2020-11-30 10:29   ` Jan Kara
2020-11-28 16:15 ` [dm-devel] [PATCH 45/45] block: stop using bdget_disk for partition 0 Christoph Hellwig
2020-11-30  7:51   ` Hannes Reinecke
2020-11-30 17:19 ` [dm-devel] merge struct block_device and struct hd_struct v4 Christoph Hellwig
2020-11-30 17:51   ` Jens Axboe

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201128161510.347752-16-hch@lst.de \
    --to=hch@lst.de \
    --cc=axboe@kernel.dk \
    --cc=colyli@suse.de \
    --cc=dm-devel@redhat.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jack@suse.com \
    --cc=jack@suse.cz \
    --cc=johannes.thumshirn@wdc.com \
    --cc=josef@toxicpanda.com \
    --cc=linux-bcache@vger.kernel.org \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=snitzer@redhat.com \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).