dm-devel.redhat.com archive mirror
 help / color / mirror / Atom feed
 messages from 2020-11-30 07:17:25 to 2020-12-07 13:42:23 UTC [more...]

[dm-devel] split hard read-only vs read-only policy v2
 2020-12-07 13:19 UTC  (6+ messages)
` [dm-devel] [PATCH 1/6] dm: use bdev_read_only to check if a device is read-only
` [dm-devel] [PATCH 2/6] block: remove the NULL bdev check in bdev_read_only
` [dm-devel] [PATCH 3/6] block: add a hard-readonly flag to struct gendisk
` [dm-devel] [PATCH 4/6] block: propagate BLKROSET on the whole device to all partitions
` [dm-devel] [PATCH 6/6] nvme: allow revalidate to set a namespace read-only

[dm-devel] [PATCH] dm verity: skip verity work on I/O errors when system is shutting down
 2020-12-06 23:18 UTC  (5+ messages)

[dm-devel] [RFC PATCH v1 00/12] Replace strstarts() by str_has_prefix()
 2020-12-04 17:56 UTC  (3+ messages)
` [dm-devel] [RFC PATCH v1 04/12] device-mapper: "

[dm-devel] [RFC PATCH v2 0/2] add simple copy support
 2020-12-07  9:01 UTC  (9+ messages)
    ` [dm-devel] [RFC PATCH v2 1/2] block: "
    ` [dm-devel] [RFC PATCH v2 2/2] nvme: "

[dm-devel] [git pull] device mapper fixes for 5.10-rc7
 2020-12-05 19:21 UTC  (5+ messages)
  ` [dm-devel] [PATCH] block: fix incorrect branching in blk_max_size_offset() [was: Re: [git pull] device mapper fixes for 5.10-rc7]
    ` [dm-devel] [git pull] device mapper induced block fix for 5.10-rc7

[dm-devel] [PATCH] block: revert to using min_not_zero() when stacking chunk_sectors
 2020-12-04 17:49 UTC  (33+ messages)
  ` [dm-devel] "
` [dm-devel] [PATCH v2] block: use gcd() to fix chunk_sectors limit stacking
  ` [dm-devel] [PATCH] dm: "
        ` [dm-devel] "
              ` [dm-devel] [RFC PATCH] dm: fix IO splitting [was: Re: [PATCH v2] block: use gcd() to fix chunk_sectors limit stacking]

[dm-devel] store a pointer to the block_device in struct bio (again)
 2020-12-04 16:43 UTC  (27+ messages)
` [dm-devel] [PATCH 1/9] brd: remove the end of device check in brd_do_bvec
` [dm-devel] [PATCH 2/9] dcssblk: "
` [dm-devel] [PATCH 3/9] block: store a block_device pointer in struct bio
` [dm-devel] [PATCH 4/9] block: simplify submit_bio_checks a bit
` [dm-devel] [PATCH 5/9] block: use ->bi_bdev for bio based I/O accounting
` [dm-devel] [PATCH 6/9] blk-mq: use ->bi_bdev for "
` [dm-devel] [PATCH 7/9] block: add a disk_uevent helper
` [dm-devel] [PATCH 8/9] block: remove DISK_PITER_REVERSE
` [dm-devel] [PATCH 9/9] block: use an xarray for disk->part_tbl

[dm-devel] block tracepoint cleanups v2
 2020-12-04 16:42 UTC  (17+ messages)
` [dm-devel] [PATCH 1/5] block: remove the unused block_sleeprq tracepoint
` [dm-devel] [PATCH 2/5] block: simplify and extend the block_bio_merge tracepoint class
` [dm-devel] [PATCH 3/5] block: remove the request_queue argument to the block_split tracepoint
` [dm-devel] [PATCH 4/5] block: remove the request_queue argument to the block_bio_remap tracepoint
` [dm-devel] [PATCH 5/5] block: remove the request_queue to argument request based tracepoints

[dm-devel] [PATCH v1 0/5] dm: dm-user: New target that proxies BIOs to userspace
 2020-12-04 10:33 UTC  (7+ messages)
` [dm-devel] [PATCH v1 1/5] Documentation: Describe dm-user
` [dm-devel] [PATCH v1 2/5] uapi: Add dm-user structure definition
` [dm-devel] [PATCH v1 3/5] dm: dm-user: New target that proxies BIOs to userspace
` [dm-devel] [PATCH v1 4/5] selftests/dm-user: A handful of tests for dm-user
` [dm-devel] [PATCH v1 5/5] MAINTAINERS: Add myself as a dm-user maintainer

[dm-devel] [PATCH] dm verity: correcting logic used with corrupted_errs counter
 2020-12-03 22:13 UTC  (2+ messages)

[PATCH v2 0/5] Multipath Follow-up patches
 2020-12-03 20:52 UTC  (4+ messages)
` [PATCH v2 1/5] multipath: fix issues found by compiling with gcc 10
  ` [dm-devel] "

[dm-devel] block tracepoint cleanups
 2020-12-03 15:38 UTC  (18+ messages)
` [dm-devel] [PATCH 1/5] block: remove the unused block_sleeprq tracepoint
` [dm-devel] [PATCH 2/5] block: simplify and extended the block_bio_merge tracepoint class
` [dm-devel] [PATCH 3/5] block: remove the request_queue argument to the block_split tracepoint
` [dm-devel] [PATCH 4/5] block: remove the request_queue argument to the block_bio_remap tracepoint
` [dm-devel] [PATCH 5/5] block: remove the request_queue to argument request based tracepoints

[dm-devel] split hard read-only vs read-only policy v2
 2020-12-03 14:01 UTC  (12+ messages)
` [dm-devel] [PATCH 1/4] block: add a hard-readonly flag to struct gendisk
` [dm-devel] [PATCH 2/4] rbd: remove the ->set_read_only method
` [dm-devel] [PATCH 3/4] nvme: allow revalidate to set a namespace read-only
` [dm-devel] [PATCH 4/4] dm: use bdev_read_only to check if a device is read-only

[dm-devel] merge struct block_device and struct hd_struct v4
 2020-12-02 21:52 UTC  (78+ messages)
` [dm-devel] [PATCH 02/45] filemap: consistently use ->f_mapping over ->i_mapping
` [dm-devel] [PATCH 04/45] fs: simplify freeze_bdev/thaw_bdev
` [dm-devel] [PATCH 05/45] mtip32xx: remove the call to fsync_bdev on removal
` [dm-devel] [PATCH 07/45] loop: do not call set_blocksize
` [dm-devel] [PATCH 11/45] block: remove a superflous check in blkpg_do_ioctl
` [dm-devel] [PATCH 16/45] block: switch bdgrab to use igrab
` [dm-devel] [PATCH 19/45] init: cleanup match_dev_by_uuid and match_dev_by_label
` [dm-devel] [PATCH 20/45] block: refactor __blkdev_put
` [dm-devel] [PATCH 21/45] block: refactor blkdev_get
` [dm-devel] [PATCH 22/45] block: move bdput() to the callers of __blkdev_get
` [dm-devel] [PATCH 23/45] block: opencode devcgroup_inode_permission
` [dm-devel] [PATCH 24/45] block: remove i_bdev
` [dm-devel] [PATCH 25/45] block: simplify bdev/disk lookup in blkdev_get
` [dm-devel] [PATCH 26/45] block: remove ->bd_contains
` [dm-devel] [PATCH 27/45] block: simplify the block device claiming interface
` [dm-devel] [PATCH 28/45] block: simplify part_to_disk
` [dm-devel] [PATCH 29/45] block: initialize struct block_device in bdev_alloc
` [dm-devel] [PATCH 30/45] block: remove the nr_sects field in struct hd_struct
` [dm-devel] [PATCH 31/45] block: move disk stat accounting to struct block_device
` [dm-devel] [PATCH 32/45] block: move the start_sect field "
` [dm-devel] [PATCH 33/45] block: move the partition_meta_info "
` [dm-devel] [PATCH 34/45] block: move holder_dir "
` [dm-devel] [PATCH 35/45] block: move make_it_fail "
` [dm-devel] [PATCH 36/45] block: move the policy field "
` [dm-devel] [PATCH 37/45] block: allocate struct hd_struct as part of struct bdev_inode
` [dm-devel] [PATCH 38/45] block: switch partition lookup to use struct block_device
` [dm-devel] [PATCH 39/45] block: remove the partno field from struct hd_struct
` [dm-devel] [PATCH 40/45] block: pass a block_device to blk_alloc_devt
` [dm-devel] [PATCH 41/45] block: pass a block_device to invalidate_partition
` [dm-devel] [PATCH 42/45] block: switch disk_part_iter_* to use a struct block_device
` [dm-devel] [PATCH 43/45] f2fs: remove a few bd_part checks
` [dm-devel] [PATCH 44/45] block: merge struct block_device and struct hd_struct
` [dm-devel] [PATCH 45/45] block: stop using bdget_disk for partition 0

[dm-devel] [PATCH] dm crypt: export sysfs of kcryptd workqueue
 2020-12-02 15:19 UTC  (3+ messages)
  ` [dm-devel] "

[dm-devel] [PATCH 000/141] Fix fall-through warnings for Clang
 2020-12-01 14:08 UTC  (10+ messages)

[dm-devel] [PATCH v3 0/4] crypto: switch to crypto API for EBOIV generation
 2020-12-02  8:29 UTC  (2+ messages)

[dm-devel] [RFC PATCH 0/2] add simple copy support
 2020-12-01 12:20 UTC  (2+ messages)

[dm-devel] [PATCH] dm: Devices not having .iterate_devices may want to set max_io_len
 2020-12-01  8:37 UTC  (3+ messages)
` [dm-devel] "

[dm-devel] [PATCH] dm-crypt: fix deadlock when swapping to encrypted device
 2020-11-30 22:29 UTC  (4+ messages)
` [dm-devel] [PATCH v2] "
  ` [dm-devel] [PATCH v3] "

[dm-devel] Slow write speeds on new laptop
 2020-11-30 14:48 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).