dmaengine.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v1 1/4] dmaengine: Refactor dmaengine_check_align() to be bit operations only
@ 2020-02-26 10:18 Andy Shevchenko
  2020-02-26 10:18 ` [PATCH v1 2/4] dmaengine: Use negative condition for better readability Andy Shevchenko
                   ` (4 more replies)
  0 siblings, 5 replies; 10+ messages in thread
From: Andy Shevchenko @ 2020-02-26 10:18 UTC (permalink / raw)
  To: Vinod Koul, dmaengine, Dan Williams, Peter Ujfalusi; +Cc: Andy Shevchenko

There is no need to have branch and temporary variable in the function.
Simple convert it to be a set of bit and arithmetic operations.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 include/linux/dmaengine.h | 9 +--------
 1 file changed, 1 insertion(+), 8 deletions(-)

diff --git a/include/linux/dmaengine.h b/include/linux/dmaengine.h
index 64461fc64e1b..9f3f5582816a 100644
--- a/include/linux/dmaengine.h
+++ b/include/linux/dmaengine.h
@@ -1155,14 +1155,7 @@ static inline dma_cookie_t dmaengine_submit(struct dma_async_tx_descriptor *desc
 static inline bool dmaengine_check_align(enum dmaengine_alignment align,
 					 size_t off1, size_t off2, size_t len)
 {
-	size_t mask;
-
-	if (!align)
-		return true;
-	mask = (1 << align) - 1;
-	if (mask & (off1 | off2 | len))
-		return false;
-	return true;
+	return !(((1 << align) - 1) & (off1 | off2 | len));
 }
 
 static inline bool is_dma_copy_aligned(struct dma_device *dev, size_t off1,
-- 
2.25.0


^ permalink raw reply related	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2020-03-02  7:18 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-02-26 10:18 [PATCH v1 1/4] dmaengine: Refactor dmaengine_check_align() to be bit operations only Andy Shevchenko
2020-02-26 10:18 ` [PATCH v1 2/4] dmaengine: Use negative condition for better readability Andy Shevchenko
2020-02-26 12:36   ` Peter Ujfalusi
2020-02-26 10:18 ` [PATCH v1 3/4] dmaengine: Drop redundant 'else' keyword Andy Shevchenko
2020-02-26 12:37   ` Peter Ujfalusi
2020-02-26 13:44     ` Andy Shevchenko
2020-02-26 10:18 ` [PATCH v1 4/4] dmaengine: consistently return string literal from switch-case Andy Shevchenko
2020-02-26 12:35   ` Peter Ujfalusi
2020-02-26 12:35 ` [PATCH v1 1/4] dmaengine: Refactor dmaengine_check_align() to be bit operations only Peter Ujfalusi
2020-03-02  7:18 ` Vinod Koul

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).