dmaengine.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Bjorn Helgaas <helgaas@kernel.org>
To: Frank Li <Frank.Li@nxp.com>
Cc: gustavo.pimentel@synopsys.com, hongxing.zhu@nxp.com,
	l.stach@pengutronix.de, linux-imx@nxp.com,
	linux-pci@vger.kernel.org, dmaengine@vger.kernel.org,
	fancer.lancer@gmail.com, lznuaa@gmail.com, vkoul@kernel.org,
	lorenzo.pieralisi@arm.com, robh@kernel.org, kw@linux.com,
	bhelgaas@google.com, shawnguo@kernel.org,
	manivannan.sadhasivam@linaro.org
Subject: Re: [PATCH v5 0/9] Enable designware PCI EP EDMA locally
Date: Fri, 11 Mar 2022 16:58:46 -0600	[thread overview]
Message-ID: <20220311225846.GA334303@bhelgaas> (raw)
In-Reply-To: <20220310192457.3090-1-Frank.Li@nxp.com>

On Thu, Mar 10, 2022 at 01:24:48PM -0600, Frank Li wrote:
> Default Designware EDMA just probe remotely at host side.
> This patch allow EDMA driver can probe at EP side.
> 
> 1. Clean up patch
>    dmaengine: dw-edma: Detach the private data and chip info structures
>    dmaengine: dw-edma: remove unused field irq in struct dw_edma_chip
>    dmaengine: dw-edma: change rg_region to reg_base in struct
>    dmaengine: dw-edma: rename wr(rd)_ch_cnt to ll_wr(rd)_cnt in struct
> 
> 2. Enhance EDMA driver to allow prode eDMA at EP side
>    dmaengine: dw-edma: Add support for chip specific flags   
>    dmaengine: dw-edma: Add DW_EDMA_CHIP_32BIT_DBI for chip specific flags
> 
> 3. Bugs fix at EDMA driver when probe eDMA at EP side
>    dmaengine: dw-edma: Fix programming the source & dest addresses for ep
>    dmaengine: dw-edma: Don't rely on the deprecated "direction" member
> 
> 4. change pci-epf-test to use EDMA driver to transfer data.
>    PCI: endpoint: functions/pci-epf-test: Support PCI controller DMA
> 
> 5. Using imx8dxl to do test, but some EP functions still have not
> upstream yet. So below patch show how probe eDMA driver at EP
> controller driver.
> https://lore.kernel.org/linux-pci/20220309120149.GB134091@thinkpad/T/#m979eb506c73ab3cfca2e7a43635ecdaec18d8097
> 
> 
> 
> Frank Li (7):
>   dmaengine: dw-edma: Detach the private data and chip info structures
>   dmaengine: dw-edma: remove unused field irq in struct dw_edma_chip
>   dmaengine: dw-edma: change rg_region to reg_base in struct
>     dw_edma_chip
>   dmaengine: dw-edma: rename wr(rd)_ch_cnt to ll_wr(rd)_cnt in struct
>     dw_edma_chip

These should be consistently capitalized to match previous commits
(and the rest of your own commits :)):

s/remove unused/Remove unused/
s/change rg_region/Change rg_region/
s/rename wr/Rename wr/

>   dmaengine: dw-edma: Add support for chip specific flags
>   dmaengine: dw-edma: Add DW_EDMA_CHIP_32BIT_DBI for chip specific flags
>   PCI: endpoint: functions/pci-epf-test: Support PCI controller DMA

There are a couple commits that use the whole "PCI: endpoint:
functions/pci-epf-test:" prefix, but IMO it's a bit of overkill to use
so much space just for the prefix.

Maybe something like this would be enough?

  PCI: endpoint: Add embedded DMA controller test

> Manivannan Sadhasivam (2):
>   dmaengine: dw-edma: Fix programming the source & dest addresses for ep
>   dmaengine: dw-edma: Don't rely on the deprecated "direction" member
> 
>  drivers/dma/dw-edma/dw-edma-core.c            | 131 +++++++++++-------
>  drivers/dma/dw-edma/dw-edma-core.h            |  32 +----
>  drivers/dma/dw-edma/dw-edma-pcie.c            |  83 +++++------
>  drivers/dma/dw-edma/dw-edma-v0-core.c         |  46 +++---
>  drivers/dma/dw-edma/dw-edma-v0-debugfs.c      |  10 +-
>  drivers/pci/endpoint/functions/pci-epf-test.c | 108 +++++++++++++--
>  include/linux/dma/edma.h                      |  56 +++++++-
>  7 files changed, 298 insertions(+), 168 deletions(-)
> 
> -- 
> 2.24.0.rc1
> 

      parent reply	other threads:[~2022-03-11 23:02 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-03-10 19:24 [PATCH v5 0/9] Enable designware PCI EP EDMA locally Frank Li
2022-03-10 19:24 ` [PATCH v5 1/9] dmaengine: dw-edma: Detach the private data and chip info structures Frank Li
2022-03-10 19:24 ` [PATCH v5 2/9] dmaengine: dw-edma: remove unused field irq in struct dw_edma_chip Frank Li
2022-03-10 19:24 ` [PATCH v5 3/9] dmaengine: dw-edma: change rg_region to reg_base " Frank Li
2022-03-10 19:24 ` [PATCH v5 4/9] dmaengine: dw-edma: rename wr(rd)_ch_cnt to ll_wr(rd)_cnt " Frank Li
2022-03-10 19:24 ` [PATCH v5 5/9] dmaengine: dw-edma: Fix programming the source & dest addresses for ep Frank Li
2022-03-10 19:24 ` [PATCH v5 6/9] dmaengine: dw-edma: Don't rely on the deprecated "direction" member Frank Li
2022-03-10 19:24 ` [PATCH v5 7/9] dmaengine: dw-edma: Add support for chip specific flags Frank Li
2022-03-10 19:24 ` [PATCH v5 8/9] dmaengine: dw-edma: Add DW_EDMA_CHIP_32BIT_DBI " Frank Li
2022-03-10 19:24 ` [PATCH v5 9/9] PCI: endpoint: functions/pci-epf-test: Support PCI controller DMA Frank Li
2022-03-10 19:45 ` [PATCH v5 0/9] Enable designware PCI EP EDMA locally Serge Semin
2022-03-10 19:58   ` Zhi Li
2022-03-10 20:00   ` Serge Semin
2022-03-11 22:58 ` Bjorn Helgaas [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220311225846.GA334303@bhelgaas \
    --to=helgaas@kernel.org \
    --cc=Frank.Li@nxp.com \
    --cc=bhelgaas@google.com \
    --cc=dmaengine@vger.kernel.org \
    --cc=fancer.lancer@gmail.com \
    --cc=gustavo.pimentel@synopsys.com \
    --cc=hongxing.zhu@nxp.com \
    --cc=kw@linux.com \
    --cc=l.stach@pengutronix.de \
    --cc=linux-imx@nxp.com \
    --cc=linux-pci@vger.kernel.org \
    --cc=lorenzo.pieralisi@arm.com \
    --cc=lznuaa@gmail.com \
    --cc=manivannan.sadhasivam@linaro.org \
    --cc=robh@kernel.org \
    --cc=shawnguo@kernel.org \
    --cc=vkoul@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).