dev.dpdk.org archive mirror
 help / color / mirror / Atom feed
* [dpdk-dev] [PATCH 0/3] move mbuf definition into a separate file
@ 2019-08-16 12:53 Konstantin Ananyev
  2019-08-16 12:53 ` [dpdk-dev] [PATCH 1/3] eal: move CACHE and IOVA related definitions Konstantin Ananyev
                   ` (3 more replies)
  0 siblings, 4 replies; 17+ messages in thread
From: Konstantin Ananyev @ 2019-08-16 12:53 UTC (permalink / raw)
  To: dev
  Cc: michel, olivier.matz, anatoly.burakov, vipin.varghese,
	Konstantin Ananyev

Right now inclusion of rte_mbuf.h header can cause inclusion of
some arch/os specific headers.
That prevents it to be included directly by some
non-DPDK (but related) entities: KNI, BPF programs, etc.
To overcome that problem usually a separate definitions of rte_mbuf
structure is created within these entities.
That aproach has a lot of drawbacks: code duplication, error prone, etc.
This series moves rte_mbuf structure definition (and some related macros)
into a separate file that can be included by both rte_mbuf.h and
other non-DPDK entities.

Note that these moves shouldn't introduce any change for current DPDK code.

Konstantin Ananyev (3):
  eal: move CACHE and IOVA related definitions
  mbuf: move mbuf definition into a separate file
  examples/bpf: remove duplicate mbuf definition

 examples/bpf/t2.c                             |   5 +-
 examples/bpf/t3.c                             |   3 +-
 lib/librte_eal/common/include/rte_common.h    |  44 ++
 lib/librte_eal/common/include/rte_memory.h    |  38 -
 lib/librte_mbuf/Makefile                      |   5 +-
 lib/librte_mbuf/meson.build                   |   3 +-
 lib/librte_mbuf/rte_mbuf.h                    | 738 +-----------------
 .../mbuf.h => lib/librte_mbuf/rte_mbuf_core.h | 556 ++++++++-----
 8 files changed, 428 insertions(+), 964 deletions(-)
 rename examples/bpf/mbuf.h => lib/librte_mbuf/rte_mbuf_core.h (51%)

-- 
2.17.1


^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2019-10-25 20:33 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-08-16 12:53 [dpdk-dev] [PATCH 0/3] move mbuf definition into a separate file Konstantin Ananyev
2019-08-16 12:53 ` [dpdk-dev] [PATCH 1/3] eal: move CACHE and IOVA related definitions Konstantin Ananyev
2019-08-16 18:50   ` Michel Machado
2019-08-16 12:53 ` [dpdk-dev] [PATCH 2/3] mbuf: move mbuf definition into a separate file Konstantin Ananyev
2019-08-16 18:51   ` Michel Machado
2019-08-16 12:53 ` [dpdk-dev] [PATCH 3/3] examples/bpf: remove duplicate mbuf definition Konstantin Ananyev
2019-08-16 18:44   ` Michel Machado
2019-09-27 13:50 ` [dpdk-dev] [PATCH v2 0/3] move mbuf definition into a separate file Konstantin Ananyev
2019-09-27 13:50   ` [dpdk-dev] [PATCH v2 1/3] eal: move CACHE and IOVA related definitions Konstantin Ananyev
2019-09-30 19:34     ` Michel Machado
2019-09-27 13:50   ` [dpdk-dev] [PATCH v2 2/3] mbuf: move mbuf definition into a separate file Konstantin Ananyev
2019-09-27 14:42     ` Andrew Rybchenko
2019-09-30 19:34     ` Michel Machado
2019-10-16  8:18     ` Olivier Matz
2019-09-27 13:50   ` [dpdk-dev] [PATCH v2 3/3] examples/bpf: remove duplicate mbuf definition Konstantin Ananyev
2019-09-30 19:35     ` Michel Machado
2019-10-25 20:33   ` [dpdk-dev] [PATCH v2 0/3] move mbuf definition into a separate file Thomas Monjalon

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).