DPDK-dev Archive on lore.kernel.org
 help / color / Atom feed
From: Ferruh Yigit <ferruh.yigit@intel.com>
To: "Wang, Haiyue" <haiyue.wang@intel.com>, Ray Kinsella <mdr@ashroe.eu>
Cc: "dev@dpdk.org" <dev@dpdk.org>, "Sun, Chenmin" <chenmin.sun@intel.com>
Subject: Re: [dpdk-dev] [RFC v2 1/3] ethdev: add the API for getting trace information
Date: Mon, 9 Sep 2019 12:23:36 +0100
Message-ID: <75f88e4b-97ca-7e1f-1385-8e69f659be7f@intel.com> (raw)
In-Reply-To: <E3B9F2FDCB65864C82CD632F23D8AB8773D67333@shsmsx102.ccr.corp.intel.com>

On 9/7/2019 3:42 AM, Wang, Haiyue wrote:
>> -----Original Message-----
>> From: Yigit, Ferruh
>> Sent: Friday, September 6, 2019 22:22
>> To: Ray Kinsella <mdr@ashroe.eu>; Wang, Haiyue <haiyue.wang@intel.com>
>> Cc: dev@dpdk.org
>> Subject: Re: [dpdk-dev] [RFC v2 1/3] ethdev: add the API for getting trace information
>>
>> On 8/13/2019 1:51 PM, Ray Kinsella wrote:
>>>
>>>
>>> On 13/08/2019 04:24, Stephen Hemminger wrote:
>>>> On Tue, 13 Aug 2019 11:06:10 +0800
>>>> Haiyue Wang <haiyue.wang@intel.com> wrote:
>>>>
>>>>> Enhance the PMD to support retrieving trace information like
>>>>> Rx/Tx burst selection etc.
>>>>>
>>>>> Signed-off-by: Haiyue Wang <haiyue.wang@intel.com>
>>>>> ---
>>>>>  lib/librte_ethdev/rte_ethdev.c      | 18 ++++++++++++++++++
>>>>>  lib/librte_ethdev/rte_ethdev.h      |  9 +++++++++
>>>>>  lib/librte_ethdev/rte_ethdev_core.h |  4 ++++
>>>>>  3 files changed, 31 insertions(+)
>>>>>
>>>>> diff --git a/lib/librte_ethdev/rte_ethdev.c b/lib/librte_ethdev/rte_ethdev.c
>>>>> index 17d183e..6098fad 100644
>>>>> --- a/lib/librte_ethdev/rte_ethdev.c
>>>>> +++ b/lib/librte_ethdev/rte_ethdev.c
>>>>> @@ -4083,6 +4083,24 @@ rte_eth_tx_queue_info_get(uint16_t port_id, uint16_t queue_id,
>>>>>  }
>>>>>
>>>>>  int
>>>>> +rte_eth_trace_info_get(uint16_t port_id, uint16_t queue_id,
>>>>> +		       enum rte_eth_trace type, char *buf, int sz)
>>
>> Better to use struct as argument instead of individual variables because it is
>> easier to extend the struct later if needed.
>>
>>>>> +{
>>>>> +	struct rte_eth_dev *dev;
>>>>> +
>>>>> +	RTE_ETH_VALID_PORTID_OR_ERR_RET(port_id, -ENODEV);
>>>>> +
>>>>> +	if (buf == NULL)
>>>>> +		return -EINVAL;
>>>>> +
>>>>> +	dev = &rte_eth_devices[port_id];
>>>>> +
>>>>> +	RTE_FUNC_PTR_OR_ERR_RET(*dev->dev_ops->trace_info_get, -ENOTSUP);
>>>>> +
>>>>> +	return dev->dev_ops->trace_info_get(dev, queue_id, type, buf, sz);
>>>>
>>>> What if queueid is out of bounds?
>>>>
>>>> The bigger problem is that this information is like a log message
>>>> and unstructured, which makes it device specific and useless for automation.
>>>
>>> IMHO - this is much better implemented as a capability bitfield, that
>>> can be queried.
>>
>> +1 to return the datapath capability as bitfield.
>>
>> Also +1 to have a new API,
>> - I am not sure about the API name, 'rte_eth_trace_info_get()', can we find
>> something better instead of 'trace' there.
>> - I think we should limit this API only to get current datapath configuration,
>> for clarity of the API don't return capability or not datapath related config.
>>
>> Also this information not always supported in queue level, what do you think
>> having ability to get this information in port level,
>> like this API can return a struct, which may have a field that says if the
>> output is for queue or port, or this can be another bitfield, what do you think?
>>
> 
> #define RX_SCALAR	(1ULL < 0)
> #define RX_VECTOR_AVX2  ...

What about having RX_VECTOR value, later another bit group for the details of
the vectorization:
SSE
AVX2
AVX512
NEON
ALTIVEC

Since above options can exist together, what about using values for them instead
of bitfields? Reserving 4 bits, 2^4 = 16, can be enough I think for long term.

> ...
> #define RX_SCATTER ...
> #define RX_BULK_ALLOC
> #define TX_SCALAR
> #define TX_VECTOR_AVX2 ..
> ...
> #define TX_SIMPLE

And what about implementing these as 'enum' instead of defines?

> 
> struct rte_pkt_burst_info {
> 	bool per_queue_support; /* Per queue has each rx/tx burst setting */
> 	uint64_t burst_infos;

'infos' can be wrong linguistically, I think better to stick to 'info'

> };
> 
> int
> rte_eth_pkt_burst_info_get(uint16_t port_id, bool is_rx, uint16_t queue_id,
> 		       	struct rte_pkt_burst_info *pbinfo)

Naming is the hard ;) I am not sure about 'burst_info' as well, I think they are
exactly "burst mode function types" that recv/send burst of packets.
It feels like it will provide information about all the burst mode related
things like burst size etc.. but this is only for the function type.
And suggestion is welcome :)

> 
> Rx/Tx shares the 64 bits definition, but return according to 'is_rx'.

Why 'is_rx' required, is it because 'per_queue_support' field? If so I think
better to add Rx and Tx version of it and drop the 'is_rx' from the API.

> Application can call with 'queue_id = 0' firstly, if the Rx/Tx queue
> support queue level burst setting, then 'per_queue_support = true', then
> it can iterate to get the burst info with different 'queue_id', of course,
> the 'per_queue_support = true' will be returned always.

I am not sure if that is what you meant but there shouldn't be any special
behavior for "queue_id = 0", for the devices that doesn't support queue level,
they can send same value for each queue with "per_queue_support = false"

An application iterating the over queues can use same API without worrying the
'per_queue_support' value, for the application that assumes the burst mode
function should be same for the port may want to verify this in advance by
checking the 'per_queue_support' value.

> 
> How about this ?
> 
> 
>>>
>>>>
>>>> Why not just keep it in the log like it is now?
>>>>
>>>>>  int rte_eth_tx_queue_info_get(uint16_t port_id, uint16_t queue_id,
>>>>>  	struct rte_eth_txq_info *qinfo);
>>>>>
>>>>> +int
>>>>> +rte_eth_trace_info_get(uint16_t port_id, uint16_t queue_id,
>>>>> +	enum rte_eth_trace type, char *buf, int sz);
>>>>> +
>>>>
>>>> You didn't run checkpatch, otherwise you would have seen complaints
>>>> about not listing API as experimental.
>>>>
>>>> Also the API would have to be in the map file as well.
>>>>
>>>> Docbook comments are also missing.
>>>>
>>>>
>>>>
>>>>
> 


  reply index

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-13  3:06 [dpdk-dev] [RFC v2 0/3] show the Rx/Tx burst description field Haiyue Wang
2019-08-13  3:06 ` [dpdk-dev] [RFC v2 1/3] ethdev: add the API for getting trace information Haiyue Wang
2019-08-13  3:24   ` Stephen Hemminger
2019-08-13  4:37     ` Wang, Haiyue
2019-08-13  9:57     ` David Marchand
2019-08-13 11:21       ` Wang, Haiyue
2019-08-13 12:51     ` Ray Kinsella
2019-09-06 14:21       ` Ferruh Yigit
2019-09-07  2:42         ` Wang, Haiyue
2019-09-09 11:23           ` Ferruh Yigit [this message]
2019-09-09 12:40             ` Bruce Richardson
2019-09-09 12:50               ` Ferruh Yigit
2019-09-09 13:17                 ` Ferruh Yigit
2019-09-10  4:36                   ` Wang, Haiyue
2019-09-10  8:06                     ` Ferruh Yigit
2019-09-10  8:37                       ` Wang, Haiyue
2019-09-10  9:14                         ` Ferruh Yigit
2019-09-10 11:41                           ` Wang, Haiyue
2019-09-10 15:00                             ` Ferruh Yigit
2019-09-10 15:17                               ` Wang, Haiyue
2019-09-10 15:33                                 ` Ferruh Yigit
2019-09-10 15:35                                   ` Wang, Haiyue
2019-09-10 14:19                           ` Wang, Haiyue
2019-09-10 15:03                             ` Ferruh Yigit
2019-09-10 15:18                               ` Wang, Haiyue
2019-09-10 15:36                                 ` Ferruh Yigit
2019-09-10 15:38                                   ` Wang, Haiyue
2019-09-10 15:06                     ` Ferruh Yigit
2019-09-10 15:21                       ` Wang, Haiyue
2019-09-10 15:35                         ` Ferruh Yigit
2019-09-10 15:37                           ` Wang, Haiyue
2019-08-15  9:07     ` Ray Kinsella
2019-08-13  3:06 ` [dpdk-dev] [RFC v2 2/3] testpmd: show the Rx/Tx burst description Haiyue Wang
2019-08-13  3:06 ` [dpdk-dev] [RFC v2 3/3] net/ice: support the Rx/Tx burst description trace Haiyue Wang

Reply instructions:

You may reply publically to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=75f88e4b-97ca-7e1f-1385-8e69f659be7f@intel.com \
    --to=ferruh.yigit@intel.com \
    --cc=chenmin.sun@intel.com \
    --cc=dev@dpdk.org \
    --cc=haiyue.wang@intel.com \
    --cc=mdr@ashroe.eu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

DPDK-dev Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/dpdk-dev/0 dpdk-dev/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 dpdk-dev dpdk-dev/ https://lore.kernel.org/dpdk-dev \
		dev@dpdk.org dpdk-dev@archiver.kernel.org
	public-inbox-index dpdk-dev

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.dpdk.dev


AGPL code for this site: git clone https://public-inbox.org/ public-inbox