dri-devel.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: Daniel Vetter <daniel.vetter@ffwll.ch>
Cc: "Rafael J. Wysocki" <rafael@kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Intel Graphics Development <intel-gfx@lists.freedesktop.org>,
	Emil Velikov <emil.l.velikov@gmail.com>,
	DRI Development <dri-devel@lists.freedesktop.org>,
	Daniel Vetter <daniel.vetter@intel.com>
Subject: Re: [Intel-gfx] [PATCH 03/52] drm: add managed resources tied to drm_device
Date: Wed, 19 Feb 2020 18:46:34 +0200	[thread overview]
Message-ID: <20200219164634.GB5070@pendragon.ideasonboard.com> (raw)
In-Reply-To: <CAKMK7uE0wAR9DsmL9gPYJCeAzRw8kEE5eGwXRoVpxb4ByHtehA@mail.gmail.com>

Hi Daniel,

On Wed, Feb 19, 2020 at 05:22:38PM +0100, Daniel Vetter wrote:
> On Wed, Feb 19, 2020 at 5:09 PM Emil Velikov wrote:
> > On Wed, 19 Feb 2020 at 14:23, Daniel Vetter wrote:
> >> On Wed, Feb 19, 2020 at 2:33 PM Greg Kroah-Hartman wrote:
> >>> On Wed, Feb 19, 2020 at 03:28:47PM +0200, Laurent Pinchart wrote:
> >>>> On Wed, Feb 19, 2020 at 11:20:33AM +0100, Daniel Vetter wrote:
> >>>>> We have lots of these. And the cleanup code tends to be of dubious
> >>>>> quality. The biggest wrong pattern is that developers use devm_, which
> >>>>> ties the release action to the underlying struct device, whereas
> >>>>> all the userspace visible stuff attached to a drm_device can long
> >>>>> outlive that one (e.g. after a hotunplug while userspace has open
> >>>>> files and mmap'ed buffers). Give people what they want, but with more
> >>>>> correctness.
> >>>>>
> >>>>> Mostly copied from devres.c, with types adjusted to fit drm_device and
> >>>>> a few simplifications - I didn't (yet) copy over everything. Since
> >>>>> the types don't match code sharing looked like a hopeless endeavour.
> >>>>>
> >>>>> For now it's only super simplified, no groups, you can't remove
> >>>>> actions (but kfree exists, we'll need that soon). Plus all specific to
> >>>>> drm_device ofc, including the logging. Which I didn't bother to make
> >>>>> compile-time optional, since none of the other drm logging is compile
> >>>>> time optional either.
> >>>>>
> >>>>> One tricky bit here is the chicken&egg between allocating your
> >>>>> drm_device structure and initiliazing it with drm_dev_init. For
> >>>>> perfect onion unwinding we'd need to have the action to kfree the
> >>>>> allocation registered before drm_dev_init registers any of its own
> >>>>> release handlers. But drm_dev_init doesn't know where exactly the
> >>>>> drm_device is emebedded into the overall structure, and by the time it
> >>>>> returns it'll all be too late. And forcing drivers to be able clean up
> >>>>> everything except the one kzalloc is silly.
> >>>>>
> >>>>> Work around this by having a very special final_kfree pointer. This
> >>>>> also avoids troubles with the list head possibly disappearing from
> >>>>> underneath us when we release all resources attached to the
> >>>>> drm_device.
> >>>>
> >>>> This is all a very good idea ! Many subsystems are plagged by drivers
> >>>> using devm_k*alloc to allocate data accessible by userspace. Since the
> >>>> introduction of devm_*, we've likely reduced the number of memory leaks,
> >>>> but I'm pretty sure we've increased the risk of crashes as I've seen
> >>>> some drivers that used .release() callbacks correctly being naively
> >>>> converted to incorrect devm_* usage :-(
> >>>>
> >>>> This leads me to a question: if other subsystems have the same problem,
> >>>> could we turn this implementation into something more generic ? It
> >>>> doesn't have to be done right away and shouldn't block merging this
> >>>> series, but I think it would be very useful.
> >>>
> >>> It shouldn't be that hard to tie this into a drv_m() type of a thing
> >>> (driver_memory?)
> >>>
> >>> And yes, I think it's much better than devm_* for the obvious reasons of
> >>> this being needed here.
> >>
> >> There's two reasons I went with copypasta instead of trying to share code:
> >> - Type checking, I definitely don't want people to mix up devm_ with
> >> drmm_. But even if we do a drv_m that subsystems could embed we do
> >> have quite a few different types of component drivers (and with
> >> drm_panel and drm_bridge even standardized), and I don't want people
> >> to be able to pass the wrong kind of struct to e.g. a managed
> >> drmm_connector_init - it really needs to be the drm_device, not a
> >> panel or bridge or something else.
> >>
> >> - We could still share the code as a kind of implementation/backend
> >> library. But it's not much, and with embedding I could use the drm
> >> device logging stuff which is kinda nice. But if there's more demand
> >> for this I can definitely see the point in sharing this, as Laurent
> >> pointed out with the tiny optimization with not allocating a NULL void
> >> * that I've done (and screwed up) it's not entirely trivial code.
> >
> > My 2c as they say, although closer to a brain dump :-)
> >
> > On one hand the drm_device has an embedded struct device. On the other
> > drm_device preserves state which outlives the embedded struct device.
> >
> > Would it make sense to keep drm_device better related to the
> > underlying device? Effectively moving the $misc state to drm_driver.
> > This idea does raise another question - struct drm_driver unlike many
> > other struct $foo_driver, does not embedded device_driver :-(
> > So if one is to cover the above two, then the embedding concerns will
> > be elevated.
> 
> drm_driver isn't a bus device driver in the linux driver model sense,
> but an uapi thing that sits on top of some underlying device. So maybe
> better to rename drm_driver to drm_interface_driver, and drm_device to
> drm_interface. But that would be giantic churn and probably lots of
> confusion. We do require a link between drm_device->struct device
> nowadays, but that's just to guarantee userspace can find the
> drm_device in sysfs somewhere and make sense of what it actually
> drives.

If we wanted to rename drm_driver to align with the rest of the kernel,
it should probably be drm_device_ops, with the non-ops fields being
moved to a separate structure.

I don't mind churn (but I agree it may not be worth it), but even if we
don't rename the structure, I think it would be very useful to remove
the non-const fields, in order to allow storing the structure as a
global static const struct. Function pointers in non-const memory can be
a security issue. As far as I can tell, the only blocker is the
legacy_dev_list field.

> That's also why the lifetimes for the two things are totally
> different. The device driver an all it's resources are tied to the
> underlying physical device, and resources can be released when that
> driver<->device link is broken (either unbind or hotunplug). That's
> what devm_ does. The drm_driver/drm_device otoh is tied to the
> userspace api, and can only disappear once all the userspace handles
> have been cleaned up and released.

And so they're tied to the lifetime of the struct device that models the
userspace interface. Shame they're both called device :-)

> And we have an enormous amount of those, with all the mmaps, and
> shared fd for dma-buf, sync_file, synobj and whatever else. The
> drm_device can only be cleaned up once userspace has closed all these
> things, or we'll go boom somewhere. The only connection is that the
> userspace interface drives the underlying hw (as long as it's still
> there) and the hw side holds a reference on the uapi side
> (drm_dev_get/put) to make sure the userspace side doesn't go poof and
> disappear when no one has the /dev node open :-)
> 
> But aside from these links they're completely separate worlds, and
> mixing up the lifetimes results in all kinds of bad things happening.
> Ofc normally these two things exist at the same time, but hotunplug
> makes things very interesting here. And traditionally we've handled it
> badly, if at all in drm.
> 
> > WRT type safety, with the embedded work sorted, one could introduce
> > trivial helpers for drmm_connector_init and friends.
> >
> > In another email you've also raised the question of API diversity and
> > reviews, I believe. IMHO one could start with a bare minimum set and
> > extend as needed.
> > Based on the prompt response from Greg, I suspect review won't be an issue.
> 
> The drmm_ stuff in here is the bare minimum we need to get started. I
> expect lots of stuff will be added, but those are all just going to be
> convenience functions on top of the drmm_add_action primitive.
> 
> > If people agree with my analysis and considering the size/complexity
> > of drm_device <> drm_driver reshuffle, we could add a TODO task.
> > I suspect the underlying work will be larger than the current 52 patch
> > set, so doing it in one go will be PITA.
> 
> I'm not following what you want to shuffle. drm_driver is entirely
> static and kinda global, drm_device is the per-instance structure we
> have. And here we mean per-userspace uapi interface instance. So I
> guess I'm confused what you want to do?
> 
> > * Based on the following quick greps
> > $git grep -W "struct [a-zA-Z0-9-]*_driver {" -- include/ | grep -w
> > "struct device_driver\>.*;"  | wc -l
> > 56
> > $git cgrep "struct [a-zA-Z0-9-]*_driver {" -- include/ | wc -l
> > 71

-- 
Regards,

Laurent Pinchart
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  parent reply	other threads:[~2020-02-19 16:46 UTC|newest]

Thread overview: 135+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-19 10:20 [PATCH 00/52] drm_device managed resources Daniel Vetter
2020-02-19 10:20 ` [PATCH 01/52] mm/sl[uo]b: export __kmalloc_track(_node)_caller Daniel Vetter
2020-02-19 19:42   ` Andrew Morton
2020-02-22  3:42   ` Christopher Lameter
2020-02-19 10:20 ` [PATCH 02/52] drm/i915: Don't clear drvdata in ->release Daniel Vetter
2020-02-19 10:20 ` [PATCH 03/52] drm: add managed resources tied to drm_device Daniel Vetter
2020-02-19 12:31   ` Neil Armstrong
2020-02-19 13:24     ` Daniel Vetter
2020-02-19 13:28   ` Laurent Pinchart
2020-02-19 13:33     ` Greg Kroah-Hartman
2020-02-19 14:22       ` Daniel Vetter
2020-02-19 16:09         ` [Intel-gfx] " Emil Velikov
2020-02-19 16:22           ` Daniel Vetter
2020-02-19 16:41             ` Emil Velikov
2020-02-19 16:46             ` Laurent Pinchart [this message]
2020-02-19 16:53               ` Daniel Vetter
2020-02-19 17:02                 ` Laurent Pinchart
2020-02-19 17:06                   ` Daniel Vetter
2020-02-19 17:00         ` Greg Kroah-Hartman
2020-02-19 17:36           ` Laurent Pinchart
2020-02-19 18:19             ` Greg Kroah-Hartman
2020-02-19 19:57               ` Daniel Vetter
2020-02-20 14:58               ` Laurent Pinchart
2020-02-19 13:57     ` Daniel Vetter
2020-02-19 10:20 ` [PATCH 04/52] drm: Set final_kfree in drm_dev_alloc Daniel Vetter
2020-02-19 12:03   ` Oleksandr Andrushchenko
2020-02-19 13:39   ` Laurent Pinchart
2020-02-19 14:41     ` Daniel Vetter
2020-02-21 19:07       ` Daniel Vetter
2020-02-19 10:20 ` [PATCH 05/52] drm/mipi_dbi: Use drmm_add_final_kfree in all drivers Daniel Vetter
2020-02-19 11:47   ` Thomas Zimmermann
2020-02-19 12:45     ` Thomas Zimmermann
2020-02-19 13:23     ` Daniel Vetter
2020-02-19 13:29       ` Thomas Zimmermann
2020-02-19 14:32         ` Daniel Vetter
2020-02-20 16:18   ` Noralf Trønnes
2020-02-19 10:20 ` [PATCH 06/52] drm/udl: Use drmm_add_final_kfree Daniel Vetter
2020-02-19 10:20 ` [PATCH 07/52] " Daniel Vetter
2020-02-19 13:42   ` Laurent Pinchart
2020-02-19 14:43     ` Daniel Vetter
2020-02-19 10:20 ` [PATCH 08/52] drm/qxl: " Daniel Vetter
2020-02-19 10:20 ` [PATCH 09/52] drm/i915: " Daniel Vetter
2020-02-19 10:20 ` [PATCH 10/52] drm/cirrus: " Daniel Vetter
2020-02-24  8:13   ` Gerd Hoffmann
2020-02-19 10:20 ` [PATCH 11/52] drm/v3d: " Daniel Vetter
2020-02-19 18:43   ` Eric Anholt
2020-02-19 10:20 ` [PATCH 12/52] drm/tidss: " Daniel Vetter
2020-02-19 10:20 ` [PATCH 13/52] drm/mcde: " Daniel Vetter
2020-02-19 16:12   ` Linus Walleij
2020-02-19 10:20 ` [PATCH 14/52] drm/vgem: " Daniel Vetter
2020-02-19 10:20 ` [PATCH 15/52] drm/vkms: " Daniel Vetter
2020-02-19 10:20 ` [PATCH 16/52] drm/repaper: " Daniel Vetter
2020-02-20 16:18   ` Noralf Trønnes
2020-02-19 10:20 ` [PATCH 17/52] drm/inigenic: " Daniel Vetter
2020-02-19 10:20 ` [PATCH 18/52] drm/gm12u320: " Daniel Vetter
2020-02-19 10:20 ` [PATCH 19/52] drm/<drivers>: " Daniel Vetter
2020-02-19 14:11   ` Laurent Pinchart
2020-02-19 14:30     ` Daniel Vetter
2020-02-19 14:39       ` Laurent Pinchart
2020-02-19 15:29         ` Daniel Vetter
2020-02-19 10:20 ` [PATCH 20/52] drm: Cleanups after drmm_add_final_kfree rollout Daniel Vetter
2020-02-19 10:20 ` [PATCH 21/52] drm: Handle dev->unique with drmm_ Daniel Vetter
2020-02-19 14:28   ` Laurent Pinchart
2020-02-19 15:24     ` Daniel Vetter
2020-02-19 10:20 ` [PATCH 22/52] drm: Use drmm_ for drm_dev_init cleanup Daniel Vetter
2020-02-19 14:35   ` Laurent Pinchart
2020-02-19 15:27     ` Daniel Vetter
2020-02-19 15:37       ` Laurent Pinchart
2020-02-19 15:44         ` Daniel Vetter
2020-02-19 10:20 ` [PATCH 23/52] drm: manage drm_minor cleanup with drmm_ Daniel Vetter
2020-02-19 14:47   ` Laurent Pinchart
2020-02-19 15:34     ` Daniel Vetter
2020-02-19 10:20 ` [PATCH 24/52] drm: Manage drm_gem_init " Daniel Vetter
2020-02-19 14:22   ` Laurent Pinchart
2020-02-19 14:37     ` Daniel Vetter
2020-02-19 14:52       ` Laurent Pinchart
2020-02-19 14:56         ` Daniel Vetter
2020-02-19 10:20 ` [PATCH 25/52] drm: Manage drm_vblank_cleanup " Daniel Vetter
2020-02-19 10:20 ` [PATCH 26/52] drm: Garbage collect drm_dev_fini Daniel Vetter
2020-02-19 10:20 ` [PATCH 27/52] drm: Manage drm_mode_config_init with drmm_ Daniel Vetter
2020-02-19 13:49   ` Laurent Pinchart
2020-02-19 15:47     ` Daniel Vetter
2020-02-19 16:07       ` Laurent Pinchart
2020-02-19 16:23         ` Daniel Vetter
2020-02-19 17:30           ` Noralf Trønnes
2020-02-19 18:12             ` Daniel Vetter
2020-02-19 10:20 ` [PATCH 28/52] drm/bochs: Remove leftover drm_atomic_helper_shutdown Daniel Vetter
2020-02-24  8:14   ` Gerd Hoffmann
2020-02-19 10:20 ` [PATCH 29/52] drm/bochs: Drop explicit drm_mode_config_cleanup Daniel Vetter
2020-02-24  8:15   ` Gerd Hoffmann
2020-02-19 10:21 ` [PATCH 30/52] drm/cirrus: Drop explicit drm_mode_config_cleanup call Daniel Vetter
2020-02-24  8:16   ` Gerd Hoffmann
2020-02-19 10:21 ` [PATCH 31/52] drm/cirrus: Fully embrace devm_ Daniel Vetter
2020-02-24  8:18   ` Gerd Hoffmann
2020-02-19 10:21 ` [PATCH 32/52] drm/ingenic: Drop explicit drm_mode_config_cleanup call Daniel Vetter
2020-02-19 10:21 ` [PATCH 33/52] drm/mcde: " Daniel Vetter
2020-02-19 16:12   ` Linus Walleij
2020-02-19 10:21 ` [PATCH 34/52] drm/mcde: More devm_drm_dev_init Daniel Vetter
2020-02-19 16:13   ` Linus Walleij
2020-02-19 10:21 ` [PATCH 35/52] drm/meson: Drop explicit drm_mode_config_cleanup call Daniel Vetter
2020-02-19 10:39   ` Neil Armstrong
2020-02-19 10:21 ` [PATCH 36/52] drm/pl111: " Daniel Vetter
2020-02-19 10:21 ` [PATCH 37/52] drm/rcar-du: " Daniel Vetter
2020-02-19 10:30   ` Geert Uytterhoeven
2020-02-19 10:56     ` Daniel Vetter
2020-02-19 11:10       ` Geert Uytterhoeven
2020-02-19 12:17         ` Laurent Pinchart
2020-02-19 12:40           ` Daniel Vetter
2020-02-19 13:53   ` Laurent Pinchart
2020-02-19 14:29     ` Daniel Vetter
2020-02-19 10:21 ` [PATCH 38/52] drm/rockchip: " Daniel Vetter
2020-02-19 10:21 ` [PATCH 39/52] drm/stm: " Daniel Vetter
2020-02-20 14:18   ` Philippe CORNU
2020-02-20 16:12     ` Daniel Vetter
2020-02-19 10:21 ` [PATCH 40/52] drm/shmob: " Daniel Vetter
2020-02-19 13:57   ` Laurent Pinchart
2020-02-19 10:21 ` [PATCH 41/52] drm/mtk: " Daniel Vetter
2020-02-19 10:21 ` [PATCH 42/52] drm/tidss: " Daniel Vetter
2020-02-19 10:21 ` [PATCH 43/52] drm/gm12u320: More drmm_ Daniel Vetter
2020-02-19 10:21 ` [PATCH 44/52] drm/gm12u320: Use devm_drm_dev_init Daniel Vetter
2020-02-19 10:21 ` [PATCH 45/52] drm/gm12u320: Use helpers for shutdown/suspend/resume Daniel Vetter
2020-02-19 10:21 ` [PATCH 46/52] drm/gm12u320: Simplify upload work Daniel Vetter
2020-02-19 10:21 ` [PATCH 47/52] drm/repaper: Drop explicit drm_mode_config_cleanup call Daniel Vetter
2020-02-20 16:21   ` Noralf Trønnes
2020-02-19 10:21 ` [PATCH 48/52] drm/mipi-dbi: Move drm_mode_config_init into mipi library Daniel Vetter
2020-02-20 16:22   ` Noralf Trønnes
2020-02-19 10:21 ` [PATCH 49/52] drm/mipi-dbi: Drop explicit drm_mode_config_cleanup call Daniel Vetter
2020-02-20 16:22   ` Noralf Trønnes
2020-02-19 10:21 ` [PATCH 50/52] drm/udl: " Daniel Vetter
2020-02-19 10:21 ` [PATCH 51/52] drm/udl: drop drm_driver.release hook Daniel Vetter
2020-02-19 10:21 ` [PATCH 52/52] drm: Add docs for managed resources Daniel Vetter
2020-02-19 15:08   ` Laurent Pinchart
2020-02-19 15:40     ` Daniel Vetter
2020-02-21 20:23   ` Sam Ravnborg
2020-02-21 21:13     ` Sam Ravnborg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200219164634.GB5070@pendragon.ideasonboard.com \
    --to=laurent.pinchart@ideasonboard.com \
    --cc=daniel.vetter@ffwll.ch \
    --cc=daniel.vetter@intel.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=emil.l.velikov@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=rafael@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).