dri-devel.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
* [PATCH V3 00/15] Remove duplicated kmap code
@ 2020-05-07 14:59 ira.weiny
  2020-05-07 14:59 ` [PATCH V3 01/15] arch/kmap: Remove BUG_ON() ira.weiny
                   ` (14 more replies)
  0 siblings, 15 replies; 60+ messages in thread
From: ira.weiny @ 2020-05-07 14:59 UTC (permalink / raw)
  To: linux-kernel, Andrew Morton
  Cc: Peter Zijlstra, Dave Hansen, dri-devel, James E.J. Bottomley,
	Max Filippov, Paul Mackerras, H. Peter Anvin, sparclinux,
	Ira Weiny, Thomas Gleixner, Helge Deller, x86, linux-csky,
	Christoph Hellwig, Ingo Molnar, linux-snps-arc, linux-xtensa,
	Borislav Petkov, Al Viro, Andy Lutomirski, Dan Williams,
	linux-arm-kernel, Chris Zankel, Thomas Bogendoerfer,
	linux-parisc, linux-mips, Christian Koenig, linuxppc-dev,
	David S. Miller

From: Ira Weiny <ira.weiny@intel.com>

The kmap infrastructure has been copied almost verbatim to every architecture.
This series consolidates obvious duplicated code by defining core functions
which call into the architectures only when needed.

Some of the k[un]map_atomic() implementations have some similarities but the
similarities were not sufficient to warrant further changes.

In addition we remove a duplicate implementation of kmap() in DRM.

Testing was done by 0day to cover all the architectures I can't readily
build/test.

---
Changes from V2:
	Collect review/acks
	Add kmap_prot consolidation patch from Christoph
	Add 3 suggested patches from Al Viro
	Fix include for microblaze
	Fix static inline for microblaze

Changes from V1:
	Fix bisect-ability
	Update commit message and fix line lengths
	Remove unneded kunmap_atomic_high() declarations
	Remove unneded kmap_atomic_high() declarations
	collect reviews
	rebase to 5.7-rc4

Changes from V0:
	Define kmap_flush_tlb() and make kmap() truely arch independent.
	Redefine the k[un]map_atomic_* code to call into the architectures for
		high mem pages
	Ensure all architectures define kmap_prot, use it appropriately, and
		define kmap_atomic_prot()
	Remove drm implementation of kmap_atomic()


Ira Weiny (15):
  arch/kmap: Remove BUG_ON()
  arch/xtensa: Move kmap build bug out of the way
  arch/kmap: Remove redundant arch specific kmaps
  arch/kunmap: Remove duplicate kunmap implementations
  {x86,powerpc,microblaze}/kmap: Move preempt disable
  arch/kmap_atomic: Consolidate duplicate code
  arch/kunmap_atomic: Consolidate duplicate code
  arch/kmap: Ensure kmap_prot visibility
  arch/kmap: Don't hard code kmap_prot values
  arch/kmap: Define kmap_atomic_prot() for all arch's
  drm: Remove drm specific kmap_atomic code
  kmap: Remove kmap_atomic_to_page()
  parisc/kmap: Remove duplicate kmap code
  sparc: Remove unnecessary includes
  kmap: Consolidate kmap_prot definitions

 arch/arc/include/asm/highmem.h        | 18 -------
 arch/arc/mm/highmem.c                 | 28 ++--------
 arch/arm/include/asm/highmem.h        |  9 ----
 arch/arm/mm/highmem.c                 | 35 ++-----------
 arch/csky/include/asm/highmem.h       | 12 +----
 arch/csky/mm/highmem.c                | 56 ++++----------------
 arch/microblaze/include/asm/highmem.h | 27 ----------
 arch/microblaze/mm/highmem.c          | 16 ++----
 arch/microblaze/mm/init.c             |  3 --
 arch/mips/include/asm/highmem.h       | 11 +---
 arch/mips/mm/cache.c                  |  6 +--
 arch/mips/mm/highmem.c                | 49 +++---------------
 arch/nds32/include/asm/highmem.h      |  9 ----
 arch/nds32/mm/highmem.c               | 39 ++------------
 arch/parisc/include/asm/cacheflush.h  | 30 +----------
 arch/powerpc/include/asm/highmem.h    | 28 ----------
 arch/powerpc/mm/highmem.c             | 21 ++------
 arch/powerpc/mm/mem.c                 |  3 --
 arch/sparc/include/asm/highmem.h      | 25 +--------
 arch/sparc/mm/highmem.c               | 20 ++------
 arch/sparc/mm/io-unit.c               |  1 -
 arch/sparc/mm/iommu.c                 |  1 -
 arch/x86/include/asm/fixmap.h         |  1 -
 arch/x86/include/asm/highmem.h        |  9 ----
 arch/x86/mm/highmem_32.c              | 50 ++----------------
 arch/xtensa/include/asm/highmem.h     | 27 ----------
 arch/xtensa/mm/highmem.c              | 22 ++++----
 drivers/gpu/drm/ttm/ttm_bo_util.c     | 56 ++------------------
 drivers/gpu/drm/vmwgfx/vmwgfx_blit.c  | 16 +++---
 include/drm/ttm/ttm_bo_api.h          |  4 --
 include/linux/highmem.h               | 74 ++++++++++++++++++++++++---
 31 files changed, 150 insertions(+), 556 deletions(-)

-- 
2.25.1

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply	[flat|nested] 60+ messages in thread

end of thread, other threads:[~2020-06-05  7:19 UTC | newest]

Thread overview: 60+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-07 14:59 [PATCH V3 00/15] Remove duplicated kmap code ira.weiny
2020-05-07 14:59 ` [PATCH V3 01/15] arch/kmap: Remove BUG_ON() ira.weiny
2020-05-07 14:59 ` [PATCH V3 02/15] arch/xtensa: Move kmap build bug out of the way ira.weiny
2020-05-07 14:59 ` [PATCH V3 03/15] arch/kmap: Remove redundant arch specific kmaps ira.weiny
2020-05-07 14:59 ` [PATCH V3 04/15] arch/kunmap: Remove duplicate kunmap implementations ira.weiny
2020-05-07 14:59 ` [PATCH V3 05/15] {x86,powerpc,microblaze}/kmap: Move preempt disable ira.weiny
2020-05-07 14:59 ` [PATCH V3 06/15] arch/kmap_atomic: Consolidate duplicate code ira.weiny
2020-05-07 14:59 ` [PATCH V3 07/15] arch/kunmap_atomic: " ira.weiny
     [not found]   ` <20200516223306.GA161252@roeck-us.net>
2020-05-18  3:49     ` Ira Weiny
2020-05-18  4:29       ` Guenter Roeck
2020-05-18 18:11         ` Ira Weiny
2020-05-19  0:03         ` Ira Weiny
2020-05-19  2:50           ` Guenter Roeck
2020-05-19 16:29             ` Ira Weiny
2020-05-18 16:11       ` Guenter Roeck
2020-05-18 18:48   ` [PATCH] arch/{mips, sparc, microblaze, powerpc}: Don't enable pagefault/preempt twice ira.weiny
2020-05-19 16:54     ` [PATCH] arch/{mips,sparc,microblaze,powerpc}: " Guenter Roeck
2020-05-19 18:40       ` Ira Weiny
2020-05-19 19:42         ` Guenter Roeck
2020-05-20  5:02           ` Ira Weiny
2020-05-20  5:13           ` Ira Weiny
2020-05-21 16:05             ` Guenter Roeck
2020-05-21 17:42               ` Ira Weiny
2020-05-21 22:27                 ` Guenter Roeck
2020-05-21 22:36                   ` Weiny, Ira
2020-06-03 20:57                 ` Andrew Morton
2020-06-03 21:14                   ` Ira Weiny
2020-06-03 23:44                     ` Guenter Roeck
2020-06-04  6:18                       ` Mike Rapoport
2020-06-04  6:43                         ` Ira Weiny
2020-06-04  6:22                       ` Ira Weiny
2020-06-04  6:37                         ` Mike Rapoport
2020-06-04  6:44                           ` Ira Weiny
2020-06-04  9:38                         ` Guenter Roeck
2020-06-04  9:41                       ` Mike Rapoport
2020-06-04 20:51                         ` Ira Weiny
2020-05-21 15:14           ` Ira Weiny
2020-05-21 17:27       ` Al Viro
2020-05-21 22:20         ` Guenter Roeck
2020-05-21 22:46           ` Al Viro
2020-05-22  0:46             ` Al Viro
2020-05-22  1:11               ` Guenter Roeck
2020-05-22  1:29                 ` Al Viro
2020-05-22  1:35                   ` Al Viro
2020-05-22  2:28                     ` Guenter Roeck
2020-05-07 14:59 ` [PATCH V3 08/15] arch/kmap: Ensure kmap_prot visibility ira.weiny
2020-05-07 14:59 ` [PATCH V3 09/15] arch/kmap: Don't hard code kmap_prot values ira.weiny
2020-05-07 14:59 ` [PATCH V3 10/15] arch/kmap: Define kmap_atomic_prot() for all arch's ira.weiny
2020-05-17 17:37   ` Guenter Roeck
2020-05-18 18:17     ` Ira Weiny
2020-05-07 14:59 ` [PATCH V3 11/15] drm: Remove drm specific kmap_atomic code ira.weiny
2020-05-07 15:00 ` [PATCH V3 12/15] kmap: Remove kmap_atomic_to_page() ira.weiny
2020-05-07 15:00 ` [PATCH V3 13/15] parisc/kmap: Remove duplicate kmap code ira.weiny
2020-05-07 20:52   ` Andrew Morton
2020-05-07 22:50     ` Ira Weiny
2020-05-07 15:00 ` [PATCH V3 14/15] sparc: Remove unnecessary includes ira.weiny
2020-05-07 15:00 ` [PATCH V3 15/15] kmap: Consolidate kmap_prot definitions ira.weiny
2020-05-07 20:53   ` Andrew Morton
2020-05-07 22:51     ` Ira Weiny
2020-05-07 22:52   ` [PATCH V3.1] " ira.weiny

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).