dri-devel.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
From: Cai Huoqing <caihuoqing@baidu.com>
To: Alex Deucher <alexdeucher@gmail.com>
Cc: <alexander.deucher@amd.com>, <christian.koenig@amd.com>,
	<Xinhui.Pan@amd.com>, <airlied@linux.ie>, <daniel@ffwll.ch>,
	<amd-gfx@lists.freedesktop.org>,
	<dri-devel@lists.freedesktop.org>
Subject: Re: [PATCH] drm/radeon: Make use of the helper macro SET_RUNTIME_PM_OPS()
Date: Mon, 30 Aug 2021 20:44:44 +0800	[thread overview]
Message-ID: <20210830124444.GA173@LAPTOP-UKSR4ENP.internal.baidu.com> (raw)
In-Reply-To: <CADnq5_Oxs=BF+0v0-ZYQGVoBt-eE8zNXRcG4wWEP=1Wc=imPOw@mail.gmail.com>

On 30 Aug 21 08:21:52, Alex Deucher wrote:
> On Sat, Aug 28, 2021 at 4:51 AM Cai Huoqing <caihuoqing@baidu.com> wrote:
> >
> > Use the helper macro SET_RUNTIME_PM_OPS() instead of the verbose
> > operators ".runtime_suspend/.runtime_resume/.runtime_idle", because
> > the SET_RUNTIME_PM_OPS() is a nice helper macro that could be brought
> > in to make code a little clearer, a little more concise.
> 
> I don't personally think it really helps readability.  Just seems to
> be code churn.
> 
> Alex
>
agree, just code churn, the macro seems to do it.

Cai
> 
> >
> > Signed-off-by: Cai Huoqing <caihuoqing@baidu.com>
> > ---
> >  drivers/gpu/drm/radeon/radeon_drv.c | 5 ++---
> >  1 file changed, 2 insertions(+), 3 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/radeon/radeon_drv.c b/drivers/gpu/drm/radeon/radeon_drv.c
> > index b74cebca1f89..c2eb725e87f6 100644
> > --- a/drivers/gpu/drm/radeon/radeon_drv.c
> > +++ b/drivers/gpu/drm/radeon/radeon_drv.c
> > @@ -529,15 +529,14 @@ static long radeon_kms_compat_ioctl(struct file *filp, unsigned int cmd, unsigne
> >  #endif
> >
> >  static const struct dev_pm_ops radeon_pm_ops = {
> > +       SET_RUNTIME_PM_OPS(radeon_pmops_runtime_suspend,
> > +                          radeon_pmops_runtime_resume, radeon_pmops_runtime_idle)
> >         .suspend = radeon_pmops_suspend,
> >         .resume = radeon_pmops_resume,
> >         .freeze = radeon_pmops_freeze,
> >         .thaw = radeon_pmops_thaw,
> >         .poweroff = radeon_pmops_freeze,
> >         .restore = radeon_pmops_resume,
> > -       .runtime_suspend = radeon_pmops_runtime_suspend,
> > -       .runtime_resume = radeon_pmops_runtime_resume,
> > -       .runtime_idle = radeon_pmops_runtime_idle,
> >  };
> >
> >  static const struct file_operations radeon_driver_kms_fops = {
> > --
> > 2.25.1
> >

  reply	other threads:[~2021-08-30 12:44 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-28  8:50 [PATCH] drm/radeon: Make use of the helper macro SET_RUNTIME_PM_OPS() Cai Huoqing
2021-08-30 12:21 ` Alex Deucher
2021-08-30 12:44   ` Cai Huoqing [this message]
2021-08-30 12:51 ` Christian König

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210830124444.GA173@LAPTOP-UKSR4ENP.internal.baidu.com \
    --to=caihuoqing@baidu.com \
    --cc=Xinhui.Pan@amd.com \
    --cc=airlied@linux.ie \
    --cc=alexander.deucher@amd.com \
    --cc=alexdeucher@gmail.com \
    --cc=amd-gfx@lists.freedesktop.org \
    --cc=christian.koenig@amd.com \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).