dri-devel.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
 messages from 2023-06-30 20:42:00 to 2023-07-03 17:19:03 UTC [more...]

[PATCH v7 0/8] PCI/VGA: Introduce is_boot_device function callback to vga_client_register
 2023-07-03 17:18 UTC  (9+ messages)
` [PATCH v7 2/8] PCI/VGA: Deal only with VGA class devices

[PATCH 00/29] use refcount+RCU method to implement lockless slab shrink
 2023-07-03 16:39 UTC  (5+ messages)
` [PATCH 24/29] mm: vmscan: make global slab shrink lockless

[PATCH] dt-bindings: cleanup DTS example whitespaces
 2023-07-03 16:37 UTC  (6+ messages)

[PATCH v4 0/6] drm: Add support for atomic async page-flip
 2023-07-03 16:32 UTC  (9+ messages)
` [PATCH v4 1/6] drm: allow DRM_MODE_PAGE_FLIP_ASYNC for atomic commits
` [PATCH v4 2/6] drm: introduce DRM_CAP_ATOMIC_ASYNC_PAGE_FLIP
` [PATCH v4 3/6] drm: introduce drm_mode_config.atomic_async_page_flip_not_supported
` [PATCH v4 4/6] amd/display: indicate support for atomic async page-flips on DC
` [PATCH v4 5/6] drm: Refuse to async flip with atomic prop changes
` [PATCH v4 6/6] drm/doc: Define KMS atomic state set

[PATCH v4 00/19] drm/msm/dpu: another catalog rework
 2023-07-03 16:14 UTC  (23+ messages)
` [PATCH v4 02/19] drm/msm/dpu: always use MSM_DP/DSI_CONTROLLER_n
` [PATCH v4 03/19] drm/msm/dpu: simplify peer LM handling
` [PATCH v4 04/19] drm/msm/dpu: drop dpu_mdss_cfg::mdp_count field
` [PATCH v4 05/19] drm/msm/dpu: drop enum dpu_mdp and MDP_TOP value
` [PATCH v4 06/19] drm/msm/dpu: expand .clk_ctrls definitions
` [PATCH v4 07/19] drm/msm/dpu: drop zero features from dpu_mdp_cfg data
` [PATCH v4 08/19] drm/msm/dpu: drop zero features from dpu_ctl_cfg data
` [PATCH v4 09/19] drm/msm/dpu: correct indentation for CTL definitions
` [PATCH v4 10/19] drm/msm/dpu: inline SSPP_BLK macros
` [PATCH v4 11/19] drm/msm/dpu: inline DSPP_BLK macros

[PATCH v5 1/1] drm/doc: Document DRM device reset expectations
 2023-07-03 15:00 UTC  (8+ messages)

[PATCH] staging: fbtft: ili9341: use macro FBTFT_REGISTER_SPI_DRIVER
 2023-07-03 13:25 UTC  (4+ messages)

[PATCH v3 0/4] Fix up the boe-tv101wum-nl6 panel driver
 2023-07-03 13:21 UTC  (5+ messages)
` [PATCH v3 1/4] drm/panel: boe-tv101wum-nl6: Drop macros and open code sequences
` [PATCH v3 2/4] drm/panel: boe-tv101wum-nl6: Drop surplus prepare tracking
` [PATCH v3 3/4] drm/panel: ili9882t: Break out as separate driver
` [PATCH v3 4/4] drm/panel: ili9882t: Break out function for switching page

[PATCH] drm/amdgpu: avoid integer overflow warning in amdgpu_device_resize_fb_bar()
 2023-07-03 12:35 UTC 

[PATCH] habanalabs/gaudi: Add MODULE_FIRMWARE macros
 2023-07-03 12:31 UTC  (2+ messages)

[PATCH] accel: make accel_class a static const structure
 2023-07-03 12:27 UTC  (3+ messages)

[PATCH v2 00/24] use vmalloc_array and vcalloc
 2023-07-03 12:23 UTC  (5+ messages)
` [PATCH v2 03/24] drm/gud: "
` [PATCH v2 15/24] habanalabs: "

[PATCH v2] drm/i915: Refactor PAT/cache handling
 2023-07-03 11:52 UTC  (2+ messages)

[PATCH RFC v4 0/7] Support for Solid Fill Planes
 2023-07-03 11:49 UTC  (20+ messages)
` [PATCH RFC v4 2/7] drm: Introduce pixel_source DRM plane property
` [PATCH RFC v4 4/7] drm/atomic: Loosen FB atomic checks
` [PATCH RFC v4 5/7] drm/msm/dpu: Add solid fill and pixel source properties
` [PATCH RFC v4 6/7] drm/msm/dpu: Allow NULL FBs in atomic commit
` [PATCH RFC v4 7/7] drm/msm/dpu: Use DRM solid_fill property

[PATCH] dma-buf: keep the signaling time of merged fences v3
 2023-07-03 11:49 UTC  (3+ messages)

[PATCH v2 00/15] drm/msm/hdmi & phy: use generic PHY framework
 2023-07-03 11:35 UTC  (3+ messages)
` [PATCH v2 08/15] drm/msm/hdmi: move the alt_iface clock to the hpd list

[RFC v3 0/3] Introduce KUnit tests for TTM subsystem
 2023-07-03 11:21 UTC  (5+ messages)
` [RFC v3 1/3] drm/ttm: Introduce KUnit tests
` [RFC v3 2/3] drm/ttm/tests: Add tests for ttm_device
` [RFC v3 3/3] drm/ttm/tests: Add tests for ttm_pool

[PATCH 0/1] Backlight driver for the Apple Studio Display
 2023-07-03 10:36 UTC  (6+ messages)
` [PATCH 1/1] backlight: apple_bl_usb: Add Apple Studio Display support

[RFC PATCH v2 0/4] drm/mgag200: Use DMA to copy the framebuffer to the VRAM
 2023-07-03 10:22 UTC  (6+ messages)
` [PATCH v2 4/4] "

[PATCH v10 rebased on v6.4 00/25] DEPT(Dependency Tracker)
 2023-07-03  9:47 UTC  (26+ messages)
` [PATCH v10 rebased on v6.4 01/25] llist: Move llist_{head, node} definition to types.h
` [PATCH v10 rebased on v6.4 02/25] dept: Implement Dept(Dependency Tracker)
` [PATCH v10 rebased on v6.4 03/25] dept: Add single event dependency tracker APIs
` [PATCH v10 rebased on v6.4 04/25] dept: Add lock "
` [PATCH v10 rebased on v6.4 05/25] dept: Tie to Lockdep and IRQ tracing
` [PATCH v10 rebased on v6.4 06/25] dept: Add proc knobs to show stats and dependency graph
` [PATCH v10 rebased on v6.4 07/25] dept: Apply sdt_might_sleep_{start, end}() to wait_for_completion()/complete()
` [PATCH v10 rebased on v6.4 08/25] dept: Apply sdt_might_sleep_{start, end}() to PG_{locked, writeback} wait
` [PATCH v10 rebased on v6.4 09/25] dept: Apply sdt_might_sleep_{start, end}() to swait
` [PATCH v10 rebased on v6.4 10/25] dept: Apply sdt_might_sleep_{start, end}() to waitqueue wait
` [PATCH v10 rebased on v6.4 11/25] dept: Apply sdt_might_sleep_{start, end}() to hashed-waitqueue wait
` [PATCH v10 rebased on v6.4 12/25] dept: Distinguish each syscall context from another
` [PATCH v10 rebased on v6.4 13/25] dept: Distinguish each work "
` [PATCH v10 rebased on v6.4 14/25] dept: Add a mechanism to refill the internal memory pools on running out
` [PATCH v10 rebased on v6.4 15/25] locking/lockdep, cpu/hotplus: Use a weaker annotation in AP thread
` [PATCH v10 rebased on v6.4 16/25] dept: Apply sdt_might_sleep_{start, end}() to dma fence wait
` [PATCH v10 rebased on v6.4 17/25] dept: Track timeout waits separately with a new Kconfig
` [PATCH v10 rebased on v6.4 18/25] dept: Apply timeout consideration to wait_for_completion()/complete()
` [PATCH v10 rebased on v6.4 19/25] dept: Apply timeout consideration to swait
` [PATCH v10 rebased on v6.4 20/25] dept: Apply timeout consideration to waitqueue wait
` [PATCH v10 rebased on v6.4 21/25] dept: Apply timeout consideration to hashed-waitqueue wait
` [PATCH v10 rebased on v6.4 22/25] dept: Apply timeout consideration to dma fence wait
` [PATCH v10 rebased on v6.4 23/25] dept: Record the latest one out of consecutive waits of the same class
` [PATCH v10 rebased on v6.4 24/25] dept: Make Dept able to work with an external wgen
` [PATCH v10 rebased on v6.4 25/25] dept: Track the potential waits of PG_{locked, writeback}

[PATCH v3 0/3] Allow disabling all native fbdev drivers and only keeping DRM emulation
 2023-07-03  9:47 UTC  (6+ messages)
` [PATCH v3 1/3] drm: Improve Kconfig symbol prompt and help texts
` [PATCH v3 2/3] fbdev: Split frame buffer support in FB and FB_CORE symbols
` [PATCH v3 3/3] drm: Make FB_CORE to be selected if DRM fbdev emulation is enabled

[PATCH] drm: bridge: samsung-dsim: Drain command transfer FIFO before transfer
 2023-07-03  8:38 UTC  (3+ messages)

[PATCH v2 0/2] Allow disabling all native fbdev drivers and only keeping DRM emulation
 2023-07-03  8:49 UTC  (14+ messages)
` [PATCH v2 1/2] fbdev: Split frame buffer support in FB and FB_CORE symbols
` [PATCH v2 2/2] drm: Make fbdev emulation select FB_CORE instead of depends on FB

[PATCH 0/2] Allow disabling all native fbdev drivers and only keeping DRM emulation
 2023-07-03  8:43 UTC  (9+ messages)

[PATCH 1/2] accel/ivpu: Fix VPU register access in irq disable
 2023-07-03  8:07 UTC  (2+ messages)
` [PATCH 2/2] accel/ivpu: Clear specific interrupt status bits on C0

[PATCH v6 0/9] drm/meson: add support for MIPI DSI Display
 2023-07-03  7:24 UTC  (4+ messages)
` [PATCH v6 5/9] drm/meson: gate px_clk when setting rate

[PATCH] drm/exynos: fix a possible null-pointer dereference due to data race in exynos_drm_crtc_atomic_disable()
 2023-07-03  3:00 UTC  (3+ messages)

[PATCH 00/13] drm/msm: move KMS code from msm_drv.c
 2023-07-03  0:37 UTC  (14+ messages)
` [PATCH 01/13] drm/msm/dsi: switch to devm_drm_bridge_add()
` [PATCH 02/13] drm/msm/hdmi: "
` [PATCH 03/13] drm/msm/dp: move pdev from struct dp_display_private to struct msm_dp
` [PATCH 04/13] drm/msm/dp: switch to devm_drm_bridge_add()
` [PATCH 05/13] drm/msm: remove msm_drm_private::bridges field
` [PATCH 06/13] drm/msm: drop pm ops from the headless msm driver
` [PATCH 07/13] drm/msm: rename msm_pm_prepare/complete to note the KMS nature
` [PATCH 08/13] drm/msm: remove shutdown callback from msm_platform_driver
` [PATCH 09/13] drm/msm: rename msm_drv_shutdown() to msm_kms_shutdown()
` [PATCH 10/13] drm/msm: switch to drmm_mode_config_init()
` [PATCH 11/13] drm/msm: only register 'kms' debug file if KMS is used
` [PATCH 12/13] drm/msm: make fb debugfs file available only in KMS case
` [PATCH 13/13] drm/msm: carve out KMS code from msm_drv.c

[PATCH v3 0/4] drm/msm: move resource allocation to the _probe function
 2023-07-03  0:30 UTC  (5+ messages)
` [PATCH v3 1/4] drm/msm: allow passing struct msm_kms to msm_drv_probe()
` [PATCH v3 2/4] drm/msm/dpu: move resource allocation to the _probe function
` [PATCH v3 3/4] drm/msm/mdp4: "
` [PATCH v3 4/4] drm/msm/mdp5: "

[PATCH] Revert "drm/amd/display: Program OTG vtotal min/max selectors unconditionally for DCN1+"
 2023-07-02 22:29 UTC  (2+ messages)

[PATCH v4] drm/vkms: Add support to 1D gamma LUT
 2023-07-02 21:37 UTC  (6+ messages)

[PATCH v2 0/6] PCI/VGA: Improve the default VGA device selection
 2023-07-02 18:27 UTC  (7+ messages)
` [PATCH v2 1/6] video/aperture: Add a helper to detect if an aperture contains firmware FB
` [PATCH v2 2/6] PCI/VGA: Improve the default VGA device selection
` [PATCH v2 3/6] drm/amdgpu: Implement the is_boot_device callback function
` [PATCH v2 4/6] drm/radeon: "
` [PATCH v2 5/6] drm/i915: "
` [PATCH v2 6/6] drm/ast: Register as a vga client to vgaarb by calling vga_client_register()

[PATCH v2] drm/msm/adreno: Assign revn to A635
 2023-07-02 14:56 UTC  (8+ messages)

[PATCH] drm/msm/adreno: warn if GPU revision is not known yet
 2023-07-01 23:19 UTC  (2+ messages)

[PATCH] drm/msm/a690: Remove revn and name
 2023-07-01 16:20 UTC 

[Bug 217621] New: AMDGPU - Internal 4K display used with 1920x1080 leads to screen flickering and distortion, regression from commit edcfed8671ee57bb599184f2e12a1b3e11b32306
 2023-07-01 16:08 UTC  (5+ messages)
` [Bug 217621] "

[drm-intel:drm-intel-next 1/2] htmldocs: Documentation/gpu/rfc/i915_scheduler.rst:138: WARNING: Unknown directive type "c:namespace-push"
 2023-07-01  5:49 UTC 

[Bug 213145] New: AMDGPU resets, timesout and crashes after "*ERROR* Waiting for fences timed out!"
 2023-07-01  5:27 UTC  (3+ messages)
` [Bug 213145] "

[Bug 205089] New: amdgpu : drm:amdgpu_cs_ioctl : Failed to initialize parser -125
 2023-07-01  5:16 UTC  (3+ messages)
` [Bug 205089] "

[PATCH V5 0/9] Enable Wifi RFI interference mitigation feature support
 2023-07-01  1:02 UTC  (9+ messages)
` [PATCH V5 1/9] drivers core: Add support for Wifi band RF mitigations
` [PATCH V5 2/9] driver core: add ACPI based WBRF mechanism introduced by AMD
` [PATCH V5 4/9] wifi: mac80211: Add support for ACPI WBRF

[PATCH v3 0/7] Fix ctx workarounds for non-masked regs
 2023-07-01  0:41 UTC  (2+ messages)

[PATCH 0/6] Add support to print sub block registers in dpu hw catalog
 2023-06-30 23:15 UTC  (3+ messages)

[PATCH 1/2] docs: module: start adding some docs for MODULE_ macros
 2023-06-30 23:09 UTC  (4+ messages)
` [PATCH 2/2] modules/firmware: add a new option to denote a firmware group to choose one

[PATCH 00/15] drm/msm/hdmi: rework and fix the HPD even generation
 2023-06-30 20:55 UTC  (16+ messages)
` [PATCH 01/15] drm/msm/hdmi: move the alt_iface clock to the hpd list
` [PATCH 02/15] drm/msm/hdmi: simplify extp clock handling
` [PATCH 03/15] drm/msm/hdmi: correct indentation of HDMI bridge functions
` [PATCH 04/15] drm/msm/hdmi: switch to atomic_pre_enable/post_disable
` [PATCH 05/15] drm/msm/hdmi: set infoframes on all pre_enable calls
` [PATCH 06/15] drm/msm/hdmi: drop clock frequency assignment
` [PATCH 07/15] drm/msm/hdmi: switch to clk_bulk API
` [PATCH 08/15] drm/msm/hdmi: switch to pm_runtime_resume_and_get()
` [PATCH 09/15] drm/msm/hdmi: add runtime PM calls to DDC transfer function
` [PATCH 10/15] drm/msm/hdmi: implement proper runtime PM handling
` [PATCH 11/15] drm/msm/hdmi: rename hpd_clks to pwr_clks
` [PATCH 12/15] drm/msm/hdmi: expand the HDMI_CFG macro
` [PATCH 13/15] drm/msm/hdmi: drop hpd-gpios support
` [PATCH 14/15] drm/msm/hdmi: ensure that HDMI is one if HPD is requested
` [PATCH 15/15] drm/msm/hdmi: wire in hpd_enable/hpd_disable bridge ops

[PATCH] drm/msm/adreno: Assign revn to A635
 2023-06-30 20:41 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).