driverdev-devel.linuxdriverproject.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/3] staging: rtl8192e: sequence_control union cleanups
@ 2021-02-14 14:03 William Durand
  2021-02-14 14:03 ` [PATCH 1/3] staging: rtl8192e: rename ShortData to short_data in sequence_control union William Durand
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: William Durand @ 2021-02-14 14:03 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

This patchset fixes the checkpatch issues related to the `sequence_control`
union defined in `rtl8192e/rtl819x_BA.h` (avoid camelcase).

William Durand (3):
  staging: rtl8192e: rename ShortData to short_data in sequence_control
    union
  staging: rtl8192e: rename FragNum to frag_num in sequence_control
    union
  staging: rtl8192e: rename SeqNum to seq_num in sequence_control union

 drivers/staging/rtl8192e/rtl819x_BA.h     | 6 +++---
 drivers/staging/rtl8192e/rtl819x_BAProc.c | 4 ++--
 drivers/staging/rtl8192e/rtllib_tx.c      | 2 +-
 3 files changed, 6 insertions(+), 6 deletions(-)

--
2.17.1

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH 1/3] staging: rtl8192e: rename ShortData to short_data in sequence_control union
  2021-02-14 14:03 [PATCH 0/3] staging: rtl8192e: sequence_control union cleanups William Durand
@ 2021-02-14 14:03 ` William Durand
  2021-02-14 14:03 ` [PATCH 2/3] staging: rtl8192e: rename FragNum to frag_num " William Durand
  2021-02-14 14:03 ` [PATCH 3/3] staging: rtl8192e: rename SeqNum to seq_num " William Durand
  2 siblings, 0 replies; 4+ messages in thread
From: William Durand @ 2021-02-14 14:03 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

Fixes a checkpatch CHECK message.

Signed-off-by: William Durand <will+git@drnd.me>
---
 drivers/staging/rtl8192e/rtl819x_BA.h     | 2 +-
 drivers/staging/rtl8192e/rtl819x_BAProc.c | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/rtl8192e/rtl819x_BA.h b/drivers/staging/rtl8192e/rtl819x_BA.h
index 8b6e4c26f0fb..34d66b8f5155 100644
--- a/drivers/staging/rtl8192e/rtl819x_BA.h
+++ b/drivers/staging/rtl8192e/rtl819x_BA.h
@@ -20,7 +20,7 @@
 #define	DELBA_REASON_UNKNOWN_BA	38
 #define	DELBA_REASON_TIMEOUT			39
 union sequence_control {
-	u16 ShortData;
+	u16 short_data;
 	struct {
 		u16	FragNum:4;
 		u16	SeqNum:12;
diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c b/drivers/staging/rtl8192e/rtl819x_BAProc.c
index 2d5e4a0330c6..b3f0f64c7711 100644
--- a/drivers/staging/rtl8192e/rtl819x_BAProc.c
+++ b/drivers/staging/rtl8192e/rtl819x_BAProc.c
@@ -61,7 +61,7 @@ void ResetBaEntry(struct ba_record *pBA)
 	pBA->BaParamSet.shortData	= 0;
 	pBA->BaTimeoutValue		= 0;
 	pBA->DialogToken		= 0;
-	pBA->BaStartSeqCtrl.ShortData	= 0;
+	pBA->BaStartSeqCtrl.short_data	= 0;
 }
 static struct sk_buff *rtllib_ADDBA(struct rtllib_device *ieee, u8 *Dst,
 				    struct ba_record *pBA,
--
2.17.1

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH 2/3] staging: rtl8192e: rename FragNum to frag_num in sequence_control union
  2021-02-14 14:03 [PATCH 0/3] staging: rtl8192e: sequence_control union cleanups William Durand
  2021-02-14 14:03 ` [PATCH 1/3] staging: rtl8192e: rename ShortData to short_data in sequence_control union William Durand
@ 2021-02-14 14:03 ` William Durand
  2021-02-14 14:03 ` [PATCH 3/3] staging: rtl8192e: rename SeqNum to seq_num " William Durand
  2 siblings, 0 replies; 4+ messages in thread
From: William Durand @ 2021-02-14 14:03 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

Fixes a checkpatch CHECK message.

Signed-off-by: William Durand <will+git@drnd.me>
---
 drivers/staging/rtl8192e/rtl819x_BA.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/rtl8192e/rtl819x_BA.h b/drivers/staging/rtl8192e/rtl819x_BA.h
index 34d66b8f5155..3e5bd3fc78ce 100644
--- a/drivers/staging/rtl8192e/rtl819x_BA.h
+++ b/drivers/staging/rtl8192e/rtl819x_BA.h
@@ -22,7 +22,7 @@
 union sequence_control {
 	u16 short_data;
 	struct {
-		u16	FragNum:4;
+		u16	frag_num:4;
 		u16	SeqNum:12;
 	} field;
 };
--
2.17.1

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH 3/3] staging: rtl8192e: rename SeqNum to seq_num in sequence_control union
  2021-02-14 14:03 [PATCH 0/3] staging: rtl8192e: sequence_control union cleanups William Durand
  2021-02-14 14:03 ` [PATCH 1/3] staging: rtl8192e: rename ShortData to short_data in sequence_control union William Durand
  2021-02-14 14:03 ` [PATCH 2/3] staging: rtl8192e: rename FragNum to frag_num " William Durand
@ 2021-02-14 14:03 ` William Durand
  2 siblings, 0 replies; 4+ messages in thread
From: William Durand @ 2021-02-14 14:03 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

Fixes a checkpatch CHECK message.

Signed-off-by: William Durand <will+git@drnd.me>
---
 drivers/staging/rtl8192e/rtl819x_BA.h     | 2 +-
 drivers/staging/rtl8192e/rtl819x_BAProc.c | 2 +-
 drivers/staging/rtl8192e/rtllib_tx.c      | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/rtl8192e/rtl819x_BA.h b/drivers/staging/rtl8192e/rtl819x_BA.h
index 3e5bd3fc78ce..b2a784fa051e 100644
--- a/drivers/staging/rtl8192e/rtl819x_BA.h
+++ b/drivers/staging/rtl8192e/rtl819x_BA.h
@@ -23,7 +23,7 @@ union sequence_control {
 	u16 short_data;
 	struct {
 		u16	frag_num:4;
-		u16	SeqNum:12;
+		u16	seq_num:12;
 	} field;
 };

diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c b/drivers/staging/rtl8192e/rtl819x_BAProc.c
index b3f0f64c7711..07dade37d4eb 100644
--- a/drivers/staging/rtl8192e/rtl819x_BAProc.c
+++ b/drivers/staging/rtl8192e/rtl819x_BAProc.c
@@ -489,7 +489,7 @@ void TsInitAddBA(struct rtllib_device *ieee, struct tx_ts_record *pTS,
 			 pTS->TsCommonInfo.TSpec.f.TSInfo.field.ucTSID;
 	pBA->BaParamSet.field.BufferSize = 32;
 	pBA->BaTimeoutValue = 0;
-	pBA->BaStartSeqCtrl.field.SeqNum = (pTS->TxCurSeq + 3) % 4096;
+	pBA->BaStartSeqCtrl.field.seq_num = (pTS->TxCurSeq + 3) % 4096;

 	ActivateBAEntry(ieee, pBA, BA_SETUP_TIMEOUT);

diff --git a/drivers/staging/rtl8192e/rtllib_tx.c b/drivers/staging/rtl8192e/rtllib_tx.c
index 50cf10201fdd..30596b9702c3 100644
--- a/drivers/staging/rtl8192e/rtllib_tx.c
+++ b/drivers/staging/rtl8192e/rtllib_tx.c
@@ -308,7 +308,7 @@ static void rtllib_tx_query_agg_cap(struct rtllib_device *ieee,
 			}
 			goto FORCED_AGG_SETTING;
 		} else if (!pTxTs->bUsingBa) {
-			if (SN_LESS(pTxTs->TxAdmittedBARecord.BaStartSeqCtrl.field.SeqNum,
+			if (SN_LESS(pTxTs->TxAdmittedBARecord.BaStartSeqCtrl.field.seq_num,
 			   (pTxTs->TxCurSeq+1)%4096))
 				pTxTs->bUsingBa = true;
 			else
--
2.17.1

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply related	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-02-17 21:34 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-14 14:03 [PATCH 0/3] staging: rtl8192e: sequence_control union cleanups William Durand
2021-02-14 14:03 ` [PATCH 1/3] staging: rtl8192e: rename ShortData to short_data in sequence_control union William Durand
2021-02-14 14:03 ` [PATCH 2/3] staging: rtl8192e: rename FragNum to frag_num " William Durand
2021-02-14 14:03 ` [PATCH 3/3] staging: rtl8192e: rename SeqNum to seq_num " William Durand

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).