driverdev-devel.linuxdriverproject.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/5] staging: rtl8192e: delba_param_set union cleanups
@ 2021-02-19 16:13 William Durand
  2021-02-19 16:13 ` [PATCH 1/5] staging: rtl8192e: rename charData to char_data in delba_param_set union William Durand
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: William Durand @ 2021-02-19 16:13 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

This patchset fixes the checkpatch issues related to the `delba_param_set`
union defined in `rtl8192e/rtl819x_BA.h` (avoid camelcase).

William Durand (5):
  staging: rtl8192e: rename charData to char_data in delba_param_set union
  staging: rtl8192e: rename shortData to short_data in delba_param_set union
  staging: rtl8192e: rename Reserved to reserved in delba_param_set union
  staging: rtl8192e: rename Initiator to initiator in delba_param_set union
  staging: rtl8192e: rename TID to tid in delba_param_set union

 drivers/staging/rtl8192e/rtl819x_BA.h     | 10 +++++-----
 drivers/staging/rtl8192e/rtl819x_BAProc.c | 14 +++++++-------
 2 files changed, 12 insertions(+), 12 deletions(-)

--
2.30.0

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [PATCH 1/5] staging: rtl8192e: rename charData to char_data in delba_param_set union
  2021-02-19 16:13 [PATCH 0/5] staging: rtl8192e: delba_param_set union cleanups William Durand
@ 2021-02-19 16:13 ` William Durand
  2021-02-19 16:13 ` [PATCH 2/5] staging: rtl8192e: rename shortData to short_data " William Durand
                   ` (3 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: William Durand @ 2021-02-19 16:13 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

Fixes a checkpatch CHECK message.

Signed-off-by: William Durand <will+git@drnd.me>
---
 drivers/staging/rtl8192e/rtl819x_BA.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/rtl8192e/rtl819x_BA.h b/drivers/staging/rtl8192e/rtl819x_BA.h
index 36280c62fa56..de41d2182ff5 100644
--- a/drivers/staging/rtl8192e/rtl819x_BA.h
+++ b/drivers/staging/rtl8192e/rtl819x_BA.h
@@ -39,7 +39,7 @@ union ba_param_set {
 };

 union delba_param_set {
-	u8 charData[2];
+	u8 char_data[2];
 	u16 shortData;
 	struct {
 		u16 Reserved:11;
--
2.30.0

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 2/5] staging: rtl8192e: rename shortData to short_data in delba_param_set union
  2021-02-19 16:13 [PATCH 0/5] staging: rtl8192e: delba_param_set union cleanups William Durand
  2021-02-19 16:13 ` [PATCH 1/5] staging: rtl8192e: rename charData to char_data in delba_param_set union William Durand
@ 2021-02-19 16:13 ` William Durand
  2021-02-19 16:13 ` [PATCH 3/5] staging: rtl8192e: rename Reserved to reserved " William Durand
                   ` (2 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: William Durand @ 2021-02-19 16:13 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

Fixes a checkpatch CHECK message.

Signed-off-by: William Durand <will+git@drnd.me>
---
 drivers/staging/rtl8192e/rtl819x_BA.h     | 2 +-
 drivers/staging/rtl8192e/rtl819x_BAProc.c | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/rtl8192e/rtl819x_BA.h b/drivers/staging/rtl8192e/rtl819x_BA.h
index de41d2182ff5..ae4f117c839b 100644
--- a/drivers/staging/rtl8192e/rtl819x_BA.h
+++ b/drivers/staging/rtl8192e/rtl819x_BA.h
@@ -40,7 +40,7 @@ union ba_param_set {

 union delba_param_set {
 	u8 char_data[2];
-	u16 shortData;
+	u16 short_data;
 	struct {
 		u16 Reserved:11;
 		u16 Initiator:1;
diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c b/drivers/staging/rtl8192e/rtl819x_BAProc.c
index 1f697e87ae8d..46028f74776a 100644
--- a/drivers/staging/rtl8192e/rtl819x_BAProc.c
+++ b/drivers/staging/rtl8192e/rtl819x_BAProc.c
@@ -163,7 +163,7 @@ static struct sk_buff *rtllib_DELBA(struct rtllib_device *ieee, u8 *dst,
 	*tag++ = ACT_DELBA;


-	put_unaligned_le16(DelbaParamSet.shortData, tag);
+	put_unaligned_le16(DelbaParamSet.short_data, tag);
 	tag += 2;

 	put_unaligned_le16(ReasonCode, tag);
--
2.30.0

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 3/5] staging: rtl8192e: rename Reserved to reserved in delba_param_set union
  2021-02-19 16:13 [PATCH 0/5] staging: rtl8192e: delba_param_set union cleanups William Durand
  2021-02-19 16:13 ` [PATCH 1/5] staging: rtl8192e: rename charData to char_data in delba_param_set union William Durand
  2021-02-19 16:13 ` [PATCH 2/5] staging: rtl8192e: rename shortData to short_data " William Durand
@ 2021-02-19 16:13 ` William Durand
  2021-02-19 16:13 ` [PATCH 4/5] staging: rtl8192e: rename Initiator to initiator " William Durand
  2021-02-19 16:14 ` [PATCH 5/5] staging: rtl8192e: rename TID to tid " William Durand
  4 siblings, 0 replies; 6+ messages in thread
From: William Durand @ 2021-02-19 16:13 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

This change uses lowercase for a field name to be more consistent with
the rest of the union.

Signed-off-by: William Durand <will+git@drnd.me>
---
 drivers/staging/rtl8192e/rtl819x_BA.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/rtl8192e/rtl819x_BA.h b/drivers/staging/rtl8192e/rtl819x_BA.h
index ae4f117c839b..a482cb3b081d 100644
--- a/drivers/staging/rtl8192e/rtl819x_BA.h
+++ b/drivers/staging/rtl8192e/rtl819x_BA.h
@@ -42,7 +42,7 @@ union delba_param_set {
 	u8 char_data[2];
 	u16 short_data;
 	struct {
-		u16 Reserved:11;
+		u16 reserved:11;
 		u16 Initiator:1;
 		u16 TID:4;
 	} field;
--
2.30.0

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 4/5] staging: rtl8192e: rename Initiator to initiator in delba_param_set union
  2021-02-19 16:13 [PATCH 0/5] staging: rtl8192e: delba_param_set union cleanups William Durand
                   ` (2 preceding siblings ...)
  2021-02-19 16:13 ` [PATCH 3/5] staging: rtl8192e: rename Reserved to reserved " William Durand
@ 2021-02-19 16:13 ` William Durand
  2021-02-19 16:14 ` [PATCH 5/5] staging: rtl8192e: rename TID to tid " William Durand
  4 siblings, 0 replies; 6+ messages in thread
From: William Durand @ 2021-02-19 16:13 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

Fixes a checkpatch CHECK message.

Signed-off-by: William Durand <will+git@drnd.me>
---
 drivers/staging/rtl8192e/rtl819x_BA.h     | 2 +-
 drivers/staging/rtl8192e/rtl819x_BAProc.c | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/rtl8192e/rtl819x_BA.h b/drivers/staging/rtl8192e/rtl819x_BA.h
index a482cb3b081d..f94ce2d7d166 100644
--- a/drivers/staging/rtl8192e/rtl819x_BA.h
+++ b/drivers/staging/rtl8192e/rtl819x_BA.h
@@ -43,7 +43,7 @@ union delba_param_set {
 	u16 short_data;
 	struct {
 		u16 reserved:11;
-		u16 Initiator:1;
+		u16 initiator:1;
 		u16 TID:4;
 	} field;
 };
diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c b/drivers/staging/rtl8192e/rtl819x_BAProc.c
index 46028f74776a..3594d432b2a2 100644
--- a/drivers/staging/rtl8192e/rtl819x_BAProc.c
+++ b/drivers/staging/rtl8192e/rtl819x_BAProc.c
@@ -141,7 +141,7 @@ static struct sk_buff *rtllib_DELBA(struct rtllib_device *ieee, u8 *dst,

 	memset(&DelbaParamSet, 0, 2);

-	DelbaParamSet.field.Initiator = (TxRxSelect == TX_DIR) ? 1 : 0;
+	DelbaParamSet.field.initiator = (TxRxSelect == TX_DIR) ? 1 : 0;
 	DelbaParamSet.field.TID	= pBA->BaParamSet.field.tid;

 	skb = dev_alloc_skb(len + sizeof(struct rtllib_hdr_3addr));
@@ -440,7 +440,7 @@ int rtllib_rx_DELBA(struct rtllib_device *ieee, struct sk_buff *skb)
 	dst = (u8 *)(&delba->addr2[0]);
 	pDelBaParamSet = (union delba_param_set *)&delba->payload[2];

-	if (pDelBaParamSet->field.Initiator == 1) {
+	if (pDelBaParamSet->field.initiator == 1) {
 		struct rx_ts_record *pRxTs;

 		if (!GetTs(ieee, (struct ts_common_info **)&pRxTs, dst,
--
2.30.0

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 5/5] staging: rtl8192e: rename TID to tid in delba_param_set union
  2021-02-19 16:13 [PATCH 0/5] staging: rtl8192e: delba_param_set union cleanups William Durand
                   ` (3 preceding siblings ...)
  2021-02-19 16:13 ` [PATCH 4/5] staging: rtl8192e: rename Initiator to initiator " William Durand
@ 2021-02-19 16:14 ` William Durand
  4 siblings, 0 replies; 6+ messages in thread
From: William Durand @ 2021-02-19 16:14 UTC (permalink / raw)
  To: Greg Kroah-Hartman; +Cc: devel, linux-kernel

This change uses lowercase for a field name to be more consistent with
the rest of the union.

Signed-off-by: William Durand <will+git@drnd.me>
---
 drivers/staging/rtl8192e/rtl819x_BA.h     | 2 +-
 drivers/staging/rtl8192e/rtl819x_BAProc.c | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/staging/rtl8192e/rtl819x_BA.h b/drivers/staging/rtl8192e/rtl819x_BA.h
index f94ce2d7d166..67574e26cdfc 100644
--- a/drivers/staging/rtl8192e/rtl819x_BA.h
+++ b/drivers/staging/rtl8192e/rtl819x_BA.h
@@ -44,7 +44,7 @@ union delba_param_set {
 	struct {
 		u16 reserved:11;
 		u16 initiator:1;
-		u16 TID:4;
+		u16 tid:4;
 	} field;
 };

diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c b/drivers/staging/rtl8192e/rtl819x_BAProc.c
index 3594d432b2a2..3455fd210372 100644
--- a/drivers/staging/rtl8192e/rtl819x_BAProc.c
+++ b/drivers/staging/rtl8192e/rtl819x_BAProc.c
@@ -142,7 +142,7 @@ static struct sk_buff *rtllib_DELBA(struct rtllib_device *ieee, u8 *dst,
 	memset(&DelbaParamSet, 0, 2);

 	DelbaParamSet.field.initiator = (TxRxSelect == TX_DIR) ? 1 : 0;
-	DelbaParamSet.field.TID	= pBA->BaParamSet.field.tid;
+	DelbaParamSet.field.tid	= pBA->BaParamSet.field.tid;

 	skb = dev_alloc_skb(len + sizeof(struct rtllib_hdr_3addr));
 	if (!skb)
@@ -444,11 +444,11 @@ int rtllib_rx_DELBA(struct rtllib_device *ieee, struct sk_buff *skb)
 		struct rx_ts_record *pRxTs;

 		if (!GetTs(ieee, (struct ts_common_info **)&pRxTs, dst,
-		    (u8)pDelBaParamSet->field.TID, RX_DIR, false)) {
+		    (u8)pDelBaParamSet->field.tid, RX_DIR, false)) {
 			netdev_warn(ieee->dev,
 				    "%s(): can't get TS for RXTS. dst:%pM TID:%d\n",
 				    __func__, dst,
-				    (u8)pDelBaParamSet->field.TID);
+				    (u8)pDelBaParamSet->field.tid);
 			return -1;
 		}

@@ -457,7 +457,7 @@ int rtllib_rx_DELBA(struct rtllib_device *ieee, struct sk_buff *skb)
 		struct tx_ts_record *pTxTs;

 		if (!GetTs(ieee, (struct ts_common_info **)&pTxTs, dst,
-			   (u8)pDelBaParamSet->field.TID, TX_DIR, false)) {
+			   (u8)pDelBaParamSet->field.tid, TX_DIR, false)) {
 			netdev_warn(ieee->dev, "%s(): can't get TS for TXTS\n",
 				    __func__);
 			return -1;
--
2.30.0

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

^ permalink raw reply related	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2021-02-19 21:17 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-19 16:13 [PATCH 0/5] staging: rtl8192e: delba_param_set union cleanups William Durand
2021-02-19 16:13 ` [PATCH 1/5] staging: rtl8192e: rename charData to char_data in delba_param_set union William Durand
2021-02-19 16:13 ` [PATCH 2/5] staging: rtl8192e: rename shortData to short_data " William Durand
2021-02-19 16:13 ` [PATCH 3/5] staging: rtl8192e: rename Reserved to reserved " William Durand
2021-02-19 16:13 ` [PATCH 4/5] staging: rtl8192e: rename Initiator to initiator " William Durand
2021-02-19 16:14 ` [PATCH 5/5] staging: rtl8192e: rename TID to tid " William Durand

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).