All of lore.kernel.org
 help / color / mirror / Atom feed
From: Krish Sadhukhan <krish.sadhukhan@oracle.com>
To: Like Xu <like.xu@linux.intel.com>, kvm@vger.kernel.org
Cc: pbonzini@redhat.com, vkuznets@redhat.com, qemu-devel@nongnu.org,
	sean.j.christopherson@intel.com, jmattson@google.com
Subject: Re: [PATCH 4/5 v4] KVM: VMX: Fill in conforming vmx_x86_ops via macro
Date: Tue, 10 Nov 2020 11:02:15 -0800	[thread overview]
Message-ID: <e9819b87-c4e0-d15b-80b8-637ecb74f1c3@oracle.com> (raw)
In-Reply-To: <0ef40499-77b8-587a-138d-9b612ae9ae8c@linux.intel.com>


On 11/9/20 5:49 PM, Like Xu wrote:
> Hi Krish,
>
> On 2020/11/10 9:23, Krish Sadhukhan wrote:
>> @@ -1192,7 +1192,7 @@ void vmx_set_host_fs_gs(struct vmcs_host_state 
>> *host, u16 fs_sel, u16 gs_sel,
>>       }
>>   }
>>   -void vmx_prepare_switch_to_guest(struct kvm_vcpu *vcpu)
>> +void vmx_prepare_guest_switch(struct kvm_vcpu *vcpu)
>
> What do you think of renaming it to
>
>     void vmx_prepare_switch_for_guest(struct kvm_vcpu *vcpu);


In my opinion, it sounds a bit odd as we usually say, "switch to 
something". :-)

 From that perspective, {svm|vmx}_prepare_switch_to_guest is probably 
the best name to keep.


>
> ?
>
> Thanks,
> Like Xu
>
>>   {
>>       struct vcpu_vmx *vmx = to_vmx(vcpu);
>>       struct vmcs_host_state *host_state;
>>
>> @@ -311,7 +311,7 @@ void vmx_vcpu_load_vmcs(struct kvm_vcpu *vcpu, 
>> int cpu,
>>   int allocate_vpid(void);
>>   void free_vpid(int vpid);
>>   void vmx_set_constant_host_state(struct vcpu_vmx *vmx);
>> -void vmx_prepare_switch_to_guest(struct kvm_vcpu *vcpu);
>> +void vmx_prepare_guest_switch(struct kvm_vcpu *vcpu);
>>   void vmx_set_host_fs_gs(struct vmcs_host_state *host, u16 fs_sel, 
>> u16 gs_sel,
>>               unsigned long fs_base, unsigned long gs_base);
>>   int vmx_get_cpl(struct kvm_vcpu *vcpu);
>

  reply	other threads:[~2020-11-10 19:04 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-10  1:23 [PATCH 0/5 v4] KVM: x86: Fill in conforming {vmx|svm}_x86_ops and {vmx|svm}_nested_ops via macros Krish Sadhukhan
2020-11-10  1:23 ` Krish Sadhukhan
2020-11-10  1:23 ` [PATCH 1/5 v4] KVM: x86: Change names of some of the kvm_x86_ops functions to make them more semantical and readable Krish Sadhukhan
2020-11-10  1:23   ` Krish Sadhukhan
2020-11-10  1:23 ` [PATCH 2/5 v4] KVM: SVM: Fill in conforming svm_x86_ops via macro Krish Sadhukhan
2020-11-10  1:23   ` Krish Sadhukhan
2020-11-10  3:56   ` kernel test robot
2020-11-10  3:56     ` kernel test robot
2020-11-10  1:23 ` [PATCH 3/5 v4] KVM: nSVM: Fill in conforming svm_nested_ops " Krish Sadhukhan
2020-11-10  1:23   ` Krish Sadhukhan
2020-11-10  1:23 ` [PATCH 4/5 v4] KVM: VMX: Fill in conforming vmx_x86_ops " Krish Sadhukhan
2020-11-10  1:23   ` Krish Sadhukhan
2020-11-10  1:49   ` Like Xu
2020-11-10 19:02     ` Krish Sadhukhan [this message]
2020-11-11  1:54       ` Xu, Like
2020-11-10  1:23 ` [PATCH 5/5 v4] KVM: nVMX: Fill in conforming vmx_nested_ops " Krish Sadhukhan
2020-11-10  1:23   ` Krish Sadhukhan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e9819b87-c4e0-d15b-80b8-637ecb74f1c3@oracle.com \
    --to=krish.sadhukhan@oracle.com \
    --cc=jmattson@google.com \
    --cc=kvm@vger.kernel.org \
    --cc=like.xu@linux.intel.com \
    --cc=pbonzini@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=sean.j.christopherson@intel.com \
    --cc=vkuznets@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.