fstests.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: guaneryu@gmail.com, linux-xfs@vger.kernel.org, fstests@vger.kernel.org
Subject: Re: [PATCH 15/24] xfs/194: actually check if we got 512-byte blocks before proceeding
Date: Wed, 16 Sep 2020 14:07:47 -0700	[thread overview]
Message-ID: <20200916210747.GK7955@magnolia> (raw)
In-Reply-To: <20200916113400.GF2937@dhcp-12-102.nay.redhat.com>

On Wed, Sep 16, 2020 at 07:34:00PM +0800, Zorro Lang wrote:
> On Mon, Sep 14, 2020 at 06:44:31PM -0700, Darrick J. Wong wrote:
> > From: Darrick J. Wong <darrick.wong@oracle.com>
> > 
> > This test has specific fs block size requirements, so make sure that's
> > what we got before we proceed with the test.
> > 
> > Signed-off-by: Darrick J. Wong <darrick.wong@oracle.com>
> > ---
> >  tests/xfs/194 |    3 +++
> >  1 file changed, 3 insertions(+)
> > 
> > 
> > diff --git a/tests/xfs/194 b/tests/xfs/194
> > index 9001a146..90b74c8f 100755
> > --- a/tests/xfs/194
> > +++ b/tests/xfs/194
> > @@ -84,6 +84,9 @@ unset XFS_MKFS_OPTIONS
> >  # we need 512 byte block size, so crc's are turned off
> >  _scratch_mkfs_xfs -m crc=0 -b size=$blksize >/dev/null 2>&1
> >  _scratch_mount
> > +test "$(_get_block_size $SCRATCH_MNT)" = 512 || \
> > +	_notrun "Could not get 512-byte blocks"
> > +
> 
> If this case is only for 512 byte blocksize, the "blksize=`expr $pgsize / 8`"
> and all things with the "$blksize" looks redundant, right?

Hmm... in hindsight I shouldn't have hardwired the right hand argument.
This needs only to be a simple equivalence test:

test "$(_get_block_size $SCRATCH_MNT)" = $blksize || \
	_notrun "Could not get $blksize-byte blocks"

Will fix and resend.

--D

> Thanks,
> Zorro
> 
> >  
> >  # 512b block / 4k page example:
> >  #
> > 
> 

  reply	other threads:[~2020-09-16 21:08 UTC|newest]

Thread overview: 87+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-15  1:42 [PATCH 00/24] fstests: tons of random fixes Darrick J. Wong
2020-09-15  1:43 ` [PATCH 01/24] xfs/331: don't run this test if fallocate isn't supported Darrick J. Wong
2020-09-15 12:39   ` Zorro Lang
2020-09-17  7:50   ` Christoph Hellwig
2020-09-15  1:43 ` [PATCH 02/24] generic/60[01]: fix test failure when setting new grace limit Darrick J. Wong
2020-09-15 12:55   ` Zorro Lang
2020-09-17  7:51   ` Christoph Hellwig
2020-09-15  1:43 ` [PATCH 03/24] generic/607: don't break on filesystems that don't support FSGETXATTR on dirs Darrick J. Wong
2020-09-15 13:16   ` Zorro Lang
2020-09-17  1:41   ` Xiao Yang
2020-09-17  3:27     ` Darrick J. Wong
2020-09-17  3:43       ` Xiao Yang
2020-09-17  3:56         ` Darrick J. Wong
2020-09-17  7:52           ` Christoph Hellwig
2020-09-17 15:54             ` Darrick J. Wong
2020-09-17 16:02               ` Christoph Hellwig
2020-09-15  1:43 ` [PATCH 04/24] xfs: skip tests that rely on allocation behaviors of the data device Darrick J. Wong
2020-09-16  2:04   ` Zorro Lang
2020-09-17  7:53   ` Christoph Hellwig
2020-09-15  1:43 ` [PATCH 05/24] xfs/031: make sure we don't set rtinherit=1 on mkfs Darrick J. Wong
2020-09-16  2:21   ` Zorro Lang
2020-09-17  7:53   ` Christoph Hellwig
2020-09-17 15:57     ` Darrick J. Wong
2020-09-17 16:01       ` Christoph Hellwig
2020-09-15  1:43 ` [PATCH 06/24] xfs: wrap xfs_db calls to the test device Darrick J. Wong
2020-09-16  2:25   ` Zorro Lang
2020-09-17  7:54   ` Christoph Hellwig
2020-09-15  1:43 ` [PATCH 07/24] xfs/{111,137}: replace open-coded calls to repair with _scratch_xfs_repair Darrick J. Wong
2020-09-16  2:28   ` Zorro Lang
2020-09-17  7:54   ` Christoph Hellwig
2020-09-15  1:43 ` [PATCH 08/24] xfs: replace open-coded calls to xfs_logprint with helpers Darrick J. Wong
2020-09-16  2:35   ` Zorro Lang
2020-09-17  7:54   ` Christoph Hellwig
2020-09-15  1:43 ` [PATCH 09/24] xfs/070: add scratch log device options to direct repair invocation Darrick J. Wong
2020-09-16  2:42   ` Zorro Lang
2020-09-16  3:42     ` Darrick J. Wong
2020-09-16 11:25       ` Zorro Lang
2020-09-17  7:55   ` Christoph Hellwig
2020-09-15  1:43 ` [PATCH 10/24] xfs: add a _require_xfs_copy helper Darrick J. Wong
2020-09-16  3:29   ` Zorro Lang
2020-09-17  7:55   ` Christoph Hellwig
2020-09-15  1:44 ` [PATCH 11/24] overlay/{069,071}: fix undefined variables Darrick J. Wong
2020-09-15  8:48   ` Amir Goldstein
2020-09-15  1:44 ` [PATCH 12/24] overlay/020: make sure the system supports the required namespaces Darrick J. Wong
2020-09-15  8:46   ` Amir Goldstein
2020-09-15  1:44 ` [PATCH 13/24] generic/204: don't flood stdout with ENOSPC messages on an ENOSPC test Darrick J. Wong
2020-09-16  4:14   ` Zorro Lang
2020-09-17  7:56   ` Christoph Hellwig
2020-09-17 16:02     ` Darrick J. Wong
2020-09-15  1:44 ` [PATCH 14/24] common/xfs: extract minimum log size message from mkfs correctly Darrick J. Wong
2020-09-16  5:28   ` Zorro Lang
2020-09-17  7:56   ` Christoph Hellwig
2020-09-15  1:44 ` [PATCH 15/24] xfs/194: actually check if we got 512-byte blocks before proceeding Darrick J. Wong
2020-09-16 11:34   ` Zorro Lang
2020-09-16 21:07     ` Darrick J. Wong [this message]
2020-09-15  1:44 ` [PATCH 16/24] xfs/098: adapt to external log devices Darrick J. Wong
2020-09-16 11:36   ` Zorro Lang
2020-09-17  7:58   ` Christoph Hellwig
2020-09-15  1:44 ` [PATCH 17/24] xfs: refactor _xfs_check calls to the scratch device Darrick J. Wong
2020-09-16 11:39   ` Zorro Lang
2020-09-17  7:58   ` Christoph Hellwig
2020-09-17 16:03     ` Darrick J. Wong
2020-09-15  1:44 ` [PATCH 18/24] xfs/291: fix open-coded repair call to mdrestore'd fs image Darrick J. Wong
2020-09-16 11:41   ` Zorro Lang
2020-09-15  1:44 ` [PATCH 19/24] xfs/424: disable external devices Darrick J. Wong
2020-09-16 11:48   ` Zorro Lang
2020-09-17  7:59   ` Christoph Hellwig
2020-09-15  1:45 ` [PATCH 20/24] xfs/449: fix xfs info report output if realtime device specified Darrick J. Wong
2020-09-16 11:50   ` Zorro Lang
2020-09-17  7:59   ` Christoph Hellwig
2020-09-15  1:45 ` [PATCH 21/24] common/rc: teach _scratch_mkfs_sized to set a size on an xfs realtime volume Darrick J. Wong
2020-09-16 12:02   ` Zorro Lang
2020-09-17  8:00   ` Christoph Hellwig
2020-09-17 16:04     ` Darrick J. Wong
2020-09-18  2:08   ` [PATCH v2 " Darrick J. Wong
2020-09-15  1:45 ` [PATCH 22/24] xfs/141: run for longer with TIME_FACTOR Darrick J. Wong
2020-09-16 12:05   ` Zorro Lang
2020-09-17  8:01   ` Christoph Hellwig
2020-09-15  1:45 ` [PATCH 23/24] generic/204: sync before scrub hits EIO Darrick J. Wong
2020-09-16 12:09   ` Zorro Lang
2020-09-17  8:01   ` Christoph Hellwig
2020-09-15  1:45 ` [PATCH 24/24] check: try reloading modules Darrick J. Wong
2020-09-15  8:42   ` Amir Goldstein
2020-09-18  2:10 ` [PATCH 26/24] common: drop HOSTOS Darrick J. Wong
2020-09-18  2:11 ` [PATCH 27/24] common/rc: fix indentation in _scratch_mkfs_sized Darrick J. Wong
2020-09-19  5:13   ` Christoph Hellwig
     [not found] ` <20200918020936.GJ7954@magnolia>
2020-09-19  5:13   ` [PATCH 25/24] common: kill _supported_os Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200916210747.GK7955@magnolia \
    --to=darrick.wong@oracle.com \
    --cc=fstests@vger.kernel.org \
    --cc=guaneryu@gmail.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).