git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] name-rev: use skip_prefix() instead of starts_with()
@ 2019-11-26 15:23 René Scharfe
  2019-11-26 16:07 ` Jeff King
  0 siblings, 1 reply; 2+ messages in thread
From: René Scharfe @ 2019-11-26 15:23 UTC (permalink / raw)
  To: Git Mailing List; +Cc: Junio C Hamano

Let skip_prefix() advance refname to get rid of two magic numbers.

Signed-off-by: René Scharfe <l.s.r@web.de>
---
 builtin/name-rev.c | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/builtin/name-rev.c b/builtin/name-rev.c
index b0f0776947..c261d661d7 100644
--- a/builtin/name-rev.c
+++ b/builtin/name-rev.c
@@ -161,10 +161,8 @@ static const char *name_ref_abbrev(const char *refname, int shorten_unambiguous)
 {
 	if (shorten_unambiguous)
 		refname = shorten_unambiguous_ref(refname, 0);
-	else if (starts_with(refname, "refs/heads/"))
-		refname = refname + 11;
-	else if (starts_with(refname, "refs/"))
-		refname = refname + 5;
+	else if (!skip_prefix(refname, "refs/heads/", &refname))
+		skip_prefix(refname, "refs/", &refname);
 	return refname;
 }

--
2.24.0

^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] name-rev: use skip_prefix() instead of starts_with()
  2019-11-26 15:23 [PATCH] name-rev: use skip_prefix() instead of starts_with() René Scharfe
@ 2019-11-26 16:07 ` Jeff King
  0 siblings, 0 replies; 2+ messages in thread
From: Jeff King @ 2019-11-26 16:07 UTC (permalink / raw)
  To: René Scharfe; +Cc: Git Mailing List, Junio C Hamano

On Tue, Nov 26, 2019 at 04:23:31PM +0100, René Scharfe wrote:

> diff --git a/builtin/name-rev.c b/builtin/name-rev.c
> index b0f0776947..c261d661d7 100644
> --- a/builtin/name-rev.c
> +++ b/builtin/name-rev.c
> @@ -161,10 +161,8 @@ static const char *name_ref_abbrev(const char *refname, int shorten_unambiguous)
>  {
>  	if (shorten_unambiguous)
>  		refname = shorten_unambiguous_ref(refname, 0);
> -	else if (starts_with(refname, "refs/heads/"))
> -		refname = refname + 11;
> -	else if (starts_with(refname, "refs/"))
> -		refname = refname + 5;
> +	else if (!skip_prefix(refname, "refs/heads/", &refname))
> +		skip_prefix(refname, "refs/", &refname);
>  	return refname;

And this one is correct because we were already mutating the pointer.
Good.

Collapsing the conditional makes sense. IMHO it might be a little easier
to follow if we keep else-if non-negated, like:

  if (shorten_unambiguous)
         refname = shorten_unambiguous(refname, 0);
  else if (skip_prefix(refname, "refs/heads/", &refname))
         ; /* refname already advanced */
  else
         skip_prefix(refname, "refs/", &refname);

but I'm fine with it either way.

Also, I think we are leaking the result of shorten_unambiguous_refename
here (the caller won't free it, as we return a const; but anyway we
sometimes return a pointer into the existing const string so it wouldn't
be safe). That's all outside your patch, obviously.

-Peff

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2019-11-26 16:07 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-11-26 15:23 [PATCH] name-rev: use skip_prefix() instead of starts_with() René Scharfe
2019-11-26 16:07 ` Jeff King

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).