git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jeff King <peff@peff.net>
To: Junio C Hamano <gitster@pobox.com>
Cc: git@vger.kernel.org
Subject: Re: [PATCH v3 0/2] fmt-merge-msg: selectively suppress "into <branch>"
Date: Thu, 30 Jul 2020 20:42:02 -0400	[thread overview]
Message-ID: <20200731004202.GA240563@coredump.intra.peff.net> (raw)
In-Reply-To: <20200730180237.1392480-1-gitster@pobox.com>

On Thu, Jul 30, 2020 at 11:02:35AM -0700, Junio C Hamano wrote:

> So, this is the third iteration, which separates the reversion that
> involves too many uninteresting test changes, and the implementation
> of the new feature proper.

Thanks, that did make it much easier to read.

> Two things that changed in the implementation since the previous
> iterations are
> 
>  - An assignment-less 'truth', i.e.
> 
> 	[merge] suppressDest
> 
>    is now an error ("missing value for 'merge.suppressDest'"), not
>    "clear the list", which should be spelled as an empty string, i.e.
> 
>         [merge] suppressDest = ""

OK. I don't have a preference either way on the "truth" behavior, but
certainly considering it an error is the conservative thing.

>  - Scanning of dest_patterns to see if "into <branch>" is suppressed
>    for the current_branch is done in a helper function to make the
>    main codeflow easier to read, as suggested by Peff.

Thanks.

This version looks OK to me. The remaining issues that came up in
earlier discussion but I didn't see you weigh in on are:

  - what should happen with a detached HEAD? We'd match HEAD in the
    suppressDest config, which I think is quite reasonable. Not sure if
    it's worth documenting or testing that specifically.

  - should "master" be in the list even if you configure a value? That
    would do the wrong thing if you have a non-integration master, but
    that seems unlikely. And it would do the right thing if somebody
    later puts "main" in merge.suppressDest, but still occasionally
    works with "master" repos (where "right" is defined as "what they
    probably wanted", but it is perhaps a bit magical).

  - what's the plan if we do switch init.defaultBranch to "main"? Would
    we add default_branch() to the list of defaults alongside "master",
    or just add "main", or just leave it and let people configure
    independently? It doesn't need to be decided now, but maybe worth
    thinking about.

-Peff

  parent reply	other threads:[~2020-07-31  0:42 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-29 19:44 Avoiding 'master' nomenclature Linus Torvalds
2020-07-29 20:04 ` Junio C Hamano
2020-07-29 20:23   ` Linus Torvalds
2020-07-29 20:38     ` Jonathan Nieder
2020-07-29 20:46       ` Linus Torvalds
2020-07-29 20:56         ` Linus Torvalds
2020-07-30  8:17       ` lego_12239
2020-07-31  0:57         ` Jeff King
2020-07-31  8:19           ` Oleg
2020-07-29 20:40     ` Linus Torvalds
2020-07-29 20:58       ` Jeff King
2020-07-29 21:20         ` Linus Torvalds
2020-07-30  0:29           ` Jeff King
2020-07-30  0:44             ` Linus Torvalds
2020-07-30  0:52               ` Jeff King
2020-07-30  0:57                 ` Linus Torvalds
2020-07-31  0:44                   ` Jeff King
2020-07-29 21:25         ` Junio C Hamano
2020-07-29 22:50           ` Junio C Hamano
2020-07-30  0:14             ` Jeff King
2020-07-30  0:23               ` Linus Torvalds
2020-07-30 10:11                 ` Michal Suchánek
2020-07-30  0:31               ` Jeff King
2020-07-30  0:36             ` Junio C Hamano
2020-07-30 18:02               ` [PATCH v3 0/2] fmt-merge-msg: selectively suppress "into <branch>" Junio C Hamano
2020-07-30 18:02                 ` [PATCH v3 1/2] Revert "fmt-merge-msg: stop treating `master` specially" Junio C Hamano
2020-07-30 19:10                   ` Eric Sunshine
2020-07-30 19:40                     ` Junio C Hamano
2020-07-30 18:02                 ` [PATCH v3 2/2] fmt-merge-msg: allow merge destination to be omitted again Junio C Hamano
2020-07-31  0:42                 ` Jeff King [this message]
2020-07-31  2:04                   ` [PATCH v3 0/2] fmt-merge-msg: selectively suppress "into <branch>" Junio C Hamano
2020-07-31  2:22                     ` Jeff King
2020-07-31 20:03                       ` Taylor Blau
2020-07-31 20:12                         ` Junio C Hamano
2020-07-31 20:17                           ` Taylor Blau
2020-08-01  7:15                         ` Michal Suchánek
2020-08-10 11:53               ` Avoiding 'master' nomenclature Johannes Schindelin
2020-08-10 15:45                 ` Junio C Hamano
2020-08-11  2:39                   ` Johannes Schindelin
2020-08-12  0:30                     ` Junio C Hamano
2020-07-29 20:40     ` Junio C Hamano
2020-07-29 20:51       ` Linus Torvalds

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200731004202.GA240563@coredump.intra.peff.net \
    --to=peff@peff.net \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).