messages from 2020-12-10 20:56:18 to 2020-12-14 22:51:02 UTC [more...]
RFC: Modernizing the contept of plumbing v.s. porcelain
2020-12-14 22:49 UTC (4+ messages)
[PATCH 1/2] refs: move is_pseudoref_syntax() earlier in the file
2020-12-14 22:44 UTC (11+ messages)
` [PATCH 2/2] refs: warn on non-pseudoref looking .git/<file> refs
` [PATCH v2 0/2] "
` [PATCH v2 1/2] refs: move is_pseudoref_syntax() earlier in the file
` [PATCH v2 2/2] refs: warn on non-pseudoref looking .git/<file> refs
[ANNOUNCE] Git for Windows 2.30.0-rc0
2020-12-14 22:31 UTC
[PATCH v2 00/14] pull: default warning improvements
2020-12-14 22:30 UTC (25+ messages)
` [PATCH v2 02/14] pull: improve default warning
[PATCH v5 0/3] pull: stop warning on every pull
2020-12-14 21:40 UTC (26+ messages)
` [PATCH v5 1/3] pull: refactor fast-forward check
` [PATCH v5 2/3] pull: move default warning
` [PATCH v5 3/3] pull: display default warning only when non-ff
[PATCH v7 0/5] making pull advice not to trigger when unneeded
2020-12-14 21:24 UTC (9+ messages)
` [PATCH v7 1/5] pull: refactor fast-forward check
` [PATCH v7 2/5] pull: give the advice for choosing rebase/merge much later
` [PATCH v7 3/5] pull: get rid of unnecessary global variable
` [PATCH v7 4/5] pull: correct condition to trigger non-ff advice
` [PATCH v7 5/5] pull: display default warning only when non-ff
What's cooking in git.git (Dec 2020, #02; Mon, 14)
2020-12-14 20:04 UTC
[ANNOUNCE] Git v2.30.0-rc0
2020-12-14 20:00 UTC
Unexpected behavior on diff -I<regex> --name-only
2020-12-14 19:49 UTC (2+ messages)
Cloning empty repository uses locally configured default branch name
2020-12-14 19:42 UTC (8+ messages)
` [PATCH] clone: in protocol v2, use remote's default branch
[PATCH 00/11] merge-ort: add basic rename detection
2020-12-14 17:35 UTC (39+ messages)
` [PATCH 01/11] merge-ort: add basic data structures for handling renames
` [PATCH 02/11] merge-ort: add initial outline for basic rename detection
` [PATCH 03/11] merge-ort: implement detect_regular_renames()
` [PATCH 04/11] merge-ort: implement compare_pairs() and collect_renames()
` [PATCH 05/11] merge-ort: add basic outline for process_renames()
` [PATCH 06/11] merge-ort: add implementation of both sides renaming identically
` [PATCH 07/11] merge-ort: add implementation of both sides renaming differently
` [PATCH v2 00/11] merge-ort: add basic rename detection
` [PATCH v2 01/11] merge-ort: add basic data structures for handling renames
` [PATCH v2 02/11] merge-ort: add initial outline for basic rename detection
` [PATCH v2 03/11] merge-ort: implement detect_regular_renames()
` [PATCH v2 04/11] merge-ort: implement compare_pairs() and collect_renames()
` [PATCH v2 05/11] merge-ort: add basic outline for process_renames()
` [PATCH v2 06/11] merge-ort: add implementation of both sides renaming identically
` [PATCH v2 07/11] merge-ort: add implementation of both sides renaming differently
` [PATCH v2 08/11] merge-ort: add implementation of rename collisions
` [PATCH v2 09/11] merge-ort: add implementation of rename/delete conflicts
` [PATCH v2 10/11] merge-ort: add implementation of normal rename handling
` [PATCH v2 11/11] merge-ort: add implementation of type-changed "
[PATCH v2 00/20] fundamentals of merge-ort implementation
2020-12-14 16:24 UTC (24+ messages)
` [PATCH v3 "
` [PATCH v3 01/20] merge-ort: setup basic internal data structures
` [PATCH v3 02/20] merge-ort: add some high-level algorithm structure
` [PATCH v3 03/20] merge-ort: port merge_start() from merge-recursive
` [PATCH v3 04/20] merge-ort: use histogram diff
` [PATCH v3 05/20] merge-ort: add an err() function similar to one from merge-recursive
` [PATCH v3 06/20] merge-ort: implement a very basic collect_merge_info()
` [PATCH v3 07/20] merge-ort: avoid repeating fill_tree_descriptor() on the same tree
` [PATCH v3 08/20] merge-ort: compute a few more useful fields for collect_merge_info
` [PATCH v3 09/20] merge-ort: record stage and auxiliary info for every path
` [PATCH v3 10/20] merge-ort: avoid recursing into identical trees
` [PATCH v3 11/20] merge-ort: add a preliminary simple process_entries() implementation
` [PATCH v3 12/20] merge-ort: have process_entries operate in a defined order
` [PATCH v3 13/20] merge-ort: step 1 of tree writing -- record basenames, modes, and oids
` [PATCH v3 14/20] merge-ort: step 2 of tree writing -- function to create tree object
` [PATCH v3 15/20] merge-ort: step 3 of tree writing -- handling subdirectories as we go
` [PATCH v3 16/20] merge-ort: basic outline for merge_switch_to_result()
` [PATCH v3 17/20] merge-ort: add implementation of checkout()
` [PATCH v3 18/20] tree: enable cmp_cache_name_compare() to be used elsewhere
` [PATCH v3 19/20] merge-ort: add implementation of record_conflicted_index_entries()
` [PATCH v3 20/20] merge-ort: free data structures in merge_finalize()
Bug report: git rebase ignores different context, resulting in subtle breakage
2020-12-14 14:37 UTC
[PATCH] index-format.txt: document v2 format of file system monitor extension
2020-12-14 13:33 UTC
[PATCH] docs: multi-pack-index: remove note about future 'verify' work
2020-12-14 13:13 UTC (2+ messages)
[PATCH 0/1] Hashed mailmap support
2020-12-14 11:54 UTC (7+ messages)
` [PATCH 1/1] mailmap: support hashed entries in mailmaps
Cleanup tool for old blobs in partial clone
2020-12-13 10:10 UTC (2+ messages)
GIT_DIR output from git worktree list
2020-12-13 6:07 UTC (7+ messages)
[PATCH v5 0/2] rev-parse options for absolute or relative paths
2020-12-13 2:35 UTC (4+ messages)
` [PATCH v5 1/2] abspath: add a function to resolve paths with missing components
` [PATCH v5 2/2] rev-parse: add option for absolute or relative path formatting
[PATCH] l10n: ru.po: fix typo in Russian translation
2020-12-12 20:58 UTC
[PATCH v5 0/3] pull: stop warning on every pull
2020-12-12 16:56 UTC (5+ messages)
` [PATCH v5 1/3] pull: refactor fast-forward check
` [PATCH v5 2/3] pull: move default warning
` [PATCH v5 3/3] pull: display default warning only when non-ff
Why does "git pull --rebase" require a clean git directory?
2020-12-12 11:29 UTC (5+ messages)
Response Required
2020-12-12 1:53 UTC
[RFC 1/2] pull: warn that pulling will not merge by default in Git 3.0
2020-12-12 1:08 UTC (5+ messages)
` [RFC 2/2] pull: default pull.ff to "only" when pull.rebase is not set either
[PATCH v2 0/2] config: allow specifying config entries via envvar pairs
2020-12-11 16:10 UTC (24+ messages)
` [PATCH v4 0/6] config: allow specifying config entries via env
` [PATCH v4 2/6] config: add new way to pass config via `--config-env`
` [PATCH 3/3] config: store "git -c" variables using more robust format
What's cooking in git.git (Dec 2020, #01; Tue, 8)
2020-12-12 0:43 UTC (17+ messages)
` fc/pull-merge-rebase, was "
` js/init-defaultbranch-advice, "
[PATCH v3 0/4] Add helpful advice about init.defaultBranch
2020-12-11 11:36 UTC (19+ messages)
` [PATCH v4 "
` [PATCH v4 1/4] init: document `init.defaultBranch` better
` [PATCH v4 2/4] branch -m: allow renaming a yet-unborn branch
` [PATCH v4 3/4] get_default_branch_name(): prepare for showing some advice
` [PATCH v4 4/4] init: provide useful advice about init.defaultBranch
` [PATCH v5 0/4] Add helpful "
` [PATCH v5 1/4] init: document `init.defaultBranch` better
` [PATCH v5 2/4] branch -m: allow renaming a yet-unborn branch
` [PATCH v5 3/4] get_default_branch_name(): prepare for showing some advice
` [PATCH v5 4/4] init: provide useful advice about init.defaultBranch
[PATCH v6 00/17] propose config-based hooks (part I)
2020-12-11 10:15 UTC (3+ messages)
` [PATCH 08/17] hook: add 'run' subcommand
[PATCH 0/7] diffcore-rename improvements
2020-12-11 9:08 UTC (11+ messages)
` [PATCH v2 0/9] "
` [PATCH v2 1/9] diffcore-rename: rename num_create to num_destinations
` [PATCH v2 2/9] diffcore-rename: avoid usage of global in too_many_rename_candidates()
` [PATCH v2 3/9] diffcore-rename: simplify limit check
` [PATCH v2 4/9] diffcore-rename: reduce jumpiness in progress counters
` [PATCH v2 5/9] t4058: add more tests and documentation for duplicate tree entry handling
` [PATCH v2 6/9] t4058: explore duplicate tree entry handling in a bit more detail
` [PATCH v2 7/9] diffcore-rename: simplify and accelerate register_rename_src()
` [PATCH v2 8/9] diffcore-rename: accelerate rename_dst setup
` [PATCH v2 9/9] diffcore-rename: remove unneccessary duplicate entry checks
[PATCH v2 0/2] vim: configuration and sharness syntax
2020-12-11 4:37 UTC (10+ messages)
` [PATCH v2 1/2] Add project-wide .vimrc configuration
[PATCH 0/3] Add helpful advice about init.defaultBranch
2020-12-10 23:32 UTC (10+ messages)
` [PATCH v2 0/4] "
` [PATCH v2 4/4] init: provide useful "
[PATCH 00/26] git-log: implement new --diff-merge options
2020-12-10 21:26 UTC (18+ messages)
page: next (older) | prev (newer) | latest
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).