git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-03-05 00:55:54 to 2021-03-08 18:26:47 UTC [more...]

[PATCH] Makefile: generate 'git' as 'cc [...] -o git+ && mv git+ git'
 2021-03-08 18:26 UTC  (5+ messages)

[PATCH] read_tree(): pass "int stage" as context to read_tree_recursive()
 2021-03-08 18:19 UTC  (53+ messages)
` [PATCH 0/7] Move the read_tree() function to its only user
  ` [PATCH v2 0/6] "
    ` [PATCH 00/30] tree-walk: mostly "mode" to "enum object_type"
    ` [PATCH 01/30] diff.c: remove redundant canon_mode() call
    ` [PATCH 02/30] notes & match-trees: use name_entry's "pathlen" member
    ` [PATCH 03/30] cache.h: add a comment to object_type()
    ` [PATCH 04/30] tree-walk.h: add object_type member to name_entry
    ` [PATCH 05/30] tree-walk.c: migrate to using new "object_type" field when possible
    ` [PATCH 06/30] cache.h: have base_name_compare() take "is tree?", not "mode"
    ` [PATCH 07/30] tree-walk.h users: switch object_type(...) to new .object_type
    ` [PATCH 08/30] tree.h: format argument lists of read_tree_recursive() users
    ` [PATCH 09/30] tree.h users: format argument lists in archive.c
    ` [PATCH 10/30] archive: get rid of 'stage' parameter
    ` [PATCH 11/30] tree.h API: make read_tree_fn_t take an "enum object_type"
    ` [PATCH 12/30] tree-walk.h users: migrate "p->mode &&" pattern
    ` [PATCH 13/30] tree-walk.h users: refactor chained "mode" if/else into switch
    ` [PATCH 14/30] tree-walk.h users: migrate miscellaneous "mode" to "object_type"
    ` [PATCH 15/30] merge-tree tests: test for the mode comparison in same_entry()
    ` [PATCH 16/30] merge-ort: correct reference to test in 62fdec17a11
    ` [PATCH 17/30] fsck.c: switch on "object_type" in fsck_walk_tree()
    ` [PATCH 18/30] tree-walk.h users: use temporary variable(s) for "mode"
    ` [PATCH 19/30] tree-walk.h API: formatting changes for subsequent commit
    ` [PATCH 20/30] tree-walk.h API: rename get_tree_entry() to get_tree_entry_mode()
    ` [PATCH 21/30] tree-walk.h API users: use "tmp" for mode in shift_tree_by()
    ` [PATCH 22/30] tree-walk.h API: Add get_tree_entry_type()
    ` [PATCH 23/30] tree-walk.h API: add a get_tree_entry_path() function
    ` [PATCH 24/30] tree-walk.h API: document and format tree_entry_extract()
    ` [PATCH 25/30] tree-entry.h API: rename tree_entry_extract() to tree_entry_extract_mode()
    ` [PATCH 26/30] tree-walk.h API: add a tree_entry_extract_all() function
    ` [PATCH 27/30] tree-walk.h API: add a tree_entry_extract_type() function
    ` [PATCH 28/30] tree-walk.h API users: rename "struct name_entry"'s "mode" to "raw_mode"
    ` [PATCH 29/30] tree.h API users: rename read_tree_fn_t's "
    ` [PATCH 30/30] tree-walk.h API: move canon_mode() back out of decode_tree_entry()
  ` [PATCH v2 1/6] ls-files tests: add meaningful --with-tree tests
  ` [PATCH v2 2/6] tree.c API: move read_tree() into builtin/ls-files.c
  ` [PATCH v2 3/6] ls-files: don't needlessly pass around stage variable
  ` [PATCH v2 4/6] ls-files: refactor away read_tree()
  ` [PATCH v2 5/6] tree.h API: remove support for starting at prefix != ""
  ` [PATCH v2 6/6] tree.h API: remove "stage" parameter from read_tree_recursive()
` [PATCH 1/7] tree.c API: move read_tree() into builtin/ls-files.c
` [PATCH 2/7] ls-files: don't needlessly pass around stage variable
` [PATCH 3/7] ls-files: remove cache juggling + sorting
` [PATCH 4/7] merge-ort: move cmp_cache_name_compare() from tree.c
` [PATCH 5/7] ls-files: refactor read_one_entry_quick() to use a strbuf
` [PATCH 6/7] tree.h API: remove support for starting at prefix != ""
` [PATCH 7/7] tree.h API: remove "stage" parameter from read_tree_recursive()

[PATCH] fix: added new BANNED_EXPL macro for better error messages, new parameter
 2021-03-08 18:05 UTC  (3+ messages)

[PATCH] [.mailmap] Add entry for Ramkumar Ramachandra
 2021-03-08 17:56 UTC  (3+ messages)
` [PATCH v2] "

remote.<name>.merge missing from the git-config man page?
 2021-03-08 17:27 UTC  (3+ messages)

[PATCH] Update 'make fuzz-all' docs to reflect modern clang
 2021-03-08 17:14 UTC  (5+ messages)
` [PATCH v2] "
  ` [PATCH v3] Makefile: update "

bug: conflicting core.bare setting causes segfault during bare clone
 2021-03-08 16:43 UTC  (3+ messages)
` [PATCH] builtin/init-db: handle bare clones when core.bare set to false

[PATCH 00/10] merge-ort: add more handling of basic conflict types
 2021-03-08 14:49 UTC  (8+ messages)
` [PATCH v2 "
  ` [PATCH v2 05/10] merge-ort: flesh out implementation of handle_content_merge()
    ` A merge-ort TODO comment, and how to test merge-ort?

[PATCH 00/11] Complete merge-ort implementation...almost
 2021-03-08 14:43 UTC  (18+ messages)
` [PATCH 03/11] merge-ort: add a function for initializing our special attr_index
` [PATCH 04/11] merge-ort: have ll_merge() calls use the attr_index for renormalization
` [PATCH 05/11] merge-ort: let renormalization change modify/delete into clean delete
` [PATCH 07/11] t6428: new test for SKIP_WORKTREE handling and conflicts
` [PATCH 08/11] merge-ort: implement CE_SKIP_WORKTREE handling with conflicted entries
` [PATCH 09/11] t: mark several submodule merging tests as fixed under merge-ort
` [PATCH 10/11] merge-ort: write $GIT_DIR/AUTO_MERGE whenever we hit a conflict
` [PATCH 11/11] merge-recursive: add a bunch of FIXME comments documenting known bugs

[PATCH 0/8] Simple IPC Cleanups
 2021-03-08 14:14 UTC  (6+ messages)
` [PATCH 5/8] unix-stream-server: add st_dev and st_mode to socket stolen checks

[PATCH v2 00/10] fsck: API improvements (no conflicts with 'seen')
 2021-03-08  9:16 UTC  (26+ messages)
` [PATCH v3 00/22] fsck: API improvements
` [PATCH v3 01/22] fsck.h: update FSCK_OPTIONS_* for object_name
` [PATCH v3 02/22] fsck.h: use designed initializers for FSCK_OPTIONS_{DEFAULT,STRICT}
` [PATCH v3 03/22] fsck.h: reduce duplication between FSCK_OPTIONS_{DEFAULT,STRICT}
` [PATCH v3 04/22] fsck.h: add a FSCK_OPTIONS_COMMON_ERROR_FUNC macro
` [PATCH v3 05/22] fsck.h: indent arguments to of fsck_set_msg_type
` [PATCH v3 06/22] fsck.h: use "enum object_type" instead of "int"
` [PATCH v3 07/22] fsck.c: rename variables in fsck_set_msg_type() for less confusion
` [PATCH v3 08/22] fsck.c: move definition of msg_id into append_msg_id()
` [PATCH v3 09/22] fsck.c: rename remaining fsck_msg_id "id" to "msg_id"
` [PATCH v3 10/22] fsck.c: refactor fsck_msg_type() to limit scope of "int msg_type"
` [PATCH v3 11/22] fsck.h: move FSCK_{FATAL,INFO,ERROR,WARN,IGNORE} into an enum
` [PATCH v3 12/22] fsck.h: re-order and re-assign "enum fsck_msg_type"
` [PATCH v3 13/22] fsck.c: call parse_msg_type() early in fsck_set_msg_type()
` [PATCH v3 14/22] fsck.c: undefine temporary STR macro after use
` [PATCH v3 15/22] fsck.c: give "FOREACH_MSG_ID" a more specific name
` [PATCH v3 16/22] fsck.[ch]: move FOREACH_FSCK_MSG_ID & fsck_msg_id from *.c to *.h
` [PATCH v3 17/22] fsck.c: pass along the fsck_msg_id in the fsck_error callback
` [PATCH v3 18/22] fsck.c: add an fsck_set_msg_type() API that takes enums
` [PATCH v3 19/22] fsck.c: move gitmodules_{found,done} into fsck_options
` [PATCH v3 20/22] fetch-pack: don't needlessly copy fsck_options
` [PATCH v3 21/22] fetch-pack: use file-scope static struct for fsck_options
` [PATCH v3 22/22] fetch-pack: use new fsck API to printing dangling submodules

[PATCH 1/4] tests: remove last uses of GIT_TEST_GETTEXT_POISON=false
 2021-03-07 20:52 UTC  (5+ messages)
` [PATCH] mktag tests: fix broken "&&" chain

[RFC][PATCH 0/2] rm: changes in the '.gitmodules' are staged after using '--cached'
 2021-03-07 20:29 UTC  (9+ messages)
` [PATCH v2 0/1] rm: stage submodule removal from '.gitmodules'
  ` [PATCH v2 1/1] rm: stage submodule removal from '.gitmodules' when using '--cached'

git pull unclear manual
 2021-03-07 18:57 UTC  (5+ messages)

[PATCH] [GSOC][RFC] format-patch: pass --right-only to range-diff
 2021-03-07  6:57 UTC 

rev-list --use-bitmap-index
 2021-03-06 23:00 UTC  (4+ messages)

[PATCH] http: store credential when PKI auth is used
 2021-03-06 22:52 UTC 

[PATCH] coccicheck: optionally batch spatch invocations
 2021-03-06 19:29 UTC  (23+ messages)
` [PATCH] Makefile: fix bugs in coccicheck and speed it up
  ` [PATCH v2 0/4] Makefile/coccicheck: fix bugs "
  ` [PATCH v2 1/4] Makefile/coccicheck: add comment heading for all SPATCH flags
  ` [PATCH v2 2/4] Makefile/coccicheck: speed up and fix bug with duplicate hunks
  ` [PATCH v2 3/4] Makefile/coccicheck: allow for setting xargs concurrency
  ` [PATCH v2 4/4] Makefile/coccicheck: set SPATCH_BATCH_SIZE to 8
    ` [PATCH v2 5/4] Makefile/coccicheck: use --include-headers-for-types

gitattributes export-subst and software versioning
 2021-03-06 16:18 UTC  (8+ messages)
` [PATCH 1/2] pretty: add %(describe)
  ` [PATCH 2/2] pretty: add merge and exclude options to %(describe)

[PATCH v3 0/6][Outreachy] commit: Implementation of "amend!" commit
 2021-03-06  6:11 UTC  (12+ messages)
` [PATCH v3 6/6] doc/git-commit: add documentation for fixup=[amend|reword] options

Cross-signing commits
 2021-03-05 23:45 UTC  (5+ messages)

A note on the 5.12-rc1 tag
 2021-03-05 23:38 UTC  (5+ messages)

[PATCH v2 2/4] http-fetch: allow custom index-pack args
 2021-03-05 23:20 UTC  (9+ messages)
` [PATCH] fetch-pack: do not mix --pack_header and packfile uri

"git diff-files" command reports differences that don't exist
 2021-03-05 22:28 UTC  (5+ messages)

Possible to use git over custom ssh libraries?
 2021-03-05 21:53 UTC  (4+ messages)

[PATCH v3 00/12] Simple IPC Mechanism
 2021-03-05 21:52 UTC  (14+ messages)
` [PATCH v4 "
  ` [PATCH v4 09/12] unix-socket: disallow chdir() when creating unix domain sockets

[PATCH 0/5] clean-ups to geometric repacking
 2021-03-05 19:41 UTC  (11+ messages)
` [PATCH 1/5] builtin/repack.c: do not repack single packs with --geometric
` [PATCH 2/5] t7703: test --geometric repack with loose objects
` [PATCH 3/5] builtin/repack.c: assign pack split later
` [PATCH 4/5] builtin/repack.c: be more conservative with unsigned overflows
` [PATCH 5/5] builtin/repack.c: reword comment around pack-objects flags

Found error in documentation, looking for advice on how to start contributing
 2021-03-05 17:08 UTC  (4+ messages)

Tracking a merge bug
 2021-03-05 11:07 UTC  (3+ messages)

[PATCH v2] format-patch: allow a non-integral version numbers
 2021-03-05  7:10 UTC  (5+ messages)
` [PATCH v3] "
  ` [PATCH v4] "

[PATCH] branch: return error when --list finds no matches
 2021-03-05  0:46 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).