git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-03-15 23:44:39 to 2021-03-16 19:32:57 UTC [more...]

[PATCH v3 00/22] fsck: API improvements
 2021-03-16 19:32 UTC  (27+ messages)
` [PATCH v4 "
` [PATCH v4 01/22] fsck.h: update FSCK_OPTIONS_* for object_name
` [PATCH v4 02/22] fsck.h: use designed initializers for FSCK_OPTIONS_{DEFAULT,STRICT}
` [PATCH v4 03/22] fsck.h: reduce duplication between FSCK_OPTIONS_{DEFAULT,STRICT}
` [PATCH v4 04/22] fsck.h: add a FSCK_OPTIONS_COMMON_ERROR_FUNC macro
` [PATCH v4 05/22] fsck.h: indent arguments to of fsck_set_msg_type
` [PATCH v4 06/22] fsck.h: use "enum object_type" instead of "int"
` [PATCH v4 07/22] fsck.c: rename variables in fsck_set_msg_type() for less confusion
` [PATCH v4 08/22] fsck.c: move definition of msg_id into append_msg_id()
` [PATCH v4 09/22] fsck.c: rename remaining fsck_msg_id "id" to "msg_id"
` [PATCH v4 10/22] fsck.c: refactor fsck_msg_type() to limit scope of "int msg_type"
` [PATCH v4 11/22] fsck.h: move FSCK_{FATAL,INFO,ERROR,WARN,IGNORE} into an enum
` [PATCH v4 12/22] fsck.h: re-order and re-assign "enum fsck_msg_type"
` [PATCH v4 13/22] fsck.c: call parse_msg_type() early in fsck_set_msg_type()
` [PATCH v4 14/22] fsck.c: undefine temporary STR macro after use
` [PATCH v4 15/22] fsck.c: give "FOREACH_MSG_ID" a more specific name
` [PATCH v4 16/22] fsck.[ch]: move FOREACH_FSCK_MSG_ID & fsck_msg_id from *.c to *.h
` [PATCH v4 17/22] fsck.c: pass along the fsck_msg_id in the fsck_error callback
` [PATCH v4 18/22] fsck.c: add an fsck_set_msg_type() API that takes enums
` [PATCH v4 19/22] fsck.c: move gitmodules_{found,done} into fsck_options
` [PATCH v4 20/22] fetch-pack: don't needlessly copy fsck_options
` [PATCH v4 21/22] fetch-pack: use file-scope static struct for fsck_options
` [PATCH v4 22/22] fetch-pack: use new fsck API to printing dangling submodules

GIT_SSH and mirror not working with git 2.30.1
 2021-03-16 18:53 UTC 

Regarding the depreciation of ssh+git/git+ssh protocols
 2021-03-16 18:03 UTC  (12+ messages)

[PATCH 0/2] Declare merge-ort ready for general usage
 2021-03-16 17:33 UTC  (6+ messages)
` [PATCH 1/2] Revert "merge-ort: ignore the directory rename split conflict for now"
` [PATCH 2/2] t6423: mark remaining expected failure under merge-ort as such

[PATCH 00/30] tree-walk: mostly "mode" to "enum object_type"
 2021-03-16 17:28 UTC  (71+ messages)
` [PATCH v2 00/29] tree-walk: mostly replace "mode" with "
  ` [PATCH v3 00/32] "
  ` [PATCH v3 01/32] diff.c: remove redundant canon_mode() call
  ` [PATCH v3 02/32] notes & match-trees: use name_entry's "pathlen" member
  ` [PATCH v3 03/32] cache.h: add a comment to object_type()
  ` [PATCH v3 04/32] tree-walk.h: add object_type member to name_entry
  ` [PATCH v3 05/32] tree-walk.c: migrate to using new "object_type" field when possible
  ` [PATCH v3 06/32] fast-import tests: test for sorting dir/file foo v.s. foo.txt
  ` [PATCH v3 07/32] mktree tests: test that "mode" is passed when sorting
  ` [PATCH v3 08/32] diff "
  ` [PATCH v3 09/32] cache.h: have base_name_compare() take "is tree?", not "mode"
  ` [PATCH v3 10/32] tree-walk.h users: switch object_type(...) to new .object_type
  ` [PATCH v3 11/32] tree.h: format argument lists of read_tree_recursive() users
  ` [PATCH v3 12/32] tree.h users: format argument lists in archive.c
  ` [PATCH v3 13/32] archive: get rid of 'stage' parameter
  ` [PATCH v3 14/32] tree.h API: make read_tree_fn_t take an "enum object_type"
  ` [PATCH v3 15/32] tree-walk.h users: migrate "p->mode &&" pattern
  ` [PATCH v3 16/32] tree-walk.h users: refactor chained "mode" if/else into switch
  ` [PATCH v3 17/32] tree-walk.h users: migrate miscellaneous "mode" to "object_type"
  ` [PATCH v3 18/32] merge-tree tests: test for the mode comparison in same_entry()
  ` [PATCH v3 19/32] merge-ort: correct reference to test in 62fdec17a11
  ` [PATCH v3 20/32] fsck.c: switch on "object_type" in fsck_walk_tree()
  ` [PATCH v3 21/32] tree-walk.h users: use temporary variable(s) for "mode"
  ` [PATCH v3 22/32] tree-walk.h API: formatting changes for subsequent commit
  ` [PATCH v3 23/32] tree-walk.h API: rename get_tree_entry() to get_tree_entry_mode()
  ` [PATCH v3 24/32] match-trees: use "tmp" for mode in shift_tree_by()
  ` [PATCH v3 25/32] tree-walk.h API: add get_tree_entry_type()
  ` [PATCH v3 26/32] tree-walk.h API: document and format tree_entry_extract()
  ` [PATCH v3 27/32] tree-entry.h API: rename tree_entry_extract() to tree_entry_extract_mode()
  ` [PATCH v3 28/32] tree-walk.h API: add a tree_entry_extract_all() function
  ` [PATCH v3 29/32] tree-walk.h API: add get_tree_entry_all()
  ` [PATCH v3 30/32] tree-walk.h API: add a get_tree_entry_path() function
  ` [PATCH v3 31/32] blame: emit a better error on 'git blame directory'
  ` [PATCH v3 32/32] tree-walk.h API: add a tree_entry_extract_type() function
` [PATCH v2 01/29] diff.c: remove redundant canon_mode() call
` [PATCH v2 02/29] notes & match-trees: use name_entry's "pathlen" member
` [PATCH v2 03/29] cache.h: add a comment to object_type()
` [PATCH v2 04/29] tree-walk.h: add object_type member to name_entry
` [PATCH v2 05/29] tree-walk.c: migrate to using new "object_type" field when possible
` [PATCH v2 06/29] cache.h: have base_name_compare() take "is tree?", not "mode"
` [PATCH v2 07/29] tree-walk.h users: switch object_type(...) to new .object_type
` [PATCH v2 08/29] tree.h: format argument lists of read_tree_recursive() users
` [PATCH v2 09/29] tree.h users: format argument lists in archive.c
` [PATCH v2 10/29] archive: get rid of 'stage' parameter
` [PATCH v2 11/29] tree.h API: make read_tree_fn_t take an "enum object_type"
` [PATCH v2 12/29] tree-walk.h users: migrate "p->mode &&" pattern
` [PATCH v2 13/29] tree-walk.h users: refactor chained "mode" if/else into switch
` [PATCH v2 14/29] tree-walk.h users: migrate miscellaneous "mode" to "object_type"
` [PATCH v2 15/29] merge-tree tests: test for the mode comparison in same_entry()
` [PATCH v2 16/29] merge-ort: correct reference to test in 62fdec17a11
` [PATCH v2 17/29] fsck.c: switch on "object_type" in fsck_walk_tree()
` [PATCH v2 18/29] tree-walk.h users: use temporary variable(s) for "mode"
` [PATCH v2 19/29] tree-walk.h API: formatting changes for subsequent commit
` [PATCH v2 20/29] tree-walk.h API: rename get_tree_entry() to get_tree_entry_mode()
` [PATCH v2 21/29] tree-walk.h API users: use "tmp" for mode in shift_tree_by()
` [PATCH v2 22/29] tree-walk.h API: add get_tree_entry_type()
` [PATCH v2 23/29] tree-walk.h API: document and format tree_entry_extract()
` [PATCH v2 24/29] tree-entry.h API: rename tree_entry_extract() to tree_entry_extract_mode()
` [PATCH v2 25/29] tree-walk.h API: add a tree_entry_extract_all() function
` [PATCH v2 26/29] tree-walk.h API: add get_tree_entry_all()
` [PATCH v2 27/29] tree-walk.h API: add a get_tree_entry_path() function
` [PATCH v2 28/29] blame: emit a better error on 'git blame directory'
` [PATCH v2 29/29] tree-walk.h API: add a tree_entry_extract_type() function

[PATCH 00/20] Sparse Index: Design, Format, Tests
 2021-03-16 16:59 UTC  (30+ messages)
` [PATCH v2 "
  ` [PATCH v2 05/20] sparse-index: implement ensure_full_index()
  ` [PATCH v3 00/20] Sparse Index: Design, Format, Tests
    ` [PATCH v3 01/20] sparse-index: design doc and format update
    ` [PATCH v3 02/20] t/perf: add performance test for sparse operations
    ` [PATCH v3 03/20] t1092: clean up script quoting
    ` [PATCH v3 04/20] sparse-index: add guard to ensure full index
    ` [PATCH v3 05/20] sparse-index: implement ensure_full_index()
    ` [PATCH v3 06/20] t1092: compare sparse-checkout to sparse-index
    ` [PATCH v3 07/20] test-read-cache: print cache entries with --table
    ` [PATCH v3 08/20] test-tool: don't force full index
    ` [PATCH v3 09/20] unpack-trees: ensure "
    ` [PATCH v3 10/20] sparse-checkout: hold pattern list in index
    ` [PATCH v3 11/20] sparse-index: convert from full to sparse
    ` [PATCH v3 12/20] submodule: sparse-index should not collapse links
    ` [PATCH v3 13/20] unpack-trees: allow sparse directories
    ` [PATCH v3 14/20] sparse-index: check index conversion happens
    ` [PATCH v3 15/20] sparse-index: create extension for compatibility
    ` [PATCH v3 16/20] sparse-checkout: toggle sparse index from builtin
    ` [PATCH v3 17/20] sparse-checkout: disable sparse-index
    ` [PATCH v3 18/20] cache-tree: integrate with sparse directory entries
    ` [PATCH v3 19/20] sparse-index: loose integration with cache_tree_verify()
    ` [PATCH v3 20/20] p2000: add sparse-index repos

[PATCH v2 0/6] Move the read_tree() function to its only user
 2021-03-16 15:52 UTC  (23+ messages)
` [PATCH v3 0/9] read_tree() and read_tree_recursive() refactoring
  ` [PATCH v4 "
  ` [PATCH v4 1/9] ls-files tests: add meaningful --with-tree tests
  ` [PATCH v4 2/9] tree.c API: move read_tree() into builtin/ls-files.c
  ` [PATCH v4 3/9] ls-files: don't needlessly pass around stage variable
  ` [PATCH v4 4/9] ls-files: refactor away read_tree()
  ` [PATCH v4 5/9] tree.h API: remove support for starting at prefix != ""
  ` [PATCH v4 6/9] tree.h API: remove "stage" parameter from read_tree_recursive()
  ` [PATCH v4 7/9] tree.h API: rename read_tree_recursive() to read_tree()
  ` [PATCH v4 8/9] show tests: add test for "git show <tree>"
  ` [PATCH v4 9/9] tree.h API: expose read_tree_1() as read_tree_at()
` [PATCH v3 1/9] ls-files tests: add meaningful --with-tree tests
` [PATCH v3 2/9] tree.c API: move read_tree() into builtin/ls-files.c
` [PATCH v3 3/9] ls-files: don't needlessly pass around stage variable
` [PATCH v3 4/9] ls-files: refactor away read_tree()
` [PATCH v3 5/9] tree.h API: remove support for starting at prefix != ""
` [PATCH v3 6/9] tree.h API: remove "stage" parameter from read_tree_recursive()
` [PATCH v3 7/9] tree.h API: rename read_tree_recursive() to read_tree()
` [PATCH v3 8/9] show tests: add test for "git show <tree>"
` [PATCH v3 9/9] tree.h API: expose read_tree_1() as read_tree_at()

git bisect fails to handle annotated tags
 2021-03-16 15:15 UTC  (3+ messages)
  ` [PATCH] bisect: peel annotated tags to commits

[PATCH] config.txt: add missing period
 2021-03-16 15:17 UTC  (2+ messages)

[ANNOUNCE] Git v2.31.0
 2021-03-16 14:44 UTC  (5+ messages)

[PATCH] fsmonitor: avoid global-buffer-overflow READ when checking trivial response
 2021-03-16 14:20 UTC  (3+ messages)

Tests failed with GIT_TEST_FAIL_PREREQS and/or GIT_TEST_PROTOCOL_VERSION
 2021-03-16 13:52 UTC  (2+ messages)

[PATCH v6] [GSOC] commit: add --trailer option
 2021-03-16 12:52 UTC  (13+ messages)
` [PATCH v7] "
  ` [PATCH v8 0/2] "
    ` [PATCH v8 1/2] "
    ` [PATCH v8 2/2] interpret_trailers: for three options parse add warning
    ` [PATCH v9] [GSOC] commit: add --trailer option

[PATCH 1/2] git-compat-util.h: drop trailing semicolon from macro definition
 2021-03-16 11:43 UTC  (5+ messages)
` [PATCH 2/2] use CALLOC_ARRAY
        ` [PATCH] xcalloc: use CALLOC_ARRAY() when applicable

[PATCH/RFC] test-lib: make --verbose work under prove
 2021-03-16  9:10 UTC  (7+ messages)
` [PATCH 6/7] test-lib: make --verbose output valid TAP

slow object packing during push
 2021-03-16  8:40 UTC  (4+ messages)

[PATCH v3] format-patch: allow a non-integral version numbers
 2021-03-16  8:25 UTC  (6+ messages)
` [PATCH v4] "
  ` [PATCH v5] "

[PATCH 0/7] Sort lists and add static-analysis
 2021-03-16  6:37 UTC  (10+ messages)
` [PATCH 1/7] Makefile: mark 'check-builtins' as a .PHONY target
` [PATCH 2/7] Makefile: ASCII-sort LIB_OBJS
` [PATCH 3/7] builtin.h: ASCII-sort list of functions
` [PATCH 4/7] test-tool.h: "
` [PATCH 5/7] Makefile: add 'check-sort' target
` [PATCH 6/7] ci/run-static-analysis.sh: make check-builtins
` [PATCH 7/7] ci/run-static-analysis.sh: make check-sort

[Newbie]
 2021-03-16  4:31 UTC  (2+ messages)

3/16/21 Order Inquiry (JL)
 2021-03-16  1:42 UTC 

[PATCH] builtin/fetch.c: clean tmp pack after receive signal
 2021-03-16  2:53 UTC 

What's cooking in git.git (Mar 2021, #04; Sun, 14)
 2021-03-16  1:40 UTC  (3+ messages)

[PATCH 0/3] git-completion.bash: improvements to _git_stash()
 2021-03-16  0:54 UTC  (4+ messages)
` [PATCH 1/3] git-completion.bash: extract from else in _git_stash()
` [PATCH 2/3] git-completion.bash: fix `git <args>... stash branch` bug
` [PATCH 3/3] git-completion.bash: use __gitcomp_builtin() in _git_stash()


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).