messages from 2021-03-26 19:55:26 to 2021-03-29 14:50:55 UTC [more...]
[PATCH 2/3] rebase: add a config option to default to --reschedule-failed-exec
2021-03-29 14:49 UTC (4+ messages)
` [PATCH 0/3] rebase: don't override --no-reschedule-failed-exec with config
` [PATCH 3/3] "
[PATCH] Documentation: amended usages of various (sub)commands
2021-03-29 14:46 UTC (11+ messages)
` [PATCH v2] Documentation: make (sub)command options conform to TD of option parsing
` [PATCH v3] column, range-diff: downcase option description
` [PATCH v4] "
[PATCH v3 00/20] Sparse Index: Design, Format, Tests
2021-03-29 14:32 UTC (12+ messages)
` [PATCH v4 "
` [PATCH v4 01/20] sparse-index: design doc and format update
` [PATCH v4 07/20] test-read-cache: print cache entries with --table
[GSOC][PATCH] userdiff: add support for Scheme
2021-03-29 14:06 UTC (18+ messages)
[PATCH v3] [GSOC]trailer: pass arg as positional parameter
2021-03-29 13:43 UTC (7+ messages)
` [PATCH v4] "
[PATCH 0/2] Describe Git's security policy
2021-03-29 13:43 UTC (10+ messages)
` [PATCH 1/2] SECURITY: describe how to report vulnerabilities
` [PATCH 2/2] Document how we do embargoed releases
` [PATCH v2 0/2] Describe Git's security policy
` [PATCH v2 1/2] SECURITY: describe how to report vulnerabilities
` [PATCH v2 2/2] Document how we do embargoed releases
[PATCH 0/4] cmake: learn to optionally skip linking dashed built-ins
2021-03-29 13:36 UTC (12+ messages)
` [PATCH 1/4] cmake: support SKIP_DASHED_BUILT_INS
` [PATCH 2/4] cmake(install): fix double .exe suffixes
` [PATCH 3/4] cmake: add a preparatory work-around to accommodate `vcpkg`
` [PATCH 4/4] cmake(install): include vcpkg dlls
` [PATCH v2 0/4] cmake: learn to optionally skip linking dashed built-ins
` [PATCH v2 1/4] cmake: support SKIP_DASHED_BUILT_INS
` [PATCH v2 2/4] cmake(install): fix double .exe suffixes
` [PATCH v2 3/4] cmake: add a preparatory work-around to accommodate `vcpkg`
` [PATCH v2 4/4] cmake(install): include vcpkg dlls
[PATCH 0/7] improve reporting of unexpected objects
2021-03-29 13:34 UTC (17+ messages)
` [PATCH v2 00/10] "
` [PATCH v2 01/10] object.c: stop supporting len == -1 in type_from_string_gently()
` [PATCH v2 02/10] object.c: refactor type_from_string_gently()
` [PATCH v2 03/10] object.c: make type_from_string() return "enum object_type"
` [PATCH v2 04/10] object-file.c: make oid_object_info() "
` [PATCH v2 05/10] object-name.c: make dependency on object_type order more obvious
` [PATCH v2 06/10] tree.c: fix misindentation in parse_tree_gently()
` [PATCH v2 07/10] object.c: add a utility function for "expected type X, got Y"
` [PATCH v2 08/10] object.c: add and use oid_is_type_or_die_msg() function
` [PATCH v2 09/10] object tests: add test for unexpected objects in tags
` [PATCH v2 10/10] tag: don't misreport type of tagged objects in errors
[PATCH 0/4] usage.c: add a non-fatal bug() + misc doc fixes
2021-03-29 13:25 UTC (17+ messages)
` [PATCH 1/4] usage.c: don't copy/paste the same comment three times
` [PATCH 2/4] api docs: document BUG() in api-error-handling.txt
` [PATCH 3/4] api docs: document that BUG() emits a trace2 error event
` [PATCH 4/4] usage.c: add a non-fatal bug() function to go with BUG()
` [PATCH 0/5] fsck: improve error reporting
` [PATCH 1/5] cache.h: move object functions to object-store.h
` [PATCH 2/5] fsck tests: refactor one test to use a sub-repo
` [PATCH 3/5] fsck: don't hard die on invalid object types
` [PATCH 4/5] fsck: improve the error "
` [PATCH 5/5] fsck: improve error on loose object hash mismatch
[PATCH 0/9] midx: implement a multi-pack reverse index
2021-03-29 13:05 UTC (21+ messages)
` [PATCH v3 00/16] "
` [PATCH v3 01/16] builtin/multi-pack-index.c: inline 'flags' with options
` [PATCH v3 02/16] builtin/multi-pack-index.c: don't handle 'progress' separately
` [PATCH v3 04/16] builtin/multi-pack-index.c: split sub-commands
` [PATCH v3 06/16] builtin/multi-pack-index.c: display usage on unrecognized command
` [PATCH v3 08/16] midx: allow marking a pack as preferred
` [PATCH v3 12/16] Documentation/technical: describe multi-pack reverse indexes
` [PATCH v3 13/16] pack-revindex: read "
` [PATCH v3 15/16] pack-revindex: write "
` [PATCH v3 16/16] midx.c: improve cache locality in midx_pack_order_cmp()
Upstreaming Reviewed-by to git.git
2021-03-29 12:15 UTC (2+ messages)
[PATCH] Documentation: updated documentation for git commit --date
2021-03-29 11:11 UTC (5+ messages)
` [PATCH v2] "
[PATCH 2/2] remote-curl.c: handle v1 when check_smart_http
2021-03-29 10:40 UTC (4+ messages)
` "
[PATCH v7] builtin/clone.c: add --reject-shallow option
2021-03-29 10:19 UTC (2+ messages)
` [PATCH v8] "
[PATCH] sequencer: fix edit handling for cherry-pick and revert messages
2021-03-29 9:23 UTC (5+ messages)
[PATCH 1/2] Parse tags for absent objects
2021-03-29 9:16 UTC (7+ messages)
` [PATCH 6/7] object tests: add test for unexpected objects in tags
[PATCH v3] gitweb: redacted e-mail addresses feature
2021-03-29 3:17 UTC (11+ messages)
` [PATCH v4] "
` [PATCH v5] "
` [PATCH v6] "
[PATCH v5 00/19] fsck: API improvements
2021-03-29 2:06 UTC (24+ messages)
` [PATCH v6 "
` [PATCH v6 01/19] fsck.c: refactor and rename common config callback
` [PATCH v6 02/19] fsck.h: use designed initializers for FSCK_OPTIONS_{DEFAULT,STRICT}
` [PATCH v6 03/19] fsck.h: use "enum object_type" instead of "int"
` [PATCH v6 04/19] fsck.c: rename variables in fsck_set_msg_type() for less confusion
` [PATCH v6 05/19] fsck.c: remove (mostly) redundant append_msg_id() function
` [PATCH v6 06/19] fsck.c: rename remaining fsck_msg_id "id" to "msg_id"
` [PATCH v6 07/19] fsck.c: refactor fsck_msg_type() to limit scope of "int msg_type"
` [PATCH v6 08/19] fsck.h: move FSCK_{FATAL,INFO,ERROR,WARN,IGNORE} into an enum
` [PATCH v6 09/19] fsck.h: re-order and re-assign "enum fsck_msg_type"
` [PATCH v6 10/19] fsck.c: call parse_msg_type() early in fsck_set_msg_type()
` [PATCH v6 11/19] fsck.c: undefine temporary STR macro after use
` [PATCH v6 12/19] fsck.c: give "FOREACH_MSG_ID" a more specific name
` [PATCH v6 13/19] fsck.[ch]: move FOREACH_FSCK_MSG_ID & fsck_msg_id from *.c to *.h
` [PATCH v6 14/19] fsck.c: pass along the fsck_msg_id in the fsck_error callback
` [PATCH v6 15/19] fsck.c: add an fsck_set_msg_type() API that takes enums
` [PATCH v6 16/19] fsck.c: move gitmodules_{found,done} into fsck_options
` [PATCH v6 17/19] fetch-pack: don't needlessly copy fsck_options
` [PATCH v6 18/19] fetch-pack: use file-scope static struct for fsck_options
` [PATCH v6 19/19] fetch-pack: use new fsck API to printing dangling submodules
exporting git commands in parsable format for constructing language-specific API for git CLI
2021-03-28 23:07 UTC (2+ messages)
Pathspec does not accept / does not warn for specific pathspecs
2021-03-28 19:12 UTC (3+ messages)
` [PATCH v2] pathspec: advice: long and short forms are incompatible
What's cooking in git.git (Mar 2021, #07; Mon, 22)
2021-03-28 18:33 UTC (3+ messages)
[PATCH 0/5] small doc make and lint fixes
2021-03-28 17:53 UTC (22+ messages)
` [PATCH 1/5] Documentation/Makefile: make $(wildcard howto/*.txt) a var
` [PATCH 2/5] Documentation/Makefile: make $(wildcard <doc deps>) "
` [PATCH 3/5] doc lint: Perl "strict" and "warnings" in lint-gitlink.perl
` [PATCH 4/5] doc lint: fix bugs in, simplify and improve lint script
` [PATCH 5/5] doc lint: lint and fix missing "GIT" end sections
[RFC PATCH v1 1/2] pathspec: warn: long and short forms are incompatible
2021-03-28 15:44 UTC (5+ messages)
[RFC PATCH v1 2/2] fixup! pathspec: warn: long and short forms are incompatible
2021-03-28 15:26 UTC (2+ messages)
` [RFC PATCH v1 3/3] squash! "
[PATCH 0/3] git-completion.bash: improvements to _git_stash()
2021-03-28 11:04 UTC (9+ messages)
` [PATCH v2 "
` [PATCH v2 1/3] git-completion.bash: pass $__git_subcommand_idx from __git_main()
` [PATCH v2 2/3] git-completion.bash: extract from else in _git_stash()
` [PATCH v2 3/3] git-completion.bash: use __gitcomp_builtin() "
[PATCH] csum-file: flush less often
2021-03-28 8:38 UTC (4+ messages)
` [PATCH v2] csum-file: make hashwrite() more readable
Git 2.31.1, Solaris and error: conflicting types for 'inet_ntop'
2021-03-28 7:22 UTC (5+ messages)
[PATCH] Makefile: add QUIET_GEN to "tags" and "TAGS" targets
2021-03-28 5:56 UTC (2+ messages)
[PATCH 0/8] Optimization batch 10: avoid detecting even more irrelevant renames
2021-03-28 2:01 UTC (5+ messages)
` [PATCH 3/8] merge-ort: record the reason that we want a rename for a directory
[PATCH v2 5/4] Makefile/coccicheck: use --include-headers-for-types
2021-03-27 19:46 UTC (4+ messages)
` [PATCH v4 0/4] Makefile/coccicheck: fix bugs and speed it up
[BUG] Git is not using the configured SSH key when there is another SSH key added to the SSH agent
2021-03-27 18:58 UTC (3+ messages)
[PATCH] usage: trace2 BUG() invocations
2021-03-27 17:56 UTC (3+ messages)
` [PATCH v2] "
[ANNOUNCE] Git for Windows 2.31.1
2021-03-27 10:28 UTC
[PATCH v1 0/1] ci: facilitate dev to mimic a CI environment
2021-03-27 9:08 UTC (4+ messages)
` [PATCH v1 1/1] "
[ANNOUNCE] Git Rev News edition 73
2021-03-27 8:30 UTC
A note from the maintainer
2021-03-27 6:59 UTC (2+ messages)
[ANNOUNCE] Git v2.31.1
2021-03-26 22:52 UTC
[PATCH] format-patch: give an overview of what a "patch" message is
2021-03-26 22:41 UTC (5+ messages)
[PATCH 0/3] Convert index writes to use hashfile API
2021-03-26 20:16 UTC (2+ messages)
[PATCH v5 00/21] Offer to run CI/PR builds in Azure Pipelines
2021-03-26 19:54 UTC (10+ messages)
` [PATCH v6 "
` [PATCH v6 16/21] mingw: try to work around issues with the test cleanup
page: next (older) | prev (newer) | latest
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).