git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-05-27 08:37:28 to 2021-05-29 07:11:39 UTC [more...]

[PATCH v2 0/6] Unconvolutize push.default=simple
 2021-05-29  7:11 UTC  (7+ messages)
` [PATCH v2 1/6] push: hedge code of default=simple
` [PATCH v2 2/6] push: move code to setup_push_simple()
` [PATCH v2 3/6] push: reorganize setup_push_simple()
` [PATCH v2 4/6] push: simplify setup_push_simple()
` [PATCH v2 5/6] push: remove unused code in setup_push_upstream()
` [PATCH v2 6/6] doc: push: explain default=simple correctly

[PATCH 00/11] Unconvolutize push.default=simple
 2021-05-29  5:38 UTC  (24+ messages)
` [PATCH 01/11] push: hedge code of default=simple
` [PATCH 02/11] push: move code to setup_push_simple()
` [PATCH 03/11] push: reorganize setup_push_simple()
` [PATCH 04/11] push: simplify setup_push_simple()
` [PATCH 05/11] push: remove unused code in setup_push_upstream()
` [PATCH 06/11] push: merge current and simple
` [PATCH 07/11] push: remove redundant check
` [PATCH 08/11] push: fix Yoda condition
` [PATCH 09/11] push: remove trivial function
` [PATCH 10/11] push: flip !triangular for centralized
` [PATCH 11/11] doc: push: explain default=simple correctly

bug report: git checkout deletes worktree file even though it is excluded by sparse-checkout
 2021-05-28 22:44 UTC  (2+ messages)

time needed to rebase shortend by using --onto?
 2021-05-28 22:26 UTC  (10+ messages)

git push doesn't use local branch name as default
 2021-05-28 21:12 UTC  (10+ messages)
        ` git push default doesn't make sense

Bug when cloning a repository with a default branch called HEAD
 2021-05-28 19:05 UTC 

[PATCH 0/5] Optimization batch 12: miscellaneous unthemed stuff
 2021-05-28 18:09 UTC  (12+ messages)
` [PATCH 1/5] merge-ort: replace string_list_df_name_compare with faster alternative
` [PATCH 2/5] diffcore-rename: avoid unnecessary strdup'ing in break_idx
` [PATCH 3/5] diffcore-rename: enable limiting rename detection to relevant destinations
` [PATCH 4/5] Fix various issues found in comments
` [PATCH 5/5] merge-ort: miscellaneous touch-ups

[PATCH 0/2] [GSOC] ref-filter: add %(raw) atom
 2021-05-28 16:38 UTC  (14+ messages)
` [PATCH 1/2] "
` [PATCH 2/2] [GSOC] ref-filter: add %(header) atom

[PATCH v3 00/13] send-email: various optimizations to speed up by >2x
 2021-05-28 16:13 UTC  (25+ messages)
` [PATCH v4 "
  ` [PATCH v4 10/13] send-email: lazily load modules for a big speedup
  ` [PATCH v4 12/13] send-email: move trivial config handling to Perl
  ` [PATCH v5 00/13] send-email: various optimizations to speed up by >2x
    ` [PATCH v5 01/13] send-email tests: support GIT_TEST_PERL_FATAL_WARNINGS=true
    ` [PATCH v5 02/13] send-email tests: test for boolean variables without a value
    ` [PATCH v5 03/13] send-email: remove non-working support for "sendemail.smtpssl"
    ` [PATCH v5 04/13] send-email: refactor sendemail.smtpencryption config parsing
    ` [PATCH v5 05/13] send-email: copy "config_regxp" into git-send-email.perl
    ` [PATCH v5 06/13] send-email: lazily load config for a big speedup
    ` [PATCH v5 07/13] send-email: lazily shell out to "git var"
    ` [PATCH v5 08/13] send-email: use function syntax instead of barewords
    ` [PATCH v5 09/13] send-email: get rid of indirect object syntax
    ` [PATCH v5 10/13] send-email: lazily load modules for a big speedup
    ` [PATCH v5 11/13] perl: lazily load some common Git.pm setup code
    ` [PATCH v5 12/13] send-email: move trivial config handling to Perl
    ` [PATCH v5 13/13] perl: nano-optimize by replacing Cwd::cwd() with Cwd::getcwd()

[PATCH 0/9] send-email: various optimizations to speed up by >2x
 2021-05-28 15:49 UTC  (7+ messages)
` [PATCH v2 00/10] "

[PATCH v3 4/4] maintenance: optionally use systemd timers on Linux
 2021-05-28 14:44 UTC  (14+ messages)
                ` CoC, inclusivity etc. (was "Re: [...] systemd timers on Linux")

Should we do something with #git-devel on Freenode?
 2021-05-28 14:37 UTC  (13+ messages)

[PATCH v8 00/37] config-based hooks
 2021-05-28 14:11 UTC  (44+ messages)
` [PATCH v9 00/37] propose "
  ` [PATCH v9 22/37] read-cache: convert post-index-change hook to use config
  ` [PATCH v9 34/37] git-send-email: use 'git hook run' for 'sendemail-validate'
    ` [PATCH 00/31] minimal restart of "config-based-hooks"
      ` [PATCH 01/31] hooks tests: don't leave "actual" nonexisting on failure
      ` [PATCH 02/31] gc tests: add a test for the "pre-auto-gc" hook
      ` [PATCH 03/31] hook: add 'run' subcommand
      ` [PATCH 04/31] run-command.h: move find_hook() to hook.h
      ` [PATCH 05/31] hook.c: add a hook_exists() wrapper and use it in bugreport.c
      ` [PATCH 06/31] gc: use hook library for pre-auto-gc hook
      ` [PATCH 07/31] rebase: teach pre-rebase to use hook.h
      ` [PATCH 08/31] am: convert applypatch hooks to use config
      ` [PATCH 09/31] hooks: convert 'post-checkout' hook to hook library
      ` [PATCH 10/31] merge: use config-based hooks for post-merge hook
      ` [PATCH 11/31] git hook run: add an --ignore-missing flag
      ` [PATCH 12/31] send-email: use 'git hook run' for 'sendemail-validate'
      ` [PATCH 13/31] git-p4: use 'git hook' to run hooks
      ` [PATCH 14/31] commit: use hook.h to execute hooks
      ` [PATCH 15/31] read-cache: convert post-index-change hook to use config
      ` [PATCH 16/31] receive-pack: convert push-to-checkout hook to hook.h
      ` [PATCH 17/31] run-command: allow stdin for run_processes_parallel
      ` [PATCH 18/31] hook: support passing stdin to hooks
      ` [PATCH 19/31] am: convert 'post-rewrite' hook to hook.h
      ` [PATCH 20/31] run-command: add stdin callback for parallelization
      ` [PATCH 21/31] hook: provide stdin by string_list or callback
      ` [PATCH 22/31] hook: convert 'post-rewrite' hook in sequencer.c to hook.h
      ` [PATCH 23/31] transport: convert pre-push hook to use config
      ` [PATCH 24/31] reference-transaction: use hook.h to run hooks
      ` [PATCH 25/31] run-command: allow capturing of collated output
      ` [PATCH 26/31] hooks: allow callers to capture output
      ` [PATCH 27/31] receive-pack: convert 'update' hook to hook.h
      ` [PATCH 28/31] post-update: use hook.h library
      ` [PATCH 29/31] receive-pack: convert receive hooks to hook.h
      ` [PATCH 30/31] hooks: fix a TOCTOU in "did we run a hook?" heuristic
      ` [PATCH 31/31] hook-list.h: add a generated list of hooks, like config-list.h

[ANNOUNCE] Git for Windows 2.32.0-rc2
 2021-05-28 13:21 UTC 

Fetching single tag in shallow clone almost unshallow the clone
 2021-05-28 12:46 UTC  (3+ messages)

[PATCH v3 00/12] Sparse-index: integrate with status
 2021-05-28 11:36 UTC  (4+ messages)
` [PATCH v4 "
  ` [PATCH v4 07/12] unpack-trees: be careful around sparse directory entries

[PATCH][GSoC] submodule: introduce add-clone helper for submodule add
 2021-05-28  8:12 UTC 

[ANNOUNCE] Git v2.32.0-rc2
 2021-05-28  6:13 UTC 

git rm --pathspec-from-file does not work in subdirectories
 2021-05-28  5:56 UTC  (4+ messages)

[PATCH 0/5] fsck: improve error reporting
 2021-05-28  5:41 UTC  (8+ messages)
` [PATCH v3 00/17] fsck: better "invalid object" "
  ` [PATCH v3 04/17] cat-file tests: test that --allow-unknown-type isn't on by default

[BUG REPORT] File names that contain UTF8 characters are unnecessarily escaped in 'git status .' messages
 2021-05-28  4:45 UTC  (8+ messages)

Bug: git p4 clone fails if non unicode files with +k or+ko attributes are present
 2021-05-28  4:18 UTC 

[PATCH v3 0/5] doc: asciidoc cleanups
 2021-05-28  1:12 UTC  (8+ messages)

Product Inquiry [JL] 05/27/21,,
 2021-05-27 16:02 UTC 

[ANNOUNCE] Git Rev News edition 75
 2021-05-27 20:39 UTC 

git push doesn't use local branch name as default
 2021-05-27 19:51 UTC  (2+ messages)

Runaway sed memory use in test on older sed+glibc (was "Re: [PATCH v6 1/3] test: add helper functions for git-bundle")
 2021-05-27 19:19 UTC  (5+ messages)

[PATCH v3 17/17] fsck: report invalid object type-path combinations
 2021-05-27 18:28 UTC  (2+ messages)

[PATCH v3 16/17] fsck: report invalid types recorded in objects
 2021-05-27 18:24 UTC  (2+ messages)

[PATCH v3 14/17] fsck: don't hard die on invalid object types
 2021-05-27 18:18 UTC  (2+ messages)

[PATCH v3 12/17] object-file.c: return -2 on "header too long" in unpack_loose_header()
 2021-05-27 17:54 UTC  (2+ messages)

[PATCH v3 11/17] object-file.c: stop dying in parse_loose_header()
 2021-05-27 17:50 UTC  (2+ messages)

[PATCH] doc: replace jargon word "impact" with "effect"/"affect"
 2021-05-27 16:43 UTC  (14+ messages)

fast forward merge overwriting my code
 2021-05-27 15:12 UTC  (12+ messages)

[PATCH 0/8] Speed up connectivity checks via quarantine dir
 2021-05-27 14:38 UTC  (4+ messages)
` [PATCH 7/8] receive-pack: skip connectivity checks on delete-only commands

SunCC doesn't compile v2.32.0-rc* anymore (was "Re: [PATCH 2/3] t/helper/test-bitmap.c: initial commit")
 2021-05-27 12:51 UTC  (4+ messages)
` [PATCH] pack-objects: move builtin-only code to its own header

[PATCH] t2080: fix cp invocation to copy symlinks instead of following them
 2021-05-27 12:51 UTC  (2+ messages)

[PATCH] doc: replace jargon word "impact" with "effect"/"affect"
 2021-05-27 11:20 UTC  (4+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).