git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Eric Sunshine <sunshine@sunshineco.com>
To: Karthik Nayak <karthik.188@gmail.com>
Cc: Git List <git@vger.kernel.org>,
	Christian Couder <christian.couder@gmail.com>,
	Matthieu Moy <Matthieu.Moy@grenoble-inp.fr>,
	Junio C Hamano <gitster@pobox.com>
Subject: Re: [PATCH v9 02/11] ref-filter: introduce ref_formatting_state
Date: Fri, 7 Aug 2015 00:43:02 -0400	[thread overview]
Message-ID: <CAPig+cTt__tphEqFuyeOiTadOL9cAi51RLd3z6rr3nM-8Qp6Aw@mail.gmail.com> (raw)
In-Reply-To: <CAOLa=ZSp3aL0Z5YP5xmzdW7H92yU3EA+MJjLYA29QyoZTD5RiA@mail.gmail.com>

On Thu, Aug 6, 2015 at 11:53 PM, Karthik Nayak <karthik.188@gmail.com> wrote:
> On Fri, Aug 7, 2015 at 5:49 AM, Eric Sunshine <sunshine@sunshineco.com> wrote:
>> On Tue, Aug 4, 2015 at 8:42 AM, Karthik Nayak <karthik.188@gmail.com> wrote:
>>> +static void apply_formatting_state(struct ref_formatting_state *state, struct strbuf *final)
>>> +{
>>> +       /* More formatting options to be evetually added */
>>> +       strbuf_addbuf(final, state->output);
>>> +       strbuf_release(state->output);
>>
>> I guess the idea here is that you intend state->output to be re-used
>> and it is convenient to "clear" it here rather than making that the
>> responsibility of each caller. For re-use, it is more typical to use
>> strbuf_reset() than strbuf_release() (though Junio may disagree[1]).
>
> it seems like a smarter way to around this without much overhead But it
> was more of to release it as its no longer required unless another modifier atom
> is encountered. Is it worth keeping hoping for another modifier atom eventually,
> and release it at the end like you suggested below?

If I understand your question correctly, it sounds like you're asking
about a memory micro-optimization. From an architectural standpoint,
it's cleaner for the entity which allocates a resource to also release
it. In this case, show_ref_array_item() allocates the strbuf, thus it
should be the one to release it.

And, although we shouldn't be worrying about micro-optimizations at
this point, if it were to be an issue, resetting the strbuf via
strbuf_reset(), which doesn't involve slow memory
deallocation/reallocation, is likely to be a winner over repeated
strbuf_release().

>>> +       memset(&state, 0, sizeof(state));
>>> +       state.quote_style = quote_style;
>>> +       state.output = &value;
>>
>> It feels strange to assign a local variable reference to state.output,
>> and there's no obvious reason why you should need to do so. I would
>> have instead expected ref_format_state to be declared as:
>>
>>     struct ref_formatting_state {
>>        int quote_style;
>>        struct strbuf output;
>>     };
>>
>> and initialized as so:
>>
>>     memset(&state, 0, sizeof(state));
>>     state.quote_style = quote_style;
>>     strbuf_init(&state.output, 0);
>
> This looks neater, thanks. It'll go along with the previous patch.
>
>> (In fact, the memset() isn't even necessary here since you're
>> initializing all fields explicitly, though perhaps you want the
>> memset() because a future patch adds more fields which are not
>> initialized explicitly?)
>
> Yea the memset is needed for bit fields evnetually added in the future.

Perhaps move the memset() to the first patch which actually requires
it, where it won't be (effectively) dead code, as it becomes here once
you make the above change.

>>>         for (cp = format; *cp && (sp = find_next(cp)); cp = ep + 1) {
>>> -               struct atom_value *atomv;
>>> +               struct atom_value *atomv = NULL;
>>
>> What is this change about?
>
> To remove the warning about atomv being unassigned before usage.

Hmm, where were you seeing that warning? The first use of 'atomv'
following its declaration is in the get_ref_atom_value() below, and
(as far as the compiler knows) that should be setting its value.

>>>                 ep = strchr(sp, ')');
>>> -               if (cp < sp)
>>> -                       emit(cp, sp, &output);
>>> +               if (cp < sp) {
>>> +                       emit(cp, sp, &state);
>>> +                       apply_formatting_state(&state, &final_buf);
>>> +               }
>>>                 get_ref_atom_value(info, parse_ref_filter_atom(sp + 2, ep), &atomv);
>>> -               print_value(atomv, quote_style, &output);
>>> +               process_formatting_state(atomv, &state);
>>> +               print_value(atomv, &state);
>>> +               apply_formatting_state(&state, &final_buf);
>>>         }
>>>         if (*cp) {
>>>                 sp = cp + strlen(cp);
>>> -               emit(cp, sp, &output);
>>> +               emit(cp, sp, &state);
>>> +               apply_formatting_state(&state, &final_buf);
>>
>> I'm getting the feeling that these functions
>> (process_formatting_state, print_value, emit, apply_formatting_state)
>> are becoming misnamed (again) with the latest structural changes (but
>> perhaps I haven't read far enough into the series yet?).
>>
>> process_formatting_state() is rather generic.
>
> perhaps set_formatting_state()?

I don't know. I don't have a proper high-level overview of the
functionality yet to say if that is a good name or not (which is one
reason I didn't suggest an alternative).

>> print_value() and emit() both imply outputting something, but neither
>> does so anymore.
>
> I think I'll append a "to_state" to each of them.

Meh. print_value() might be better named format_value(). emit() might
become append_literal() or append_non_atom() or something.

>> apply_formatting_state() seems to be more about finalizing the
>> already-formatted output.
>
> perform_state_formatting()? perhaps.

Dunno.

  reply	other threads:[~2015-08-07  4:43 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-08-04 12:39 [PATCH v9 0/11] Port tag.c over to use ref-filter APIs Karthik Nayak
2015-08-04 12:42 ` [PATCH v9 01/11] ref-filter: print output to strbuf for formatting Karthik Nayak
2015-08-04 12:42   ` [PATCH v9 02/11] ref-filter: introduce ref_formatting_state Karthik Nayak
2015-08-07  0:19     ` Eric Sunshine
2015-08-07  3:53       ` Karthik Nayak
2015-08-07  4:43         ` Eric Sunshine [this message]
2015-08-07 11:37           ` Karthik Nayak
2015-08-07 17:30             ` Eric Sunshine
2015-08-07 17:50               ` Karthik Nayak
2015-08-07  3:36     ` Eric Sunshine
2015-08-04 12:43   ` [PATCH v9 03/11] ref-filter: implement an `align` atom Karthik Nayak
2015-08-04 12:43   ` [PATCH v9 04/11] ref-filter: add option to filter only tags Karthik Nayak
2015-08-04 12:43   ` [PATCH v9 05/11] ref-filter: support printing N lines from tag annotation Karthik Nayak
2015-08-04 12:43   ` [PATCH v9 06/11] ref-filter: add support to sort by version Karthik Nayak
2015-08-04 12:43   ` [PATCH v9 07/11] ref-filter: add option to match literal pattern Karthik Nayak
2015-08-04 12:43   ` [PATCH v9 08/11] tag.c: use 'ref-filter' data structures Karthik Nayak
2015-08-04 12:43   ` [PATCH v9 09/11] tag.c: use 'ref-filter' APIs Karthik Nayak
2015-08-04 12:43   ` [PATCH v9 10/11] tag.c: implement '--format' option Karthik Nayak
2015-08-04 12:43   ` [PATCH v9 11/11] tag.c: implement '--merged' and '--no-merged' options Karthik Nayak
2015-08-06 22:21   ` [PATCH v9 01/11] ref-filter: print output to strbuf for formatting Eric Sunshine
2015-08-07  3:24     ` Karthik Nayak

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAPig+cTt__tphEqFuyeOiTadOL9cAi51RLd3z6rr3nM-8Qp6Aw@mail.gmail.com \
    --to=sunshine@sunshineco.com \
    --cc=Matthieu.Moy@grenoble-inp.fr \
    --cc=christian.couder@gmail.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=karthik.188@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).