git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Ævar Arnfjörð Bjarmason" <avarab@gmail.com>
To: git@vger.kernel.org
Cc: "Junio C Hamano" <gitster@pobox.com>,
	"Derrick Stolee" <derrickstolee@github.com>,
	"Ævar Arnfjörð Bjarmason" <avarab@gmail.com>
Subject: [PATCH 0/2] For v2.37.0: rename fetch.credentialsInUrl to transfer.credentialsInUrl
Date: Wed, 15 Jun 2022 12:44:10 +0200	[thread overview]
Message-ID: <cover-0.2-00000000000-20220615T103852Z-avarab@gmail.com> (raw)

The $subject is a case where nothing is broken except potential user
expectations, but as argued in 2/2 I think we really should rename
this before we kick it out the door.

Having a "fetch" configuration configure "git push" is really
confusing, and once we need to support it backing out of it would be a
hassle.

Then 1/2 clarifies how it really works, and what it's aimed to do, and
notes the major caveat that the check doesn't cover "pushurl"
configuration, which in some setups is the only place you'll put
passwords in URLs. I think it likewise makes sense to have that in
v2.37.0 so we won't lull users into a false sense of security.

This is a relatively large change for an "rc", but the only code
changes are s/fetch\.credentialsInUrl/transfer.credentialsInUrl/g, the
rest is all docs.

There's a trivial conflict with my just-submitted
https://lore.kernel.org/git/cover-0.1-00000000000-20220615T103609Z-avarab@gmail.com:
The relevant "test_expect_success" line needs a "LIBCURL" prerequisite
added in the merge conflict.

Ævar Arnfjörð Bjarmason (2):
  fetch doc: note "pushurl" caveat about "credentialsInUrl", elaborate
  transfer doc: move fetch.credentialsInUrl to "transfer" config
    namespace

 Documentation/RelNotes/2.37.0.txt |  6 +++--
 Documentation/config/fetch.txt    | 14 ------------
 Documentation/config/transfer.txt | 38 +++++++++++++++++++++++++++++++
 remote.c                          |  4 ++--
 t/t5516-fetch-push.sh             | 14 ++++++------
 t/t5601-clone.sh                  | 10 ++++----
 6 files changed, 56 insertions(+), 30 deletions(-)

-- 
2.36.1.1239.gfba91521d90


             reply	other threads:[~2022-06-15 10:44 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-06-15 10:44 Ævar Arnfjörð Bjarmason [this message]
2022-06-15 10:44 ` [PATCH 1/2] fetch doc: note "pushurl" caveat about "credentialsInUrl", elaborate Ævar Arnfjörð Bjarmason
2022-06-26 13:15   ` René Scharfe
2022-06-15 10:44 ` [PATCH 2/2] transfer doc: move fetch.credentialsInUrl to "transfer" config namespace Ævar Arnfjörð Bjarmason
2022-06-15 13:12 ` [PATCH 0/2] For v2.37.0: rename fetch.credentialsInUrl to transfer.credentialsInUrl Derrick Stolee
2022-06-15 18:35   ` Junio C Hamano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover-0.2-00000000000-20220615T103852Z-avarab@gmail.com \
    --to=avarab@gmail.com \
    --cc=derrickstolee@github.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).