git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jakub Narebski <jnareb@gmail.com>
To: Junio C Hamano <gitster@pobox.com>
Cc: git@vger.kernel.org
Subject: Re: What's cooking in git.git (Oct 2009, #01; Wed, 07)
Date: Thu, 08 Oct 2009 18:38:48 -0700 (PDT)	[thread overview]
Message-ID: <m3iqepgxcc.fsf@localhost.localdomain> (raw)
In-Reply-To: <7viqeqjsx6.fsf@alter.siamese.dyndns.org>

Junio C Hamano <gitster@pobox.com> writes:

> --------------------------------------------------
> [New Topics]

> * jn/gitweb-patch (2009-09-30) 1 commit
>  - gitweb: Do not show 'patch' link in 'commit' view for merges
> 
> jk: After some comments with Jakub, I think the code is right but he
> promised a re-roll with more in the commit message.

Not only better commit message, but a more complete patch as well.
 
> * mr/gitweb-snapshot (2009-09-26) 2 commits
>  - gitweb: append short hash ids to snapshot files
>  - gitweb: check given hash before trying to create snapshot
> 
> jk: He posted a v5 of his series. I didn't look at it closely, but Jakub
> ack'd it.

Actually I acked first patch in series (the "check hash" one), but the
second needs review, and I think corrections.  First there is matter
of tests and matter of not calling git_get_short_hash if it would not
be used (what was mentioned in my review).  But what is more important
that now that gitweb doesn't use full SHA-1 unconditionally, we have
to deal with stripping prefix from refs/tags/v1.6.3-rc3 and
refs/heads/master, and with hierarchical branch names such as
'mr/gitweb-snapshot'.  I'll post improved review soon.

In short: first patch is a go, second needs more work.

> * jc/pretty-lf (2009-10-04) 1 commit
>  - Pretty-format: %[+-]x to tweak inter-item newlines
> 
> I am not happy with this one yet.  I am contemplating to introduce a new
> syntax "%[magic(param)<anything>%]" to generalize expressions of this and
> line wrapping features in an extensible way.
> 
> * js/log-rewrap (2008-11-10) 3 commits
>  . Add "%w" to pretty formats, which rewraps the commit message
>  - Add strbuf_add_wrapped_text() to utf8.[ch]
>  - print_wrapped_text(): allow hard newlines
> 
> ... and the first two from this series will be useful to implement an
> example magic "wrap", e.g. "%{wrap(i,j,w)%s%+b%]".

So... it is magic %[...%] or %{...} or %{...%}?

BTW we can take rpm's queryformat as an example (or counterexample).
Also perhaps we can reuse minilanguage of git-for-each-ref format,
i.e. %(field:modifier).
  
> --------------------------------------------------
> [Cooking]

> * jn/gitweb-show-size (2009-09-07) 1 commit
>  - gitweb: Add 'show-sizes' feature to show blob sizes in tree view

What this one requires (beside better name for a feature)?

> * jn/gitweb-blame (2009-09-01) 5 commits
>  - gitweb: Minify gitweb.js if JSMIN is defined
>  - gitweb: Create links leading to 'blame_incremental' using JavaScript
>   (merged to 'next' on 2009-09-07 at 3622199)
>  + gitweb: Colorize 'blame_incremental' view during processing
>  + gitweb: Incremental blame (using JavaScript)
>  + gitweb: Add optional "time to generate page" info in footer
> 
> Ajax-y blame.

I reordered patches so JSMIN one is first (as it is less
controversial), but the 'create blame_incremental links' one needs
more work.

-- 
Jakub Narebski
Poland
ShadeHawk on #git

  parent reply	other threads:[~2009-10-09  1:46 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-10-08  6:33 What's cooking in git.git (Oct 2009, #01; Wed, 07) Junio C Hamano
2009-10-08  6:49 ` Johannes Schindelin
2009-10-08  6:49   ` Sverre Rabbelier
2009-10-08 17:39     ` Shawn O. Pearce
2009-10-08 17:58       ` Sverre Rabbelier
2009-10-11 11:40         ` [Vcs-fast-import-devs] " Matt McClure
2009-10-11 11:58           ` Sverre Rabbelier
2009-10-28 22:08         ` Sverre Rabbelier
2009-10-28 23:19           ` [Vcs-fast-import-devs] " Ian Clatworthy
2009-10-29 10:54           ` Johannes Schindelin
2009-10-30  3:50         ` [Vcs-fast-import-devs] " Ian Clatworthy
2009-10-30 12:41           ` Sverre Rabbelier
2009-10-08  6:58 ` Marius Storm-Olsen
2009-10-08 18:15   ` Erik Faye-Lund
2009-10-09  6:47     ` Junio C Hamano
2009-10-09  1:38 ` Jakub Narebski [this message]
2009-10-09  6:46   ` Junio C Hamano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=m3iqepgxcc.fsf@localhost.localdomain \
    --to=jnareb@gmail.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).