git.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Johannes Schindelin <Johannes.Schindelin@gmx.de>
To: Junio C Hamano <gitster@pobox.com>
Cc: Bert Wesarg <bert.wesarg@googlemail.com>, git@vger.kernel.org
Subject: Re: [PATCH] remote: rename also remotes in the branch.<name>.pushRemote config
Date: Fri, 17 Jan 2020 10:49:12 +0100 (CET)	[thread overview]
Message-ID: <nycvar.QRO.7.76.6.2001171046460.46@tvgsbejvaqbjf.bet> (raw)
In-Reply-To: <xmqq7e1rf0zg.fsf@gitster-ct.c.googlers.com>

Hi Junio,

On Thu, 16 Jan 2020, Junio C Hamano wrote:

> Bert Wesarg <bert.wesarg@googlemail.com> writes:
>
> > diff --git a/t/t5505-remote.sh b/t/t5505-remote.sh
> > index 883b32efa0..59a1681636 100755
> > --- a/t/t5505-remote.sh
> > +++ b/t/t5505-remote.sh
> > @@ -737,12 +737,14 @@ test_expect_success 'rename a remote' '
> >  	git clone one four &&
> >  	(
> >  		cd four &&
> > +		git config branch.master.pushRemote origin &&
> >  		git remote rename origin upstream &&
> >  		test -z "$(git for-each-ref refs/remotes/origin)" &&
> >  		test "$(git symbolic-ref refs/remotes/upstream/HEAD)" = "refs/remotes/upstream/master" &&
> >  		test "$(git rev-parse upstream/master)" = "$(git rev-parse master)" &&
> >  		test "$(git config remote.upstream.fetch)" = "+refs/heads/*:refs/remotes/upstream/*" &&
> > -		test "$(git config branch.master.remote)" = "upstream"
> > +		test "$(git config branch.master.remote)" = "upstream" &&
> > +		test "$(git config branch.master.pushRemote)" = "upstream"
> >  	)
> >  '
>
> OK, so the issue the patch wants to address is
>
> 	git remote rename X Y
>
> ought to rename branch.X.Z (for any value of Z) to branch.Y.Z but it
> forgot to do so for Z==pushRemote?
>
> If that is the case, I have to wonder if the patch is making the
> situation better or even worse.  Shouldn't we be not even caring
> what Z is by not having to list these specific keys?  I dunno.

I think what the code does is not rename branch.X.Z to branch.Y.Z, but for
every `branch.B.pushRemote` whose value is `X`, it will now be set to `Y`.

So we really should not touch, say, `branch.X.description` because it has
nothing to do with any renamed remote.

And yes, I agree, the commit message would have made for a splendid place
to explain something like this.

Ciao,
Dscho

  parent reply	other threads:[~2020-01-17  9:49 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-16 21:25 [PATCH] remote: rename also remotes in the branch.<name>.pushRemote config Bert Wesarg
2020-01-16 23:14 ` Junio C Hamano
2020-01-17  9:33   ` [PATCH v2] remote rename: rename branch.<name>.pushRemote config values too Bert Wesarg
2020-01-17 11:50     ` Johannes Schindelin
2020-01-17 12:37       ` Bert Wesarg
2020-01-17 13:30         ` Johannes Schindelin
2020-01-17 14:40           ` Bert Wesarg
2020-01-20 11:25             ` Johannes Schindelin
2020-01-20 13:14               ` Bert Wesarg
2020-01-20 13:51                 ` Johannes Schindelin
2020-01-17 18:48     ` Junio C Hamano
2020-01-17 20:20       ` Bert Wesarg
2020-01-17 21:24         ` Junio C Hamano
2020-01-21  9:24     ` [PATCH 0/7] remote rename: improve handling of configuration values Bert Wesarg
2020-01-21  9:24       ` [PATCH 1/7] pull --rebase/remote rename: document and honor single-letter abbreviations rebase types Bert Wesarg
2020-01-21 23:26         ` Junio C Hamano
2020-01-22  7:34           ` Bert Wesarg
2020-01-22 19:43             ` Junio C Hamano
2020-01-21  9:24       ` [PATCH 2/7] remote: clean-up by returning early to avoid one indentation Bert Wesarg
2020-01-23 23:02         ` Junio C Hamano
2020-01-21  9:24       ` [PATCH 3/7] remote: clean-up config callback Bert Wesarg
2020-01-21  9:24       ` [PATCH v3 4/7] remote rename: rename branch.<name>.pushRemote config values too Bert Wesarg
2020-01-21  9:24       ` [PATCH 5/7] [RFC] config: make `scope_name` global as `config_scope_name` Bert Wesarg
2020-01-22  0:12         ` Matt Rogers
2020-01-22  7:37           ` Bert Wesarg
2020-01-23  1:30             ` Matt Rogers
2020-01-21  9:24       ` [PATCH 6/7] config: provide access to the current line number Bert Wesarg
2020-01-21  9:24       ` [PATCH 7/7] remote rename: gently handle remote.pushDefault config Bert Wesarg
2020-01-23 23:03         ` Junio C Hamano
2020-01-24  8:49           ` Bert Wesarg
2020-01-22 15:26       ` [PATCH 0/7] remote rename: improve handling of configuration values Bert Wesarg
2020-01-17  9:49   ` Johannes Schindelin [this message]
2020-01-17  9:45 ` [PATCH] remote: rename also remotes in the branch.<name>.pushRemote config Johannes Schindelin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=nycvar.QRO.7.76.6.2001171046460.46@tvgsbejvaqbjf.bet \
    --to=johannes.schindelin@gmx.de \
    --cc=bert.wesarg@googlemail.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).