historical-speck.lore.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: speck@linutronix.de
Subject: Re: [PATCH 2/2] more sampling fun 2
Date: Wed, 26 Feb 2020 22:16:46 +0100	[thread overview]
Message-ID: <875zftoxq9.fsf@nanos.tec.linutronix.de> (raw)
In-Reply-To: <20200226202010.k42cf4625ckk6ym6@treble>

speck for Josh Poimboeuf <speck@linutronix.de> writes:
> On Tue, Feb 25, 2020 at 03:59:06PM +0100, speck for Borislav Petkov wrote:
>> > I'd expect to call this one "SRBDS" a year from now. I find
>> > "srb_sampling" to be confusing and hard to remember because it renames
>> > something that already has an industry standard name.
>> srb_sampling *is* srbds - just more readable.
>> We are not giving any new names to the vulns - we're simply making our command
>> line options more readable so that when you have to type them, you either have
>> to remember "srbds" - in that order - or "srb sampling".
>> Latter is easier for me.
> But you're leaving out the "data" portion of the acronym/name.
> Either call it "srbds" or "special_register_buffer_data_sampling" -- but
> *please* don't give it a new name.  It will just create more confusion.
> If you can't remember what srbds stands for, that's why we have
> documentation and search engines.

Our command line options for this mess are inconsistent already, but for
most of them we have actual acronyms used, so lets just go with srbds.

Having a half correct, but more elaborate one does not really help. If
at all you want to come up with a snarky one like:

   super_random_but_data_stolen = [hell_no, shrug, nsa]



  reply	other threads:[~2020-02-26 21:16 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-24 17:31 [MODERATED] " Konrad Rzeszutek Wilk
2020-02-24 18:17 ` [MODERATED] " Borislav Petkov
2020-02-24 21:39   ` mark gross
2020-02-24 23:10     ` [MODERATED] " Borislav Petkov
2020-02-25  1:26       ` Josh Poimboeuf
2020-02-25 10:46         ` Borislav Petkov
2020-02-25 14:18           ` Josh Poimboeuf
2020-02-25 14:23             ` Jiri Kosina
2020-02-25 14:44               ` Josh Poimboeuf
2020-02-25 14:59             ` Borislav Petkov
2020-02-26 20:20               ` Josh Poimboeuf
2020-02-26 21:16                 ` Thomas Gleixner [this message]
2020-02-26 22:19                   ` Konrad Rzeszutek Wilk

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=875zftoxq9.fsf@nanos.tec.linutronix.de \
    --to=tglx@linutronix.de \
    --cc=speck@linutronix.de \
    --subject='Re: [PATCH 2/2] more sampling fun 2' \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).