kernel-hardening.lists.openwall.com archive mirror
 help / color / mirror / Atom feed
 messages from 2019-12-24 22:57:04 to 2020-02-06 19:28:31 UTC [more...]

[RFC PATCH 00/11] Finer grained kernel address space randomization
 2020-02-06 19:27 UTC  (47+ messages)
` [RFC PATCH 01/11] modpost: Support >64K sections
` [RFC PATCH 02/11] x86: tools/relocs: Support >64K section headers
` [RFC PATCH 03/11] x86/boot: Allow a "silent" kaslr random byte fetch
` [RFC PATCH 04/11] x86/boot/KASLR: Introduce PRNG for faster shuffling
` [RFC PATCH 05/11] x86: Makefile: Add build and config option for CONFIG_FG_KASLR
` [RFC PATCH 06/11] x86: make sure _etext includes function sections
` [RFC PATCH 07/11] x86/tools: Adding relative relocs for randomized functions
` [RFC PATCH 08/11] x86: Add support for finer grained KASLR
` [RFC PATCH 09/11] kallsyms: hide layout and expose seed
` [RFC PATCH 10/11] module: Reorder functions
` [RFC PATCH 11/11] x86/boot: Move "boot heap" out of .bss

[PATCH v3 0/6] implement KASLR for powerpc/fsl_booke/64
 2020-02-06  2:58 UTC  (7+ messages)
` [PATCH v3 1/6] powerpc/fsl_booke/kaslr: refactor kaslr_legal_offset() and kaslr_early_init()
` [PATCH v3 2/6] powerpc/fsl_booke/64: introduce reloc_kernel_entry() helper
` [PATCH v3 3/6] powerpc/fsl_booke/64: implement KASLR for fsl_booke64
` [PATCH v3 4/6] powerpc/fsl_booke/64: do not clear the BSS for the second pass
` [PATCH v3 5/6] powerpc/fsl_booke/64: clear the original kernel if randomized
` [PATCH v3 6/6] powerpc/fsl_booke/kaslr: rename kaslr-booke32.rst to kaslr-booke.rst and add 64bit part

[PATCH v2 0/6] implement KASLR for powerpc/fsl_booke/64
 2020-02-05  5:13 UTC  (8+ messages)
` [PATCH v2 1/6] powerpc/fsl_booke/kaslr: refactor kaslr_legal_offset() and kaslr_early_init()
` [PATCH v2 2/6] powerpc/fsl_booke/64: introduce reloc_kernel_entry() helper
` [PATCH v2 3/6] powerpc/fsl_booke/64: implement KASLR for fsl_booke64
` [PATCH v2 4/6] powerpc/fsl_booke/64: do not clear the BSS for the second pass
` [PATCH v2 5/6] powerpc/fsl_booke/64: clear the original kernel if randomized
` [PATCH v2 6/6] powerpc/fsl_booke/kaslr: rename kaslr-booke32.rst to kaslr-booke.rst and add 64bit part

[ANNOUNCE][CFP] Linux Security Summit North America 2020
 2020-02-03 23:59 UTC 

[PATCH v2] drm/radeon: have the callers of set_memory_*() check the return value
 2020-02-03 20:44 UTC  (3+ messages)

[kernel-hardening] [PATCH v5 00/38] Hardened usercopy whitelisting
 2020-02-03 17:41 UTC  (23+ messages)
` [kernel-hardening] [PATCH 09/38] usercopy: Mark kmalloc caches as usercopy caches

[PATCH v6 0/5] Implement STRICT_MODULE_RWX for powerpc
 2020-02-03  7:06 UTC  (11+ messages)
` [PATCH v6 1/5] powerpc/mm: Implement set_memory() routines
` [PATCH v6 2/5] powerpc/kprobes: Mark newly allocated probes as RO
` [PATCH v6 3/5] powerpc/mm/ptdump: debugfs handler for W+X checks at runtime

[PATCH] lkdtm: Test KUAP directional user access unlocks on powerpc
 2020-02-01 16:40 UTC  (6+ messages)

[PATCH 1/2] powerpc/book3s64/hash: Disable 16M linear mapping size if not aligned
 2020-01-29  5:17 UTC  (2+ messages)

[PATCH 00/18] add support for Clang's Shadow Call Stack
 2020-01-28 22:50 UTC  (38+ messages)
` [PATCH v6 00/15] "
  ` [PATCH v6 08/15] arm64: disable function graph tracing with SCS
  ` [PATCH v6 09/15] arm64: reserve x18 from general allocation "
  ` [PATCH v6 10/15] arm64: preserve x18 when CPU is suspended
  ` [PATCH v6 11/15] arm64: efi: restore x18 if it was corrupted
  ` [PATCH v6 12/15] arm64: vdso: disable Shadow Call Stack
  ` [PATCH v6 13/15] arm64: disable SCS for hypervisor code
  ` [PATCH v6 14/15] arm64: implement Shadow Call Stack
  ` [PATCH v6 15/15] arm64: scs: add shadow stacks for SDEI
` [PATCH v7 00/11] add support for Clang's Shadow Call Stack
  ` [PATCH v7 01/11] add support for Clang's Shadow Call Stack (SCS)
  ` [PATCH v7 02/11] scs: add accounting
  ` [PATCH v7 03/11] scs: add support for stack usage debugging
  ` [PATCH v7 04/11] scs: disable when function graph tracing is enabled
  ` [PATCH v7 05/11] arm64: reserve x18 from general allocation with SCS
  ` [PATCH v7 06/11] arm64: preserve x18 when CPU is suspended
  ` [PATCH v7 07/11] arm64: efi: restore x18 if it was corrupted
  ` [PATCH v7 08/11] arm64: vdso: disable Shadow Call Stack
  ` [PATCH v7 09/11] arm64: disable SCS for hypervisor code
  ` [PATCH v7 10/11] arm64: implement Shadow Call Stack
  ` [PATCH v7 11/11] arm64: scs: add shadow stacks for SDEI

[PATCH v7 00/11] proc: modernize proc to support multiple private instances
 2020-01-28 14:58 UTC  (16+ messages)
` [PATCH v7 01/11] proc: Rename struct proc_fs_info to proc_fs_opts
` [PATCH v7 02/11] proc: add proc_fs_info struct to store proc information
` [PATCH v7 03/11] proc: move /proc/{self|thread-self} dentries to proc_fs_info
` [PATCH v7 04/11] proc: move hide_pid, pid_gid from pid_namespace "
` [PATCH v7 05/11] proc: add helpers to set and get proc hidepid and gid mount options
` [PATCH v7 06/11] proc: support mounting procfs instances inside same pid namespace
` [PATCH v7 07/11] proc: flush task dcache entries from all procfs instances
` [PATCH v7 08/11] proc: instantiate only pids that we can ptrace on 'hidepid=4' mount option
` [PATCH v7 09/11] proc: add option to mount only a pids subset
` [PATCH v7 10/11] docs: proc: add documentation for "hidepid=4" and "subset=pidfs" options and new mount behavior
` [PATCH v7 11/11] proc: Move hidepid values to uapi as they are user interface to mount

[PATCH 0/5] Annotate allocation functions with alloc_size attribute
 2020-01-20 22:51 UTC  (8+ messages)
` [PATCH 1/5] altera-stapl: altera_get_note: prevent write beyond end of 'key'
` [PATCH 2/5] [RFC] kasan: kasan_test: hide allocation sizes from the compiler
` [PATCH 3/5] [RFC] staging: rts5208: make len a u16 in rtsx_write_cfg_seq
` [PATCH 4/5] [VERY RFC] mm: kmalloc(_node): return NULL immediately for SIZE_MAX
` [PATCH 5/5] [RFC] mm: annotate memory allocation functions with their sizes

[PATCH v2 0/2] FORTIFY_SOURCE: detect intra-object overflow in string functions
 2020-01-20  4:54 UTC  (3+ messages)
` [PATCH v2 1/2] string.h: detect intra-object overflow in fortified "
` [PATCH v2 2/2] lkdtm: tests for FORTIFY_SOURCE

[PATCH] string.h: detect intra-object overflow in fortified string functions
 2020-01-20  0:27 UTC  (3+ messages)

[PATCH v3 0/6] ubsan: Split out bounds checker
 2020-01-18  9:19 UTC  (13+ messages)
` [PATCH v3 1/6] ubsan: Add trap instrumentation option
` [PATCH v3 2/6] ubsan: Split "bounds" checker from other options
` [PATCH v3 3/6] lkdtm/bugs: Add arithmetic overflow and array bounds checks
` [PATCH v3 4/6] ubsan: Check panic_on_warn
` [PATCH v3 5/6] kasan: Unset panic_on_warn before calling panic()
` [PATCH v3 6/6] ubsan: Include bug type in report header

[PATCH 0/2] drm/radeon: have the callers of set_memory_*() check the return value
 2020-01-09 20:16 UTC  (10+ messages)
` [PATCH 1/2] "
` [PATCH 2/2] drm/radeon: change call sites to handle return value properly

[RFC v5 43/57] gcc-plugins: objtool: Add plugin to detect switch table on arm64
 2020-01-09 16:02 UTC 

[PATCH v6 00/10] proc: modernize proc to support multiple private instances
 2020-01-08 10:37 UTC  (17+ messages)
` [PATCH v6 01/10] proc: Rename struct proc_fs_info to proc_fs_opts
` [PATCH v6 02/10] proc: add proc_fs_info struct to store proc information
` [PATCH v6 03/10] proc: move /proc/{self|thread-self} dentries to proc_fs_info
` [PATCH v6 04/10] proc: move hide_pid, pid_gid from pid_namespace "
` [PATCH v6 05/10] proc: add helpers to set and get proc hidepid and gid mount options
` [PATCH v6 06/10] proc: support mounting procfs instances inside same pid namespace
` [PATCH v6 07/10] proc: flush task dcache entries from all procfs instances
` [PATCH v6 08/10] proc: instantiate only pids that we can ptrace on 'hidepid=3' mount option
` [PATCH v6 09/10] proc: add option to mount only a pids subset
` [PATCH v6 10/10] docs: proc: add documentation for "hidepid=3" and "pidonly" options and new mount behavior

[PATCH] gcc-plugins: make it possible to disable CONFIG_GCC_PLUGINS again
 2019-12-30 19:41 UTC  (6+ messages)

[PATCH v10 00/11] x86: PIE support to extend KASLR randomization
 2019-12-30 18:52 UTC  (3+ messages)

[RESEND RFC 0/2] Paravirtualized Control Register pinning
 2019-12-24 22:56 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).