kernel-hardening.lists.openwall.com archive mirror
 help / color / mirror / Atom feed
 messages from 2020-03-02 09:37:43 to 2020-03-26 15:49:15 UTC [more...]

[PATCH v2 0/5] Optionally randomize kernel stack offset each syscall
 2020-03-26 15:48 UTC  (16+ messages)
` [PATCH v2 1/5] jump_label: Provide CONFIG-driven build state defaults
` [PATCH v2 2/5] init_on_alloc: Unpessimize default-on builds
` [PATCH v2 3/5] stack: Optionally randomize kernel stack offset each syscall
` [PATCH v2 4/5] x86/entry: Enable random_kstack_offset support
` [PATCH v2 5/5] arm64: entry: "

[PATCH 1/2] kconfig: remove unused variable in qconf.cc
 2020-03-26  2:06 UTC  (4+ messages)
` [PATCH 2/2] kbuild: add -Wall to KBUILD_HOSTCXXFLAGS

[PATCH RESEND v9 0/8] proc: modernize proc to support multiple private instances
 2020-03-25 19:16 UTC  (14+ messages)
` [PATCH RESEND v9 1/8] proc: rename struct proc_fs_info to proc_fs_opts
` [PATCH RESEND v9 2/8] proc: allow to mount many instances of proc in one pid namespace
` [PATCH RESEND v9 3/8] proc: move hide_pid, pid_gid from pid_namespace to proc_fs_info
    ` [PATCH v9 9/8] proc: use named enums for better readability
` [PATCH RESEND v9 4/8] proc: instantiate only pids that we can ptrace on 'hidepid=4' mount option
` [PATCH RESEND v9 5/8] proc: add option to mount only a pids subset
` [PATCH RESEND v9 6/8] docs: proc: add documentation for "hidepid=4" and "subset=pidfs" options and new mount behavior
` [PATCH RESEND v9 7/8] proc: move hidepid values to uapi as they are user interface to mount
` [PATCH RESEND v9 8/8] proc: use human-readable values for hidehid

[RFC PATCH 00/11] Finer grained kernel address space randomization
 2020-03-25 15:34 UTC  (12+ messages)
` [RFC PATCH 05/11] x86: Makefile: Add build and config option for CONFIG_FG_KASLR
` [RFC PATCH 09/11] kallsyms: hide layout and expose seed

Curiosity around 'exec_id' and some problems associated with it
 2020-03-24 21:50 UTC 

[RFC PATCH 00/21] Improve list integrity checking
 2020-03-24 21:33 UTC  (40+ messages)
` [RFC PATCH 01/21] list: Remove hlist_unhashed_lockless()
` [RFC PATCH 02/21] list: Remove hlist_nulls_unhashed_lockless()
` [RFC PATCH 03/21] list: Annotate lockless list primitives with data_race()
` [RFC PATCH 04/21] timers: Use hlist_unhashed() instead of open-coding in timer_pending()
` [RFC PATCH 05/21] list: Comment missing WRITE_ONCE() in __list_del()
` [RFC PATCH 06/21] list: Remove superfluous WRITE_ONCE() from hlist_nulls implementation
` [RFC PATCH 07/21] Revert "list: Use WRITE_ONCE() when adding to lists and hlists"
` [RFC PATCH 08/21] Revert "list: Use WRITE_ONCE() when initializing list_head structures"
` [RFC PATCH 09/21] list: Remove unnecessary WRITE_ONCE() from hlist_bl_add_before()
` [RFC PATCH 10/21] kernel-hacking: Make DEBUG_{LIST,PLIST,SG,NOTIFIERS} non-debug options
` [RFC PATCH 11/21] list: Add integrity checking to hlist implementation
` [RFC PATCH 12/21] list: Poison ->next pointer for non-RCU deletion of 'hlist_nulls_node'
` [RFC PATCH 13/21] list: Add integrity checking to hlist_nulls implementation
` [RFC PATCH 14/21] plist: Use CHECK_DATA_CORRUPTION instead of explicit {BUG,WARN}_ON()
` [RFC PATCH 15/21] list_bl: Use CHECK_DATA_CORRUPTION instead of custom BUG_ON() wrapper
` [RFC PATCH 16/21] list_bl: Extend integrity checking in deletion routines
` [RFC PATCH 17/21] linux/bit_spinlock.h: Include linux/processor.h
` [RFC PATCH 18/21] list_bl: Move integrity checking out of line
` [RFC PATCH 19/21] list_bl: Extend integrity checking to cover the same cases as 'hlist'
` [RFC PATCH 20/21] list: Format CHECK_DATA_CORRUPTION error messages consistently
` [RFC PATCH 21/21] lkdtm: Extend list corruption checks

[PATCH v2] lib/refcount: Document interaction with PID_MAX_LIMIT
 2020-03-24 15:29 UTC  (6+ messages)

Looking for help testing patch attestation
 2020-03-23 19:16 UTC  (2+ messages)

[PATCH v4 0/6] implement KASLR for powerpc/fsl_booke/64
 2020-03-20  6:16 UTC  (11+ messages)
` [PATCH v4 1/6] powerpc/fsl_booke/kaslr: refactor kaslr_legal_offset() and kaslr_early_init()
` [PATCH v4 2/6] powerpc/fsl_booke/64: introduce reloc_kernel_entry() helper
` [PATCH v4 3/6] powerpc/fsl_booke/64: implement KASLR for fsl_booke64
` [PATCH v4 4/6] powerpc/fsl_booke/64: do not clear the BSS for the second pass
` [PATCH v4 5/6] powerpc/fsl_booke/64: clear the original kernel if randomized
` [PATCH v4 6/6] powerpc/fsl_booke/kaslr: rename kaslr-booke32.rst to kaslr-booke.rst and add 64bit part

[RFC PATCH v14 00/10] Landlock LSM
 2020-03-19 21:17 UTC  (16+ messages)
` [RFC PATCH v14 06/10] landlock: Add syscall implementation
` [RFC PATCH v14 10/10] landlock: Add user and kernel documentation

[PATCH v9 1/8] proc: rename struct proc_fs_info to proc_fs_opts
 2020-03-15 15:25 UTC  (8+ messages)
` [PATCH v9 2/8] proc: allow to mount many instances of proc in one pid namespace
` [PATCH v9 3/8] proc: move hide_pid, pid_gid from pid_namespace to proc_fs_info
` [PATCH v9 4/8] proc: instantiate only pids that we can ptrace on 'hidepid=4' mount option
` [PATCH v9 5/8] proc: add option to mount only a pids subset
` [PATCH v9 6/8] docs: proc: add documentation for "hidepid=4" and "subset=pidfs" options and new mount behavior
` [PATCH v9 7/8] proc: move hidepid values to uapi as they are user interface to mount
` [PATCH v9 8/8] proc: use human-readable values for hidehid

[PATCH v9 0/8] proc: modernize proc to support multiple private instances
 2020-03-15 15:25 UTC 

[PATCH v4 0/6] binfmt_elf: Update READ_IMPLIES_EXEC logic for modern CPUs
 2020-03-13  0:06 UTC  (4+ messages)
` [PATCH v4 1/6] x86/elf: Add table to document READ_IMPLIES_EXEC

[PATCH v3] ARM: smp: add support for per-task stack canaries
 2020-03-11 21:39 UTC  (7+ messages)

[PATCH v6 0/7] set_memory() routines and STRICT_MODULE_RWX
 2020-03-11  6:09 UTC  (10+ messages)
` [PATCH v6 1/7] powerpc/mm: Implement set_memory() routines
` [PATCH v6 2/7] powerpc/kprobes: Mark newly allocated probes as RO
` [PATCH v6 3/7] powerpc/mm/ptdump: debugfs handler for W+X checks at runtime
` [PATCH v6 4/7] powerpc: Set ARCH_HAS_STRICT_MODULE_RWX
` [PATCH v6 5/7] powerpc/configs: Enable STRICT_MODULE_RWX in skiroot_defconfig
` [PATCH v6 6/7] powerpc/mm: implement set_memory_attr()
` [PATCH v6 7/7] powerpc/32: use set_memory_attr()

[PATCH] arm64: add check_wx_pages debugfs for CHECK_WX
 2020-03-09 16:51 UTC  (6+ messages)

[PATCH] x86/mm/init_32: Don't print out kernel memory layout if KASLR
 2020-03-09 10:09 UTC  (33+ messages)
      ` [PATCH] microblaze: Stop printing the virtual memory layout
      ` [PATCH] nds32/mm: "
      ` [PATCH] powerpc/32: "
      ` [PATCH] sh: "
      ` [PATCH] xtensa/mm: "
  ` [PATCH v2] x86/mm/init_32: "
      ` [PATCH v3] "

Maybe inappropriate use BUG_ON() in CONFIG_SLAB_FREELIST_HARDENED
 2020-03-08  0:44 UTC  (6+ messages)

[PATCH v3 0/6] implement KASLR for powerpc/fsl_booke/64
 2020-03-05  3:22 UTC  (24+ messages)
` [PATCH v3 3/6] powerpc/fsl_booke/64: implement KASLR for fsl_booke64
` [PATCH v3 4/6] powerpc/fsl_booke/64: do not clear the BSS for the second pass
` [PATCH v3 5/6] powerpc/fsl_booke/64: clear the original kernel if randomized

[PATCH v11 00/11] x86: PIE support to extend KASLR randomization
 2020-03-04 19:22 UTC  (16+ messages)
` [PATCH v11 06/11] x86/CPU: Adapt assembly for PIE support
` [PATCH v11 11/11] x86/alternatives: "

[PATCH] lib/refcount: Document interaction with PID_MAX_LIMIT
 2020-03-03 10:54 UTC  (3+ messages)

[RESEND PATCH v4 05/10] lib/refcount: Improve performance of generic REFCOUNT_FULL code
 2020-03-02 13:06 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).