kernel-hardening.lists.openwall.com archive mirror
 help / color / mirror / Atom feed
 messages from 2020-03-27 17:24:28 to 2020-04-07 12:00:45 UTC [more...]

[PATCH 00/18] add support for Clang's Shadow Call Stack
 2020-04-07 12:00 UTC  (17+ messages)
` [PATCH v10 00/12] "
  ` [PATCH v10 01/12] add support for Clang's Shadow Call Stack (SCS)
  ` [PATCH v10 02/12] scs: add accounting
  ` [PATCH v10 03/12] scs: add support for stack usage debugging
  ` [PATCH v10 04/12] scs: disable when function graph tracing is enabled
  ` [PATCH v10 05/12] arm64: reserve x18 from general allocation with SCS
  ` [PATCH v10 06/12] arm64: preserve x18 when CPU is suspended
  ` [PATCH v10 07/12] arm64: efi: restore x18 if it was corrupted
  ` [PATCH v10 08/12] arm64: vdso: disable Shadow Call Stack
  ` [PATCH v10 09/12] arm64: disable SCS for hypervisor code
  ` [PATCH v10 10/12] arm64: implement Shadow Call Stack
  ` [PATCH v10 11/12] arm64: scs: add shadow stacks for SDEI
  ` [PATCH v10 12/12] efi/libstub: disable SCS

[PATCH] gcc-common.h: 'params.h' has been dropped in GCC10
 2020-04-07 11:32 UTC 

[kernel-hardening] [PATCH 09/38] usercopy: Mark kmalloc caches as usercopy caches
 2020-04-07 11:05 UTC  (14+ messages)

[RFC PATCH 0/5] Prevent write to read-only pages (text, PLT/GOT
 2020-04-07 10:16 UTC  (8+ messages)
` [RFC PATCH 1/5] security : hardening : prevent write to proces's read-only pages from another process
` [RFC PATCH 2/5] Prevent write to "
` [RFC PATCH 3/5] Prevent write to read-only pages text, PLT/GOT tables "
` [RFC PATCH 4/5] X86:Prevent write to read-only pages :text, "
` [RFC PATCH 5/5] UM:Prevent "

[PATCH v3 0/5] Optionally randomize kernel stack offset each syscall
 2020-04-06 23:16 UTC  (6+ messages)
` [PATCH v3 1/5] jump_label: Provide CONFIG-driven build state defaults
` [PATCH v3 2/5] init_on_alloc: Unpessimize default-on builds
` [PATCH v3 3/5] stack: Optionally randomize kernel stack offset each syscall
` [PATCH v3 4/5] x86/entry: Enable random_kstack_offset support
` [PATCH v3 5/5] arm64: entry: "

kCFI sources
 2020-04-04  1:28 UTC  (3+ messages)

[PATCH v10 0/9] proc: modernize proc to support multiple private instances
 2020-04-03 23:59 UTC  (32+ messages)
` [PATCH v10 1/9] proc: rename struct proc_fs_info to proc_fs_opts
` [PATCH v10 2/9] proc: allow to mount many instances of proc in one pid namespace
` [PATCH v10 3/9] proc: move hide_pid, pid_gid from pid_namespace to proc_fs_info
` [PATCH v10 4/9] proc: instantiate only pids that we can ptrace on 'hidepid=4' mount option
` [PATCH v10 5/9] proc: add option to mount only a pids subset
` [PATCH v10 6/9] docs: proc: add documentation for "hidepid=4" and "subset=pid" options and new mount behavior
` [PATCH v10 7/9] proc: move hidepid values to uapi as they are user interface to mount
` [PATCH v10 8/9] proc: use human-readable values for hidehid
  ` [PATCH v11 "
` [PATCH v10 9/9] proc: use named enums for better readability

[PATCH v11 0/8] proc: modernize proc to support multiple private instances
 2020-04-03 18:06 UTC  (9+ messages)
` [PATCH v11 1/8] proc: rename struct proc_fs_info to proc_fs_opts
` [PATCH v11 2/8] proc: allow to mount many instances of proc in one pid namespace
` [PATCH v11 3/8] proc: move hide_pid, pid_gid from pid_namespace to proc_fs_info
` [PATCH v11 4/8] proc: instantiate only pids that we can ptrace on 'hidepid=4' mount option
` [PATCH v11 5/8] proc: add option to mount only a pids subset
` [PATCH v11 6/8] docs: proc: add documentation for "hidepid=4" and "subset=pid" options and new mount behavior
` [PATCH v11 7/8] proc: use human-readable values for hidepid
` [PATCH v11 8/8] proc: use named enums for better readability

[PATCH v8 1/7] powerpc/mm: Implement set_memory() routines
 2020-04-03 10:03 UTC  (14+ messages)
` [PATCH v8 2/7] powerpc/kprobes: Mark newly allocated probes as RO
` [PATCH v8 3/7] powerpc/mm/ptdump: debugfs handler for W+X checks at runtime
` [PATCH v8 4/7] powerpc: Set ARCH_HAS_STRICT_MODULE_RWX
` [PATCH v8 5/7] powerpc/configs: Enable STRICT_MODULE_RWX in skiroot_defconfig
` [PATCH v8 6/7] powerpc/mm: implement set_memory_attr()
` [PATCH v8 7/7] powerpc/32: use set_memory_attr()

[RFC PATCH] arm64: remove CONFIG_DEBUG_ALIGN_RODATA feature
 2020-04-03  8:58 UTC  (17+ messages)

Curiosity around 'exec_id' and some problems associated with it
 2020-04-03  2:11 UTC  (19+ messages)
  ` [PATCH] signal: Extend exec_id to 64bits

[PATCH v2 bpf] kbuild: fix dependencies for DEBUG_INFO_BTF
 2020-04-02 22:49 UTC  (17+ messages)
  ` [PATCH v3 "
      ` [PATCH v4 "
              ` [PATCH v5 "

[PATCH] gcc-plugins/stackleak: Avoid assignment for unused macro argument
 2020-04-02  8:10 UTC 

[RFC PATCH 00/21] Improve list integrity checking
 2020-04-01  8:40 UTC  (29+ messages)
` [RFC PATCH 01/21] list: Remove hlist_unhashed_lockless()
` [RFC PATCH 02/21] list: Remove hlist_nulls_unhashed_lockless()
` [RFC PATCH 03/21] list: Annotate lockless list primitives with data_race()
` [RFC PATCH 05/21] list: Comment missing WRITE_ONCE() in __list_del()
` [RFC PATCH 06/21] list: Remove superfluous WRITE_ONCE() from hlist_nulls implementation
` [RFC PATCH 07/21] Revert "list: Use WRITE_ONCE() when adding to lists and hlists"
` [RFC PATCH 08/21] Revert "list: Use WRITE_ONCE() when initializing list_head structures"
` [RFC PATCH 09/21] list: Remove unnecessary WRITE_ONCE() from hlist_bl_add_before()
` [RFC PATCH 12/21] list: Poison ->next pointer for non-RCU deletion of 'hlist_nulls_node'

CONFIG_DEBUG_INFO_BTF and CONFIG_GCC_PLUGIN_RANDSTRUCT
 2020-04-01  7:32 UTC  (11+ messages)

[PATCH v7 0/7] set_memory() routines and STRICT_MODULE_RWX
 2020-04-01  5:50 UTC  (11+ messages)
` [PATCH v7 1/7] powerpc/mm: Implement set_memory() routines
` [PATCH v7 2/7] powerpc/kprobes: Mark newly allocated probes as RO
` [PATCH v7 3/7] powerpc/mm/ptdump: debugfs handler for W+X checks at runtime
` [PATCH v7 4/7] powerpc: Set ARCH_HAS_STRICT_MODULE_RWX
` [PATCH v7 5/7] powerpc/configs: Enable STRICT_MODULE_RWX in skiroot_defconfig
` [PATCH v7 6/7] powerpc/mm: implement set_memory_attr()
` [PATCH v7 7/7] powerpc/32: use set_memory_attr()

[PATCH v2 0/5] Optionally randomize kernel stack offset each syscall
 2020-03-30 18:27 UTC  (13+ messages)
` [PATCH v2 3/5] stack: "
` [PATCH v2 4/5] x86/entry: Enable random_kstack_offset support
` [PATCH v2 5/5] arm64: entry: "

[PATCH v6 0/7] set_memory() routines and STRICT_MODULE_RWX
 2020-03-31  1:49 UTC  (4+ messages)
` [PATCH v6 1/7] powerpc/mm: Implement set_memory() routines

[PATCH v15 00/10] Landlock LSM
 2020-03-30 18:29 UTC  (3+ messages)
` [PATCH v15 05/10] fs,landlock: Support filesystem access-control

[RFC PATCH v14 00/10] Landlock LSM
 2020-03-30 18:26 UTC  (11+ messages)

[PATCH] gcc-plugins: drop support for GCC <= 4.7
 2020-03-30  5:12 UTC  (3+ messages)

[PATCH v5 0/6] implement KASLR for powerpc/fsl_booke/64
 2020-03-30  2:20 UTC  (7+ messages)
` [PATCH v5 1/6] powerpc/fsl_booke/kaslr: refactor kaslr_legal_offset() and kaslr_early_init()
` [PATCH v5 2/6] powerpc/fsl_booke/64: introduce reloc_kernel_entry() helper
` [PATCH v5 3/6] powerpc/fsl_booke/64: implement KASLR for fsl_booke64
` [PATCH v5 4/6] powerpc/fsl_booke/64: do not clear the BSS for the second pass
` [PATCH v5 5/6] powerpc/fsl_booke/64: clear the original kernel if randomized
` [PATCH v5 6/6] powerpc/fsl_booke/kaslr: rename kaslr-booke32.rst to kaslr-booke.rst and add 64bit part

[PATCH 1/2] kconfig: remove unused variable in qconf.cc
 2020-03-29 11:04 UTC  (6+ messages)
` [PATCH 2/2] kbuild: add -Wall to KBUILD_HOSTCXXFLAGS


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).