From mboxrd@z Thu Jan 1 00:00:00 1970 From: maowenan Date: Mon, 24 Jun 2019 03:41:07 +0000 Subject: Re: [PATCH -next v2] drm/amdgpu: return 'ret' in amdgpu_pmu_init Message-Id: List-Id: References: <20190622104318.GT28859@kadam> <20190622130527.182022-1-maowenan@huawei.com> <0ab82cdb0bec30e7e431f106f8e0e9d141491555.camel@perches.com> In-Reply-To: <0ab82cdb0bec30e7e431f106f8e0e9d141491555.camel@perches.com> MIME-Version: 1.0 Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: 8bit To: Joe Perches , airlied@linux.ie, daniel@ffwll.ch, alexander.deucher@amd.com, christian.koenig@amd.com, David1.Zhou@amd.com, dan.carpenter@oracle.com, julia.lawall@lip6.fr Cc: kernel-janitors@vger.kernel.org, amd-gfx@lists.freedesktop.org, linux-kernel@vger.kernel.org, Jonathan Kim On 2019/6/23 2:13, Joe Perches wrote: > On Sat, 2019-06-22 at 21:05 +0800, Mao Wenan wrote: >> There is one warning: >> drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c: In function ‘amdgpu_pmu_init’: >> drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c:249:6: warning: variable ‘ret’ set but not used [-Wunused-but-set-variable] >> int ret = 0; > [] >> v1->v2: change the subject for this patch; change the indenting when it calls init_pmu_by_type; use the value 'ret' in >> amdgpu_pmu_init(). > [] >> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c > [] >> @@ -252,8 +252,8 @@ int amdgpu_pmu_init(struct amdgpu_device *adev) >> case CHIP_VEGA20: >> /* init df */ >> ret = init_pmu_by_type(adev, df_v3_6_attr_groups, >> - "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF, >> - DF_V3_6_MAX_COUNTERS); >> + "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF, >> + DF_V3_6_MAX_COUNTERS); > > trivia: > > The indentation change seems superfluous and > appears to make the code harder to read. > > You could also cc Jonathan Kim who wrote all of this. I think this is just display issue in mail format. It is correct that in vi/vim. The arguments are line up with '(' after my change. @@ -252,8 +252,8 @@ int amdgpu_pmu_init(struct amdgpu_device *adev)$ ^Icase CHIP_VEGA20:$ ^I^I/* init df */$ ^I^Iret = init_pmu_by_type(adev, df_v3_6_attr_groups,$ -^I^I^I^I "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF,$ -^I^I^I^I DF_V3_6_MAX_COUNTERS);$ +^I^I^I^I^I^I^I "DF", "amdgpu_df", PERF_TYPE_AMDGPU_DF,$ +^I^I^I^I^I^I^I DF_V3_6_MAX_COUNTERS);$ $ ^I^I/* other pmu types go here*/$ ^I^Ibreak;$ > > > > . >