Kernel Newbies archive on lore.kernel.org
 help / color / Atom feed
* Help troubleshooting memory leak when highres=on
@ 2020-07-17  5:49 William Tambe
  0 siblings, 0 replies; only message in thread
From: William Tambe @ 2020-07-17  5:49 UTC (permalink / raw)
  To: Kernel Newbies

I am doing porting work; I am having a memory leak issue in a kernel
build with CONFIG_HIGH_RES_TIMERS=y.

When highres=on, load average as returned by uptime are always null,
and KernelStack from /proc/meminfo steadily grows until the system
runs out of memory triggering oom-killer and eventually the whole
system hangs.

Above memory leak and load average issues are not seen when booting
the kernel using highres=off.

Any idea where I should start debugging these issues ?

_______________________________________________
Kernelnewbies mailing list
Kernelnewbies@kernelnewbies.org
https://lists.kernelnewbies.org/mailman/listinfo/kernelnewbies

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-17  5:49 Help troubleshooting memory leak when highres=on William Tambe

Kernel Newbies archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/kernelnewbies/0 kernelnewbies/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 kernelnewbies kernelnewbies/ https://lore.kernel.org/kernelnewbies \
		kernelnewbies@kernelnewbies.org
	public-inbox-index kernelnewbies

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernelnewbies.kernelnewbies


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git