kvm.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Alex Williamson <alex.williamson@redhat.com>
To: Matthew Rosato <mjrosato@linux.ibm.com>,
	Stefan Hajnoczi <stefanha@redhat.com>
Cc: cohuck@redhat.com, thuth@redhat.com, pmorel@linux.ibm.com,
	schnelle@linux.ibm.com, rth@twiddle.net, david@redhat.com,
	pasic@linux.ibm.com, borntraeger@de.ibm.com, mst@redhat.com,
	pbonzini@redhat.com, philmd@redhat.com, qemu-s390x@nongnu.org,
	qemu-devel@nongnu.org, kvm@vger.kernel.org
Subject: Re: [PATCH 02/13] linux-headers: update against 5.10-rc1
Date: Mon, 26 Oct 2020 11:37:16 -0600	[thread overview]
Message-ID: <20201026113716.2c67aec6@w520.home> (raw)
In-Reply-To: <1603726481-31824-3-git-send-email-mjrosato@linux.ibm.com>

On Mon, 26 Oct 2020 11:34:30 -0400
Matthew Rosato <mjrosato@linux.ibm.com> wrote:

> commit 3650b228f83adda7e5ee532e2b90429c03f7b9ec
> 
> Signed-off-by: Matthew Rosato <mjrosato@linux.ibm.com>
> ---
>  .../drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h | 14 ++--
>  .../infiniband/hw/vmw_pvrdma/pvrdma_verbs.h        |  2 +-
>  include/standard-headers/linux/ethtool.h           |  2 +
>  include/standard-headers/linux/fuse.h              | 50 +++++++++++++-
>  include/standard-headers/linux/input-event-codes.h |  4 ++
>  include/standard-headers/linux/pci_regs.h          |  6 +-
>  include/standard-headers/linux/virtio_fs.h         |  3 +
>  include/standard-headers/linux/virtio_gpu.h        | 19 ++++++
>  include/standard-headers/linux/virtio_mmio.h       | 11 +++
>  include/standard-headers/linux/virtio_pci.h        | 11 ++-
>  linux-headers/asm-arm64/kvm.h                      | 25 +++++++
>  linux-headers/asm-arm64/mman.h                     |  1 +
>  linux-headers/asm-generic/hugetlb_encode.h         |  1 +
>  linux-headers/asm-generic/unistd.h                 | 18 ++---
>  linux-headers/asm-mips/unistd_n32.h                |  1 +
>  linux-headers/asm-mips/unistd_n64.h                |  1 +
>  linux-headers/asm-mips/unistd_o32.h                |  1 +
>  linux-headers/asm-powerpc/unistd_32.h              |  1 +
>  linux-headers/asm-powerpc/unistd_64.h              |  1 +
>  linux-headers/asm-s390/unistd_32.h                 |  1 +
>  linux-headers/asm-s390/unistd_64.h                 |  1 +
>  linux-headers/asm-x86/kvm.h                        | 20 ++++++
>  linux-headers/asm-x86/unistd_32.h                  |  1 +
>  linux-headers/asm-x86/unistd_64.h                  |  1 +
>  linux-headers/asm-x86/unistd_x32.h                 |  1 +
>  linux-headers/linux/kvm.h                          | 19 ++++++
>  linux-headers/linux/mman.h                         |  1 +
>  linux-headers/linux/vfio.h                         | 29 +++++++-
>  linux-headers/linux/vfio_zdev.h                    | 78 ++++++++++++++++++++++
>  29 files changed, 301 insertions(+), 23 deletions(-)
>  create mode 100644 linux-headers/linux/vfio_zdev.h
> 
> diff --git a/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h b/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> index 7b4062a..acd4c83 100644
> --- a/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> +++ b/include/standard-headers/drivers/infiniband/hw/vmw_pvrdma/pvrdma_ring.h
> @@ -68,7 +68,7 @@ static inline int pvrdma_idx_valid(uint32_t idx, uint32_t max_elems)
>  
>  static inline int32_t pvrdma_idx(int *var, uint32_t max_elems)
>  {
> -	const unsigned int idx = qatomic_read(var);
> +	const unsigned int idx = atomic_read(var);
>  
>  	if (pvrdma_idx_valid(idx, max_elems))
>  		return idx & (max_elems - 1);
> @@ -77,17 +77,17 @@ static inline int32_t pvrdma_idx(int *var, uint32_t max_elems)
>  
>  static inline void pvrdma_idx_ring_inc(int *var, uint32_t max_elems)
>  {
> -	uint32_t idx = qatomic_read(var) + 1;	/* Increment. */
> +	uint32_t idx = atomic_read(var) + 1;	/* Increment. */
>  
>  	idx &= (max_elems << 1) - 1;		/* Modulo size, flip gen. */
> -	qatomic_set(var, idx);
> +	atomic_set(var, idx);
>  }
>  
>  static inline int32_t pvrdma_idx_ring_has_space(const struct pvrdma_ring *r,
>  					      uint32_t max_elems, uint32_t *out_tail)
>  {
> -	const uint32_t tail = qatomic_read(&r->prod_tail);
> -	const uint32_t head = qatomic_read(&r->cons_head);
> +	const uint32_t tail = atomic_read(&r->prod_tail);
> +	const uint32_t head = atomic_read(&r->cons_head);
>  
>  	if (pvrdma_idx_valid(tail, max_elems) &&
>  	    pvrdma_idx_valid(head, max_elems)) {
> @@ -100,8 +100,8 @@ static inline int32_t pvrdma_idx_ring_has_space(const struct pvrdma_ring *r,
>  static inline int32_t pvrdma_idx_ring_has_data(const struct pvrdma_ring *r,
>  					     uint32_t max_elems, uint32_t *out_head)
>  {
> -	const uint32_t tail = qatomic_read(&r->prod_tail);
> -	const uint32_t head = qatomic_read(&r->cons_head);
> +	const uint32_t tail = atomic_read(&r->prod_tail);
> +	const uint32_t head = atomic_read(&r->cons_head);
>  
>  	if (pvrdma_idx_valid(tail, max_elems) &&
>  	    pvrdma_idx_valid(head, max_elems)) {


The above is clearly just going to revert Stefan's changes to this file
via:

d73415a31547 )"qemu/atomic.h: rename atomic_ to qatomic_")

For now I'm just going to drop these changes (with comment) to avoid
that.  I'll leave it to others to fix the header update script to either
reimplement the s/atomic_/qatomic_/ conversion or remove these code
blocks altogether.  Sound ok?  Thanks,

Alex


  reply	other threads:[~2020-10-26 17:37 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-10-26 15:34 [PATCH 00/13] s390x/pci: s390-pci updates for kernel 5.10-rc1 Matthew Rosato
2020-10-26 15:34 ` [PATCH 01/13] update-linux-headers: Add vfio_zdev.h Matthew Rosato
2020-10-26 15:34 ` [PATCH 02/13] linux-headers: update against 5.10-rc1 Matthew Rosato
2020-10-26 17:37   ` Alex Williamson [this message]
2020-10-26 17:40     ` Matthew Rosato
2020-10-26 15:34 ` [PATCH 03/13] s390x/pci: Move header files to include/hw/s390x Matthew Rosato
2020-10-26 15:34 ` [PATCH 04/13] vfio: Create shared routine for scanning info capabilities Matthew Rosato
2020-10-26 15:34 ` [PATCH 05/13] vfio: Find DMA available capability Matthew Rosato
2020-10-26 15:34 ` [PATCH 06/13] s390x/pci: Add routine to get the vfio dma available count Matthew Rosato
2020-10-26 15:34 ` [PATCH 07/13] s390x/pci: Honor DMA limits set by vfio Matthew Rosato
2020-10-26 15:34 ` [PATCH 08/13] s390x/pci: create a header dedicated to PCI CLP Matthew Rosato
2020-10-26 15:34 ` [PATCH 09/13] s390x/pci: use a PCI Group structure Matthew Rosato
2020-10-26 15:34 ` [PATCH 10/13] s390x/pci: clean up s390 PCI groups Matthew Rosato
2020-10-26 15:34 ` [PATCH 11/13] s390x/pci: use a PCI Function structure Matthew Rosato
2020-10-26 15:34 ` [PATCH 12/13] vfio: Add routine for finding VFIO_DEVICE_GET_INFO capabilities Matthew Rosato
2020-10-26 15:34 ` [PATCH 13/13] s390x/pci: get zPCI function info from host Matthew Rosato
2020-10-26 16:38   ` Cornelia Huck
2020-10-26 16:19 ` [PATCH 00/13] s390x/pci: s390-pci updates for kernel 5.10-rc1 Cornelia Huck
2020-10-26 16:38   ` Matthew Rosato
2020-10-26 16:44     ` Cornelia Huck
2020-10-26 16:41   ` Cornelia Huck
2020-10-26 16:53     ` Alex Williamson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201026113716.2c67aec6@w520.home \
    --to=alex.williamson@redhat.com \
    --cc=borntraeger@de.ibm.com \
    --cc=cohuck@redhat.com \
    --cc=david@redhat.com \
    --cc=kvm@vger.kernel.org \
    --cc=mjrosato@linux.ibm.com \
    --cc=mst@redhat.com \
    --cc=pasic@linux.ibm.com \
    --cc=pbonzini@redhat.com \
    --cc=philmd@redhat.com \
    --cc=pmorel@linux.ibm.com \
    --cc=qemu-devel@nongnu.org \
    --cc=qemu-s390x@nongnu.org \
    --cc=rth@twiddle.net \
    --cc=schnelle@linux.ibm.com \
    --cc=stefanha@redhat.com \
    --cc=thuth@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).