From: Brijesh Singh <brijesh.singh@amd.com>
To: Borislav Petkov <bp@alien8.de>
Cc: brijesh.singh@amd.com, x86@kernel.org,
linux-kernel@vger.kernel.org, kvm@vger.kernel.org,
tglx@linutronix.de, jroedel@suse.de, thomas.lendacky@amd.com,
pbonzini@redhat.com, mingo@redhat.com, dave.hansen@intel.com,
rientjes@google.com, seanjc@google.com, peterz@infradead.org,
hpa@zytor.com, tony.luck@intel.com
Subject: Re: [PATCH Part1 RFC v2 11/20] x86/compressed: Add helper for validating pages in the decompression stage
Date: Thu, 20 May 2021 13:05:15 -0500 [thread overview]
Message-ID: <921408d1-a399-7089-8647-f9617eb12919@amd.com> (raw)
In-Reply-To: <YKah5QInPK4+7xaC@zn.tnic>
On 5/20/21 12:52 PM, Borislav Petkov wrote:
> On Fri, Apr 30, 2021 at 07:16:07AM -0500, Brijesh Singh wrote:
>> @@ -278,12 +279,28 @@ static int set_clr_page_flags(struct x86_mapping_info *info,
>> if ((set | clr) & _PAGE_ENC)
>> clflush_page(address);
>>
>> + /*
>> + * If the encryption attribute is being cleared, then change the page state to
>> + * shared in the RMP entry. Change of the page state must be done before the
>> + * PTE updates.
>> + */
>> + if (clr & _PAGE_ENC)
>> + snp_set_page_shared(pte_pfn(*ptep) << PAGE_SHIFT);
> From the last review:
>
> The statement above already looks at clr - just merge the two together.
Maybe I am missing something, the statement above was executed for
either set or clr but the page shared need to happen only for clr. So,
from code readability point I kept it outside of that if().
Otherwise we may have to do something like.
...
if ((set | clr) & _PAGE_EN) {
if (clr)
snp_set_page_shared(pte_pfn(*ptep) << PAGE_SHIFT);
}
I am okay with above is the preferred approach.
>
>> @@ -136,6 +137,55 @@ static inline bool sev_snp_enabled(void)
>> return sev_status_val & MSR_AMD64_SEV_SNP_ENABLED ? true : false;
>> }
>>
>> +static void snp_page_state_change(unsigned long paddr, int op)
> From the last review:
>
> no need for too many prefixes on static functions - just call this one
> __change_page_state() or so, so that the below one can be called...
I guess I still kept the "snp" prefix because vmgexit was named that
way. Based on your feedback, I am droping the "SNP" prefix from the
VMGEXIT and will update it as well.
>> +{
>> + u64 val;
>> +
>> + if (!sev_snp_enabled())
>> + return;
>> +
>> + /*
>> + * If the page is getting changed from private to shard then invalidate the page
> shared
>
> And you can write this a lot shorter
>
> * If private -> shared, ...
>
>> + * before requesting the state change in the RMP table.
>> + */
>> + if ((op == SNP_PAGE_STATE_SHARED) && pvalidate(paddr, RMP_PG_SIZE_4K, 0))
>> + goto e_pvalidate;
>> +
>> + /* Issue VMGEXIT to change the page state in RMP table. */
>> + sev_es_wr_ghcb_msr(GHCB_MSR_PSC_REQ_GFN(paddr >> PAGE_SHIFT, op));
>> + VMGEXIT();
>> +
>> + /* Read the response of the VMGEXIT. */
>> + val = sev_es_rd_ghcb_msr();
>> + if ((GHCB_RESP_CODE(val) != GHCB_MSR_PSC_RESP) || GHCB_MSR_PSC_RESP_VAL(val))
>> + goto e_psc;
> That label is used only once - just do the termination here directly and
> remove it.
Noted.
>
> Thx.
>
next prev parent reply other threads:[~2021-05-20 18:05 UTC|newest]
Thread overview: 62+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-04-30 12:15 [PATCH Part1 RFC v2 00/20] Add AMD Secure Nested Paging (SEV-SNP) Guest Support Brijesh Singh
2021-04-30 12:15 ` [PATCH Part1 RFC v2 01/20] x86/sev: Define the GHCB MSR protocol for AP reset hold Brijesh Singh
2021-04-30 12:15 ` [PATCH Part1 RFC v2 02/20] x86/sev: Save the negotiated GHCB version Brijesh Singh
2021-05-11 9:23 ` Borislav Petkov
2021-05-11 18:29 ` Brijesh Singh
2021-05-11 18:41 ` Borislav Petkov
2021-05-12 14:03 ` Brijesh Singh
2021-05-12 14:31 ` Borislav Petkov
2021-05-12 15:03 ` Brijesh Singh
2021-04-30 12:15 ` [PATCH Part1 RFC v2 03/20] x86/sev: Add support for hypervisor feature VMGEXIT Brijesh Singh
2021-05-11 10:01 ` Borislav Petkov
2021-05-11 18:53 ` Brijesh Singh
2021-05-17 14:40 ` Borislav Petkov
2021-04-30 12:16 ` [PATCH Part1 RFC v2 04/20] x86/sev: Increase the GHCB protocol version Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 05/20] x86/sev: Define SNP Page State Change VMGEXIT structure Brijesh Singh
2021-05-18 10:41 ` Borislav Petkov
2021-05-18 15:06 ` Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 06/20] x86/sev: Define SNP guest request NAE events Brijesh Singh
2021-05-18 10:45 ` Borislav Petkov
2021-05-18 13:42 ` Brijesh Singh
2021-05-18 13:54 ` Borislav Petkov
2021-05-18 14:13 ` Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 07/20] x86/sev: Define error codes for reason set 1 Brijesh Singh
2021-05-18 11:05 ` Borislav Petkov
2021-04-30 12:16 ` [PATCH Part1 RFC v2 08/20] x86/mm: Add sev_snp_active() helper Brijesh Singh
2021-05-18 18:11 ` Borislav Petkov
2021-05-19 17:28 ` Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 09/20] x86/sev: check SEV-SNP features support Brijesh Singh
2021-05-20 16:02 ` Borislav Petkov
2021-05-20 17:40 ` Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 10/20] x86/sev: Add a helper for the PVALIDATE instruction Brijesh Singh
2021-04-30 13:05 ` Brijesh Singh
2021-05-20 17:32 ` Borislav Petkov
2021-05-20 17:44 ` Brijesh Singh
2021-05-20 17:51 ` Borislav Petkov
2021-05-20 17:57 ` Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 11/20] x86/compressed: Add helper for validating pages in the decompression stage Brijesh Singh
2021-05-20 17:52 ` Borislav Petkov
2021-05-20 18:05 ` Brijesh Singh [this message]
2021-05-25 10:18 ` Borislav Petkov
2021-04-30 12:16 ` [PATCH Part1 RFC v2 12/20] x86/compressed: Register GHCB memory when SEV-SNP is active Brijesh Singh
2021-05-25 10:41 ` Borislav Petkov
2021-04-30 12:16 ` [PATCH Part1 RFC v2 13/20] x86/sev: " Brijesh Singh
2021-05-25 11:11 ` Borislav Petkov
2021-05-25 14:28 ` Brijesh Singh
2021-05-25 14:35 ` Borislav Petkov
2021-05-25 14:47 ` Brijesh Singh
2021-05-26 9:57 ` Borislav Petkov
2021-05-26 13:23 ` Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 14/20] x86/sev: Add helper for validating pages in early enc attribute changes Brijesh Singh
2021-05-26 10:39 ` Borislav Petkov
2021-05-26 13:34 ` Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 15/20] x86/kernel: Make the bss.decrypted section shared in RMP table Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 16/20] x86/kernel: Validate rom memory before accessing when SEV-SNP is active Brijesh Singh
2021-05-27 11:49 ` Borislav Petkov
2021-05-27 12:12 ` Brijesh Singh
2021-05-27 12:23 ` Borislav Petkov
2021-05-27 12:56 ` Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 17/20] x86/mm: Add support to validate memory when changing C-bit Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 18/20] x86/boot: Add Confidential Computing address to setup_header Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 19/20] x86/sev: Register SNP guest request platform device Brijesh Singh
2021-04-30 12:16 ` [PATCH Part1 RFC v2 20/20] virt: Add SEV-SNP guest driver Brijesh Singh
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=921408d1-a399-7089-8647-f9617eb12919@amd.com \
--to=brijesh.singh@amd.com \
--cc=bp@alien8.de \
--cc=dave.hansen@intel.com \
--cc=hpa@zytor.com \
--cc=jroedel@suse.de \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=pbonzini@redhat.com \
--cc=peterz@infradead.org \
--cc=rientjes@google.com \
--cc=seanjc@google.com \
--cc=tglx@linutronix.de \
--cc=thomas.lendacky@amd.com \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).