kvm.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-06-22 15:55:28 to 2020-06-23 11:11:15 UTC [more...]

[PATCH] Allow RDTSC and RDTSCP from userspace
 2020-06-23 11:11 UTC  (10+ messages)
      ` Should SEV-ES #VC use IST? (Re: [PATCH] Allow RDTSC and RDTSCP from userspace)

[PATCH v2] SVM: add test for nested guest RIP corruption
 2020-06-23 10:57 UTC  (2+ messages)

[PATCH 0/7] accel/kvm: Simplify few functions that can use global kvm_state
 2020-06-23 10:50 UTC  (8+ messages)
` [PATCH 1/7] accel/kvm: Let kvm_check_extension use global KVM state
` [PATCH 2/7] accel/kvm: Simplify kvm_check_extension()
` [PATCH 3/7] accel/kvm: Simplify kvm_check_extension_list()
` [RFC PATCH 4/7] accel/kvm: Simplify kvm_set_sigmask_len()
` [PATCH 5/7] target/i386/kvm: Simplify get_para_features()
` [RFC PATCH 6/7] target/i386/kvm: Simplify kvm_get_mce_cap_supported()
` [RFC PATCH 7/7] target/i386/kvm: Simplify kvm_get_supported_[feature]_msrs()

[PATCH] SVM: add test for nested guest RIP corruption
 2020-06-23 10:48 UTC  (3+ messages)

[PATCH v3 0/2] target/arm: Fix using pmu=on on KVM
 2020-06-23 10:35 UTC  (7+ messages)
` [PATCH v3 1/2] tests/qtest/arm-cpu-features: Add feature setting tests
` [PATCH v3 2/2] target/arm: Check supported KVM features globally (not per vCPU)

[PATCH v4 0/7] clean up redundant 'kvm_run' parameters
 2020-06-23 10:24 UTC  (4+ messages)

[RFC PATCH v13 0/9] Enable ptp_kvm for arm64
 2020-06-23 10:23 UTC  (6+ messages)
` [RFC PATCH v13 7/9] arm64/kvm: Add hypercall service for kvm ptp

linux-next build error (9)
 2020-06-23 10:17 UTC  (6+ messages)

[PATCH] KVM: VMX: Remove vcpu_vmx's defunct copy of host_pkru
 2020-06-23 10:01 UTC  (2+ messages)

[kvm-unit-tests PATCH] x86: skip hyperv_clock test when host clocksource is not TSC
 2020-06-23 10:01 UTC  (2+ messages)

[PATCH] KVM: x86: allow TSC to differ by NTP correction bounds without TSC scaling
 2020-06-23  9:56 UTC  (4+ messages)
  ` [PATCH v2] "

[PATCH] KVM: X86: Fix MSR range of APIC registers in X2APIC mode
 2020-06-23  9:50 UTC  (2+ messages)

[PATCH kvm-unit-tests] x86: disable SSE on 32-bit hosts
 2020-06-23  9:45 UTC  (3+ messages)

[PATCH] KVM: nVMX: Wrap VM-Fail valid path in generic VM-Fail helper
 2020-06-23  9:38 UTC  (3+ messages)

[PATCH 0/3 v2] kvm-unit-tests: nVMX: Test base and limit fields of guest GDTR and IDTR
 2020-06-23  9:33 UTC  (4+ messages)
` [PATCH 2/3 v2] kvm-unit-tests: nVMX: Optimize test_guest_dr7() by factoring out the loops into a macro

[GIT PULL 0/1] KVM: s390: Fix for 5.8
 2020-06-23  9:23 UTC  (2+ messages)
` [GIT PULL 1/1] KVM: s390: reduce number of IO pins to 1

[PATCH v4 0/6] Add logical CPU to KVM_EXIT_FAIL_ENTRY info
 2020-06-23  9:29 UTC  (2+ messages)

[PATCH kvm-unit-tests] vmx: remove unnecessary #ifdef __x86_64__
 2020-06-23  9:20 UTC 

[PATCH] KVM: x86: report sev_pin_memory errors with PTR_ERR
 2020-06-23  9:17 UTC 

[PATCH kvm-unit-tests] x86: always set up SMP
 2020-06-23  9:11 UTC  (4+ messages)

[PATCH 0/4] KVM: nSVM: Check reserved bits in DR6, DR7 and EFER on vmrun of nested guests
 2020-06-23  9:04 UTC  (2+ messages)

[PATCH v4 00/18] Add support for Nitro Enclaves
 2020-06-23  8:59 UTC  (21+ messages)
` [PATCH v4 01/18] nitro_enclaves: Add ioctl interface definition
` [PATCH v4 02/18] nitro_enclaves: Define the PCI device interface
` [PATCH v4 03/18] nitro_enclaves: Define enclave info for internal bookkeeping
` [PATCH v4 04/18] nitro_enclaves: Init PCI device driver
` [PATCH v4 05/18] nitro_enclaves: Handle PCI device command requests
` [PATCH v4 06/18] nitro_enclaves: Handle out-of-band PCI device events
` [PATCH v4 07/18] nitro_enclaves: Init misc device providing the ioctl interface
` [PATCH v4 08/18] nitro_enclaves: Add logic for enclave vm creation
` [PATCH v4 09/18] nitro_enclaves: Add logic for enclave vcpu creation
` [PATCH v4 10/18] nitro_enclaves: Add logic for enclave image load info
` [PATCH v4 11/18] nitro_enclaves: Add logic for enclave memory region set
` [PATCH v4 12/18] nitro_enclaves: Add logic for enclave start
` [PATCH v4 13/18] nitro_enclaves: Add logic for enclave termination
` [PATCH v4 14/18] nitro_enclaves: Add Kconfig for the Nitro Enclaves driver
` [PATCH v4 15/18] nitro_enclaves: Add Makefile "
` [PATCH v4 16/18] nitro_enclaves: Add sample for ioctl interface usage
` [PATCH v4 17/18] nitro_enclaves: Add overview documentation
` [PATCH v4 18/18] MAINTAINERS: Add entry for the Nitro Enclaves driver

[PATCH v9 0/2] Use DIAG318 to set Control Program Name & Version Codes
 2020-06-23  8:58 UTC  (13+ messages)
` [PATCH v9 2/2] s390/kvm: diagnose 0x318 sync and reset

[kvm-unit-tests PATCH] x86: Initialize segment selectors
 2020-06-23  8:41 UTC 

[PATCH kvm-unit-tests RFC] Revert "SVM: move guest past HLT"
 2020-06-23  8:27 UTC 

[PATCH RFC v8 00/11] vhost: ring format independence
 2020-06-23  8:25 UTC  (14+ messages)
` [PATCH RFC v8 02/11] vhost: use batched get_vq_desc version

[PATCH] KVM: s390: reduce number of IO pins to 1
 2020-06-23  8:06 UTC  (5+ messages)

[PATCH v2] kvm: Fix false positive RCU usage warning
 2020-06-23  7:39 UTC  (2+ messages)

[kvm-unit-tests PULL 00/12] CI-related fixes and improvements
 2020-06-23  7:30 UTC  (2+ messages)

[PATCH kvm-unit-tests] lib/alloc.c: fix missing include
 2020-06-23  7:28 UTC 

[kvm-unit-tests PATCH v1 0/8] Minor fixes, improvements, and cleanup
 2020-06-23  7:27 UTC  (12+ messages)
` [kvm-unit-tests PATCH v1 1/8] x86/cstart.S: initialize stack before using it
` [kvm-unit-tests PATCH v1 2/8] x86: add missing PAGE_ALIGN macro from page.h
` [kvm-unit-tests PATCH v1 3/8] lib: use PAGE_ALIGN
` [kvm-unit-tests PATCH v1 4/8] lib/alloc.c: add overflow check for calloc
` [kvm-unit-tests PATCH v1 5/8] lib: Fix a typo and add documentation comments
` [kvm-unit-tests PATCH v1 6/8] lib/vmalloc: fix potential race and non-standard pointer arithmetic
` [kvm-unit-tests PATCH v1 7/8] lib/alloc_page: make get_order return unsigned int
` [kvm-unit-tests PATCH v1 8/8] lib/vmalloc: add locking and a check for initialization

[PATCH] kvm: x86 mmu: avoid mmu_page_hash lookup for direct_map-only VM
 2020-06-23  6:53 UTC  (4+ messages)

[PATCH v2 00/15] vfio: expose virtual Shared Virtual Addressing to VMs
 2020-06-23  6:43 UTC  (6+ messages)
` [PATCH v2 14/15] vfio: Document dual stage control

[PATCH] KVM: X86: Emulate APERF/MPERF to report actual VCPU frequency
 2020-06-23  6:35 UTC 

[PATCH] KVM: VMX: Stop context switching MSR_IA32_UMWAIT_CONTROL
 2020-06-23  1:31 UTC  (4+ messages)

[PATCH] KVM: x86/mmu: Don't put invalid SPs back on the list of active pages
 2020-06-23  1:15 UTC  (3+ messages)

[PATCH v2 00/11] KVM: Support guest MAXPHYADDR < host MAXPHYADDR
 2020-06-23  0:52 UTC  (14+ messages)

KVM/RCU related warning on latest mainline kernel
 2020-06-23  0:45 UTC  (2+ messages)

[kvm-unit-tests v3 PATCH] Fixes for the umip test
 2020-06-23  0:34 UTC  (2+ messages)

[PATCH kvm-unit-tests] Fix out-of-tree builds
 2020-06-23  0:34 UTC  (2+ messages)

[PATCH] KVM: LAPIC: ensure APIC map is up to date on concurrent update requests
 2020-06-23  0:26 UTC  (2+ messages)

[PATCH v2] target/arm: Check supported KVM features globally (not per vCPU)
 2020-06-22 23:05 UTC  (7+ messages)

[PATCH 1/2] kvm: x86: Refine kvm_write_tsc synchronization generations
 2020-06-22 23:02 UTC  (5+ messages)

[PATCH] kvm: nVMX: flush TLB when decoded insn != VM-exit reason
 2020-06-22 22:53 UTC  (3+ messages)

[PATCH 00/15] KVM: x86: VMX: Fix MSR namespacing
 2020-06-22 22:42 UTC  (16+ messages)
` [PATCH 01/15] KVM: x86: Rename "shared_msrs" to "user_return_msrs"
` [PATCH 02/15] KVM: VMX: Prepend "MAX_" to MSR array size defines
` [PATCH 03/15] KVM: VMX: Rename "vmx_find_msr_index" to "vmx_find_loadstore_msr_slot"
` [PATCH 04/15] KVM: VMX: Rename the "shared_msr_entry" struct to "vmx_uret_msr"
` [PATCH 05/15] KVM: VMX: Rename vcpu_vmx's "nmsrs" to "nr_uret_msrs"
` [PATCH 06/15] KVM: VMX: Rename vcpu_vmx's "save_nmsrs" to "nr_active_uret_msrs"
` [PATCH 07/15] KVM: VMX: Rename vcpu_vmx's "guest_msrs_ready" to "guest_uret_msrs_loaded"
` [PATCH 08/15] KVM: VMX: Rename "__find_msr_index" to "__vmx_find_uret_msr"
` [PATCH 09/15] KVM: VMX: Check guest support for RDTSCP before processing MSR_TSC_AUX
` [PATCH 10/15] KVM: VMX: Move uret MSR lookup into update_transition_efer()
` [PATCH 11/15] KVM: VMX: Add vmx_setup_uret_msr() to handle lookup and swap
` [PATCH 12/15] KVM: VMX: Rename "find_msr_entry" to "vmx_find_uret_msr"
` [PATCH 13/15] KVM: VMX: Rename "vmx_set_guest_msr" to "vmx_set_guest_uret_msr"
` [PATCH 14/15] KVM: VMX: Rename "vmx_msr_index" to "vmx_uret_msrs_list"
` [PATCH 15/15] KVM: VMX: Rename vmx_uret_msr's "index" to "slot"

[PATCH 0/4] KVM: x86: nVMX: Nested PML bug fix and cleanup
 2020-06-22 22:26 UTC  (6+ messages)
` [PATCH 1/4] KVM: nVMX: Plumb L2 GPA through to PML emulation
` [PATCH 2/4] KVM: x86/mmu: Drop kvm_arch_write_log_dirty() wrapper
` [PATCH 3/4] KVM: nVMX: WARN if PML emulation helper is invoked outside of nested guest
` [PATCH 4/4] KVM: x86/mmu: Make .write_log_dirty a nested operation

[PATCH 0/2] KVM: X86: A few fixes around ignore_msrs
 2020-06-22 22:04 UTC  (3+ messages)
` [PATCH 1/2] KVM: X86: Move ignore_msrs handling upper the stack
` [PATCH 2/2] KVM: X86: Do the same ignore_msrs check for feature msrs

[RFC PATCH] KVM: Add module for IRQ forwarding
 2020-06-22 21:59 UTC  (6+ messages)
` [PATCH] vfio: PoC patch for printing IRQs used by i2c devices

[PATCH 0/6] KVM: x86/mmu: Files and sp helper cleanups
 2020-06-22 20:20 UTC  (7+ messages)
` [PATCH 1/6] KVM: x86/mmu: Move mmu_audit.c and mmutrace.h into the mmu/ sub-directory
` [PATCH 2/6] KVM: x86/mmu: Move kvm_mmu_available_pages() into mmu.c
` [PATCH 3/6] KVM: x86/mmu: Add MMU-internal header
` [PATCH 4/6] KVM: x86/mmu: Make kvm_mmu_page definition and accessor internal-only
` [PATCH 5/6] KVM: x86/mmu: Add sptep_to_sp() helper to wrap shadow page lookup
` [PATCH 6/6] KVM: x86/mmu: Rename page_header() to to_shadow_page()

[PATCH v2 00/21] KVM: Cleanup and unify kvm_mmu_memory_cache usage
 2020-06-22 20:08 UTC  (22+ messages)
` [PATCH v2 01/21] KVM: x86/mmu: Track the associated kmem_cache in the MMU caches
` [PATCH v2 02/21] KVM: x86/mmu: Consolidate "page" variant of memory cache helpers
` [PATCH v2 03/21] KVM: x86/mmu: Use consistent "mc" name for kvm_mmu_memory_cache locals
` [PATCH v2 04/21] KVM: x86/mmu: Remove superfluous gotos from mmu_topup_memory_caches()
` [PATCH v2 05/21] KVM: x86/mmu: Try to avoid crashing KVM if a MMU memory cache is empty
` [PATCH v2 06/21] KVM: x86/mmu: Move fast_page_fault() call above mmu_topup_memory_caches()
` [PATCH v2 07/21] KVM: x86/mmu: Topup memory caches after walking GVA->GPA
` [PATCH v2 08/21] KVM: x86/mmu: Clean up the gorilla math in mmu_topup_memory_caches()
` [PATCH v2 09/21] KVM: x86/mmu: Separate the memory caches for shadow pages and gfn arrays
` [PATCH v2 10/21] KVM: x86/mmu: Make __GFP_ZERO a property of the memory cache
` [PATCH v2 11/21] KVM: x86/mmu: Zero allocate shadow pages (outside of mmu_lock)
` [PATCH v2 12/21] KVM: x86/mmu: Skip filling the gfn cache for guaranteed direct MMU topups
` [PATCH v2 13/21] KVM: x86/mmu: Prepend "kvm_" to memory cache helpers that will be global
` [PATCH v2 14/21] KVM: Move x86's version of struct kvm_mmu_memory_cache to common code
` [PATCH v2 15/21] KVM: Move x86's MMU memory cache helpers to common KVM code
` [PATCH v2 16/21] KVM: arm64: Drop @max param from mmu_topup_memory_cache()
` [PATCH v2 17/21] KVM: arm64: Use common code's approach for __GFP_ZERO with memory caches
` [PATCH v2 18/21] KVM: arm64: Use common KVM implementation of MMU "
` [PATCH v2 19/21] KVM: MIPS: Drop @max param from mmu_topup_memory_cache()
` [PATCH v2 20/21] KVM: MIPS: Account pages used for GPA page tables
` [PATCH v2 21/21] KVM: MIPS: Use common KVM implementation of MMU memory caches

[PATCH 00/21] KVM: Cleanup and unify kvm_mmu_memory_cache usage
 2020-06-22 19:40 UTC  (8+ messages)
` [PATCH 10/21] KVM: x86/mmu: Make __GFP_ZERO a property of the memory cache
` [PATCH 14/21] KVM: Move x86's version of struct kvm_mmu_memory_cache to common code

[kvm-unit-tests PATCH 0/4] nVMX: 5-level nested EPT support
 2020-06-22 17:44 UTC  (3+ messages)

[kvm-unit-tests PATCH] x86: fix build with GCC10
 2020-06-22 17:22 UTC  (2+ messages)

[PATCH] KVM: x86/mmu: Avoid mixing gpa_t with gfn_t in walk_addr_generic()
 2020-06-22 17:04 UTC  (2+ messages)

[PATCH] kvm: lapic: fix broken vcpu hotplug
 2020-06-22 16:47 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).