From mboxrd@z Thu Jan 1 00:00:00 1970 From: Will Deacon Subject: Re: [PATCH v10 2/3] arm/syscalls: Check address limit on user-mode return Date: Wed, 21 Jun 2017 10:08:15 +0100 Message-ID: <20170621090815.GC3768@arm.com> References: <20170615011203.144108-1-thgarnie@google.com> <20170615011203.144108-2-thgarnie@google.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: List-Post: List-Help: List-Unsubscribe: List-Subscribe: Content-Disposition: inline In-Reply-To: To: Thomas Garnier Cc: Kees Cook , Thomas Gleixner , Ingo Molnar , "H . Peter Anvin" , Andy Lutomirski , Paolo Bonzini , Rik van Riel , Oleg Nesterov , Josh Poimboeuf , Petr Mladek , Miroslav Benes , Al Viro , Arnd Bergmann , Dave Hansen , David Howells , Russell King , Andy Lutomirski , Will Drewry , Catalin Marinas , Mark Rutland , Pratyush Anand , Chris Metcalf , "x86@kernel.org" , LKML , Linux API List-Id: linux-api@vger.kernel.org On Tue, Jun 20, 2017 at 01:31:14PM -0700, Thomas Garnier wrote: > On Tue, Jun 20, 2017 at 1:18 PM, Kees Cook wrote: > > On Wed, Jun 14, 2017 at 6:12 PM, Thomas Garnier wrote: > >> diff --git a/arch/arm/kernel/entry-common.S b/arch/arm/kernel/entry-common.S > >> index eb5cd77bf1d8..e33c32d56193 100644 > >> --- a/arch/arm/kernel/entry-common.S > >> +++ b/arch/arm/kernel/entry-common.S > >> @@ -41,7 +41,9 @@ ret_fast_syscall: > >> UNWIND(.cantunwind ) > >> disable_irq_notrace @ disable interrupts > >> ldr r1, [tsk, #TI_FLAGS] @ re-check for syscall tracing > >> - tst r1, #_TIF_SYSCALL_WORK | _TIF_WORK_MASK > >> + tst r1, #_TIF_SYSCALL_WORK > >> + bne fast_work_pending > >> + tst r1, #_TIF_WORK_MASK > > > > (IIUC) MOV32 is 2 cycles (MOVW, MOVT), and each TST above is 1 cycle > > and each BNE is 1 cycle (when not taken). So: > > > > mov32 r2, #_TIF_SYSCALL_WORK | _TIF_WORK_MASK > > tst r1, r2 > > bne fast_work_pending > > > > is 4 cycles and tst, bne, tst, bne is also 4 cycles. Would mov32 be > > more readable (since it keeps the flags together)? > > I guess it would be more readable. Any opinion from the arm folks? The mov32 sequence is probably better, but statically attributing cycles on a per instruction basis is pretty futile on modern CPUs. Will