linux-arch.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Christophe Leroy <christophe.leroy@csgroup.eu>
To: Kees Cook <keescook@chromium.org>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Andrew Morton <akpm@linux-foundation.org>,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	Helge Deller <deller@gmx.de>, Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	linux-ia64@vger.kernel.org, linux-parisc@vger.kernel.org,
	linux-arch@vger.kernel.org, linux-mm@kvack.org
Subject: Re: [PATCH v1 08/10] lkdtm: Really write into kernel text in WRITE_KERN
Date: Wed, 13 Oct 2021 09:29:53 +0200	[thread overview]
Message-ID: <336f314c-2db3-0899-b012-18c493ae0e3a@csgroup.eu> (raw)
In-Reply-To: <202110130004.880A6C841@keescook>



Le 13/10/2021 à 09:05, Kees Cook a écrit :
> On Mon, Oct 11, 2021 at 05:25:35PM +0200, Christophe Leroy wrote:
>> WRITE_KERN is supposed to overwrite some kernel text, namely
>> do_overwritten() function.
>>
>> But at the time being it overwrites do_overwritten() function
>> descriptor, not function text.
>>
>> Fix it by dereferencing the function descriptor to obtain
>> function text pointer.
>>
>> And make do_overwritten() noinline so that it is really
>> do_overwritten() which is called by lkdtm_WRITE_KERN().
>>
>> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
>> ---
>>   drivers/misc/lkdtm/perms.c | 8 +++++---
>>   1 file changed, 5 insertions(+), 3 deletions(-)
>>
>> diff --git a/drivers/misc/lkdtm/perms.c b/drivers/misc/lkdtm/perms.c
>> index 60b3b2fe929d..442d60ed25ef 100644
>> --- a/drivers/misc/lkdtm/perms.c
>> +++ b/drivers/misc/lkdtm/perms.c
>> @@ -5,6 +5,7 @@
>>    * even non-readable regions.
>>    */
>>   #include "lkdtm.h"
>> +#include <linux/kallsyms.h>
> 
> Why not #include <asm/sections.h> instead here?

dereference_symbol_descriptor() is defined in linux/kallsyms.h

> 
>>   #include <linux/slab.h>
>>   #include <linux/vmalloc.h>
>>   #include <linux/mman.h>
>> @@ -37,7 +38,7 @@ static noinline void do_nothing(void)
>>   }
>>   
>>   /* Must immediately follow do_nothing for size calculuations to work out. */
>> -static void do_overwritten(void)
>> +static noinline void do_overwritten(void)
>>   {
>>   	pr_info("do_overwritten wasn't overwritten!\n");
>>   	return;
>> @@ -113,8 +114,9 @@ void lkdtm_WRITE_KERN(void)
>>   	size_t size;
>>   	volatile unsigned char *ptr;
>>   
>> -	size = (unsigned long)do_overwritten - (unsigned long)do_nothing;
>> -	ptr = (unsigned char *)do_overwritten;
>> +	size = (unsigned long)dereference_symbol_descriptor(do_overwritten) -
>> +	       (unsigned long)dereference_symbol_descriptor(do_nothing);
>> +	ptr = dereference_symbol_descriptor(do_overwritten);
> 
> But otherwise, yup, I expect there will be a bunch of things like this
> to clean up in LKDTM. :| Sorry about that!
> 
> Acked-by: Kees Cook <keescook@chromium.org>
> 
>>   
>>   	pr_info("attempting bad %zu byte write at %px\n", size, ptr);
>>   	memcpy((void *)ptr, (unsigned char *)do_nothing, size);
>> -- 
>> 2.31.1
>>
> 

  reply	other threads:[~2021-10-13  7:29 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-11 15:25 [PATCH v1 00/10] Fix LKDTM for PPC64/IA64/PARISC Christophe Leroy
2021-10-11 15:25 ` [PATCH v1 01/10] powerpc: Move 'struct ppc64_opd_entry' back into asm/elf.h Christophe Leroy
2021-10-12  7:10   ` Michael Ellerman
2021-10-12  8:02     ` Arnd Bergmann
2021-10-13  6:59   ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 02/10] powerpc: Rename 'funcaddr' to 'addr' in 'struct ppc64_opd_entry' Christophe Leroy
2021-10-13  6:59   ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 03/10] ia64: Rename 'ip' to 'addr' in 'struct fdesc' Christophe Leroy
2021-10-13  6:59   ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 04/10] asm-generic: Use HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to define associated stubs Christophe Leroy
2021-10-12  6:02   ` Helge Deller
2021-10-12  6:11     ` Christophe Leroy
2021-10-12  6:48       ` Helge Deller
2021-10-13  7:00   ` Kees Cook
2021-10-14  7:20     ` Christophe Leroy
2021-10-11 15:25 ` [PATCH v1 05/10] asm-generic: Define 'funct_descr_t' to commonly describe function descriptors Christophe Leroy
2021-10-13  7:01   ` Kees Cook
2021-10-13  7:23     ` Christophe Leroy
2021-10-13  7:27       ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 06/10] asm-generic: Refactor dereference_[kernel]_function_descriptor() Christophe Leroy
2021-10-13  7:02   ` Kees Cook
2021-10-13 11:20     ` Christophe Leroy
2021-10-13 11:34       ` Arnd Bergmann
2021-10-11 15:25 ` [PATCH v1 07/10] lkdtm: Force do_nothing() out of line Christophe Leroy
2021-10-13  7:02   ` Kees Cook
2021-10-11 15:25 ` [PATCH v1 08/10] lkdtm: Really write into kernel text in WRITE_KERN Christophe Leroy
2021-10-13  7:05   ` Kees Cook
2021-10-13  7:29     ` Christophe Leroy [this message]
2021-10-11 15:25 ` [PATCH v1 09/10] lkdtm: Fix lkdtm_EXEC_RODATA() Christophe Leroy
2021-10-13  7:09   ` Kees Cook
2021-10-13  7:35     ` Christophe Leroy
2021-10-13  7:23   ` Kees Cook
2021-10-13  7:39     ` Christophe Leroy
2021-10-13  7:48       ` Christophe Leroy
2021-10-13 12:45         ` Christophe Leroy
2021-10-11 15:25 ` [PATCH v1 10/10] lkdtm: Fix execute_[user]_location() Christophe Leroy
2021-10-13  7:16   ` Kees Cook
2021-10-13 12:00     ` Christophe Leroy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=336f314c-2db3-0899-b012-18c493ae0e3a@csgroup.eu \
    --to=christophe.leroy@csgroup.eu \
    --cc=James.Bottomley@hansenpartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=deller@gmx.de \
    --cc=gregkh@linuxfoundation.org \
    --cc=keescook@chromium.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).