On Thu, 2020-02-06 at 06:48 +0100, Christophe Leroy wrote: > > --- a/arch/powerpc/kernel/mce_power.c > > +++ b/arch/powerpc/kernel/mce_power.c > > @@ -29,7 +29,7 @@ unsigned long addr_to_pfn(struct pt_regs *regs, unsigned long addr) > > { > > pte_t *ptep; > > unsigned int shift; > > - unsigned long pfn, flags; > > + unsigned long pfn, irq_mask; > > Why change the name ? flags is a well known historical name. Oh, this commit missed the reasoning for flags name change. For local_irq_{save,restore} a parameter named flags makes sense, for the reader, as it could only be flags regarding irq. I thougt passing flags to {begin,end}_lockless_pgtbl_walk would lose it's meaning, given that it would only mean "flags for these functions" So, changing it to irq_mask would make the reader more aware of what it does mean. For other commits, I added: "Variable that saves the irq mask was renamed from flags to irq_mask so it doesn't lose meaning now it's not directly passed to local_irq_* functions." I can add it to this commit message. Thanks for the feedback, Leonardo Bras