linux-arch.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2018-05-15 00:25:52 to 2018-05-18 09:17:30 UTC [more...]

[PATCH v6 00/28] New macros for assembler symbols
 2018-05-18  9:17 UTC  (33+ messages)
` [PATCH v6 01/28] linkage: new "
` [PATCH v6 02/28] x86/asm/suspend: drop ENTRY from local data
` [PATCH v6 03/28] x86/asm/suspend: use SYM_DATA for data
` [PATCH v6 04/28] x86/asm: annotate relocate_kernel
` [PATCH v6 05/28] x86/asm/entry: annotate THUNKs
` [PATCH v6 06/28] x86/asm: annotate local pseudo-functions
` [PATCH v6 07/28] x86/asm/crypto: annotate local functions
` [PATCH v6 08/28] x86/boot/compressed: "
` [PATCH v6 09/28] x86/asm: annotate aliases
` [PATCH v6 10/28] x86/asm/entry: annotate interrupt symbols properly
` [PATCH v6 11/28] x86/asm/head: annotate data appropriatelly
` [PATCH v6 12/28] x86/boot/compressed: "
` [PATCH v6 13/28] um: "
` [PATCH v6 14/28] xen/pvh: "
` [PATCH v6 15/28] x86/asm/purgatory: start using annotations
` [PATCH v6 16/28] x86/asm: do not annotate functions by GLOBAL
` [PATCH v6 17/28] x86/asm: use SYM_INNER_LABEL instead of GLOBAL
` [PATCH v6 18/28] x86/asm/realmode: use SYM_DATA_* "
` [PATCH v6 19/28] x86/asm: kill the last GLOBAL user and remove the macro
` [PATCH v6 20/28] x86/asm: make some functions local
` [PATCH v6 21/28] x86/asm/ftrace: mark function_hook as function
` [PATCH v6 22/28] x86_64/asm: add ENDs to some functions and relabel with SYM_CODE_*
` [PATCH v6 23/28] x86_64/asm: change all ENTRY+END to SYM_CODE_*
` [PATCH v6 24/28] x86_64/asm: change all ENTRY+ENDPROC to SYM_FUNC_*
` [PATCH v6 25/28] x86_32/asm: add ENDs to some functions and relabel with SYM_CODE_*
` [PATCH v6 26/28] x86_32/asm: change all ENTRY+END to SYM_CODE_*
` [PATCH v6 27/28] x86_32/asm: change all ENTRY+ENDPROC to SYM_FUNC_*
` [PATCH v6 28/28] x86/asm: replace WEAK uses by SYM_INNER_LABEL

[PATCH -resend 00/27] New macros for assembler symbols
 2018-05-18  9:17 UTC  (7+ messages)
` [PATCH -resend 02/27] x86: assembly, use SYM_DATA for data

[PATCH 4.9 27/33] futex: Remove duplicated code and fix undefined behaviour
 2018-05-18  9:01 UTC  (6+ messages)

[PATCH v5 2/4] kernel hacking: new config NO_AUTO_INLINE to disable compiler auto-inline optimizations
 2018-05-17 17:58 UTC  (5+ messages)

[RFC PATCH] UAPI: Document auxvec AT_* namespace policy and note reservations
 2018-05-17 16:00 UTC  (14+ messages)

[PATCH] pkeys: Introduce PKEY_ALLOC_SIGNALINHERIT and change signal semantics
 2018-05-17 10:11 UTC  (32+ messages)

[PATCH v4 0/8] Introduce the for_each_set_clump macro
 2018-05-16 20:08 UTC  (22+ messages)
` [PATCH v4 1/8] bitops: "
` [PATCH v4 2/8] lib/test_bitmap.c: Add for_each_set_clump test cases
` [PATCH v4 3/8] gpio: 104-dio-48e: Utilize for_each_set_clump macro
` [PATCH v4 4/8] gpio: 104-idi-48: "
` [PATCH v4 5/8] gpio: gpio-mm: "
` [PATCH v4 6/8] gpio: ws16c48: "
` [PATCH v4 7/8] gpio: pci-idio-16: "
` [PATCH v4 8/8] gpio: pcie-idio-24: "

[PATCH v3 0/2] mm: PAGE_KERNEL_* fallbacks
 2018-05-16 16:44 UTC  (3+ messages)

[PATCH] arm64: remove no-op macro VMLINUX_SYMBOL()
 2018-05-16 10:47 UTC  (3+ messages)

[PATCH v9 00/24] ILP32 for ARM64
 2018-05-16  8:19 UTC  (49+ messages)
` [PATCH 01/24] arm64: signal: Make parse_user_sigframe() independent of rt_sigframe layout
` [PATCH 02/24] ptrace: Add compat PTRACE_{G,S}ETSIGMASK handlers
` [PATCH 03/24] compat ABI: use non-compat openat and open_by_handle_at variants
` [PATCH 04/24] 32-bit userspace ABI: introduce ARCH_32BIT_OFF_T config option
` [PATCH 05/24] asm-generic: Drop getrlimit and setrlimit syscalls from default list
` [PATCH 06/24] thread: move thread bits accessors to separated file
` [PATCH 07/24] arm64: ilp32: add documentation on the ILP32 ABI for ARM64
` [PATCH 08/24] arm64: rename COMPAT to AARCH32_EL0 in Kconfig
` [PATCH 09/24] arm64: rename functions that reference compat term
` [PATCH 10/24] arm64: uapi: set __BITS_PER_LONG correctly for ILP32 and LP64
` [PATCH 11/24] arm64: introduce is_a32_task and is_a32_thread (for AArch32 compat)
` [PATCH 12/24] arm64: ilp32: add is_ilp32_compat_{task,thread} and TIF_32BIT_AARCH64
` [PATCH 13/24] arm64: introduce binfmt_elf32.c
` [PATCH 14/24] arm64: change compat_elf_hwcap and compat_elf_hwcap2 prefix to a32
` [PATCH 15/24] arm64: ilp32: introduce binfmt_ilp32.c
` [PATCH 16/24] arm64: ilp32: share aarch32 syscall handlers
` [PATCH 17/24] arm64: ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it
` [PATCH 18/24] arm64: signal: share lp64 signal structures and routines to ilp32
` [PATCH 19/24] arm64: signal32: move ilp32 and aarch32 common code to separated file
` [PATCH 20/24] arm64: ilp32: introduce ilp32-specific sigframe and ucontext
` [PATCH 21/24] arm64: ptrace: handle ptrace_request differently for aarch32 and ilp32
` [PATCH 22/24] arm64:ilp32: add vdso-ilp32 and use for signal return
` [PATCH 23/24] arm64:ilp32: add ARM64_ILP32 to Kconfig
` [PATCH 24/24] arm64: ilp32: Make the Kconfig option default y

[PATCH 00/12] introduce support for early platform drivers
 2018-05-16  1:06 UTC  (11+ messages)
` [PATCH 09/12] platform/early: add an init section for early driver data
` [PATCH 10/12] platform/early: implement support for early platform drivers

[PATCH v9 00/24] ILP32 for ARM64
 2018-05-15 19:40 UTC  (8+ messages)
` [PATCH 01/24] arm64: signal: Make parse_user_sigframe() independent of rt_sigframe layout
` [PATCH 02/24] ptrace: Add compat PTRACE_{G,S}ETSIGMASK handlers

[PATCH memory-model 0/19] Updates to the formal memory model
 2018-05-15 16:20 UTC  (5+ messages)

[PATCH v3 0/8] Introduce the for_each_set_clump macro
 2018-05-15 15:51 UTC  (18+ messages)
` [PATCH v3 1/8] bitops: "
` [PATCH v3 2/8] lib/test_bitmap.c: Add for_each_set_clump test cases
` [PATCH v3 3/8] gpio: 104-dio-48e: Utilize for_each_set_clump macro
` [PATCH v3 4/8] gpio: 104-idi-48: "
` [PATCH v3 5/8] gpio: gpio-mm: "
` [PATCH v3 6/8] gpio: ws16c48: "
` [PATCH v3 7/8] gpio: pci-idio-16: "
` [PATCH v3 8/8] gpio: pcie-idio-24: "

[RFC PATCH 00/11] prctl: Modernise wiring for optional prctl() calls
 2018-05-15 13:30 UTC  (10+ messages)
` [RFC PATCH 06/11] powerpc: Remove unused task argument from prctl functions
` [RFC PATCH 07/11] powerpc: Move arch-specific prctls out of core code

[PATCH REPOST 0/5] Simplify setting thread flags to a particular value
 2018-05-15  3:13 UTC  (4+ messages)
` [PATCH REPOST 4/5] powerpc: Use update_thread_flag()

[PATCH 1/3] int-ll64.h: define u{8,16,32,64} and s{8,16,32,64} based on uapi header
 2018-05-15  2:22 UTC  (2+ messages)

common non-cache coherent direct dma mapping ops
 2018-05-15  0:25 UTC  (4+ messages)
` [PATCH 05/20] c6x: use generic dma_noncoherent_ops
    ` [Linux-c6x-dev] "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).