linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: wangyijing@huawei.com (Yijing Wang)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v5 07/29] PCI: Introduce pci_host_assign_domain_nr() to assign domain
Date: Fri, 6 Mar 2015 17:33:24 +0800	[thread overview]
Message-ID: <1425634426-437-8-git-send-email-wangyijing@huawei.com> (raw)
In-Reply-To: <1425634426-437-1-git-send-email-wangyijing@huawei.com>

Introduce pci_host_assign_domain_nr() to assign domain
number for pci_host_bridge. Later we will remove
pci_bus_assign_domain_nr().

Signed-off-by: Yijing Wang <wangyijing@huawei.com>
Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
---
 drivers/pci/pci.c   |   20 +++++++++++++++-----
 include/linux/pci.h |    4 ++++
 2 files changed, 19 insertions(+), 5 deletions(-)

diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
index 81f06e8..c49eec1 100644
--- a/drivers/pci/pci.c
+++ b/drivers/pci/pci.c
@@ -4501,10 +4501,10 @@ int pci_get_new_domain_nr(void)
 }
 
 #ifdef CONFIG_PCI_DOMAINS_GENERIC
-void pci_bus_assign_domain_nr(struct pci_bus *bus, struct device *parent)
+static int pci_assign_domain_nr(struct device *dev)
 {
 	static int use_dt_domains = -1;
-	int domain = of_get_pci_domain_nr(parent->of_node);
+	int domain = of_get_pci_domain_nr(dev->of_node);
 
 	/*
 	 * Check DT domain and use_dt_domains values.
@@ -4538,12 +4538,22 @@ void pci_bus_assign_domain_nr(struct pci_bus *bus, struct device *parent)
 		use_dt_domains = 0;
 		domain = pci_get_new_domain_nr();
 	} else {
-		dev_err(parent, "Node %s has inconsistent \"linux,pci-domain\" property in DT\n",
-			parent->of_node->full_name);
+		dev_err(dev, "Node %s has inconsistent \"linux,pci-domain\" property in DT\n",
+			dev->of_node->full_name);
 		domain = -1;
 	}
 
-	bus->domain_nr = domain;
+	return domain;
+}
+
+void pci_host_assign_domain_nr(struct pci_host_bridge *host)
+{
+	host->domain = pci_assign_domain_nr(host->dev.parent);
+}
+
+void pci_bus_assign_domain_nr(struct pci_bus *bus, struct device *parent)
+{
+	bus->domain_nr = pci_assign_domain_nr(parent);
 }
 #endif
 #endif
diff --git a/include/linux/pci.h b/include/linux/pci.h
index 8b3d245..2b1b998 100644
--- a/include/linux/pci.h
+++ b/include/linux/pci.h
@@ -1327,11 +1327,15 @@ static inline int pci_domain_nr(struct pci_bus *bus)
 	return bus->domain_nr;
 }
 void pci_bus_assign_domain_nr(struct pci_bus *bus, struct device *parent);
+void pci_host_assign_domain_nr(struct pci_host_bridge *host);
 #else
 static inline void pci_bus_assign_domain_nr(struct pci_bus *bus,
 					struct device *parent)
 {
 }
+static inline void pci_host_assign_domain_nr(struct pci_host_bridge *host)
+{
+}
 #endif
 
 /* some architectures require additional setup to direct VGA traffic */
-- 
1.7.1

  parent reply	other threads:[~2015-03-06  9:33 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-06  9:33 [PATCH v5 00/29] Refine PCI scan interfaces and make generic pci host bridge Yijing Wang
2015-03-06  9:33 ` [PATCH v5 01/29] PCI: Rip out pci_bus_add_devices() from pci_scan_bus() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 02/29] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 03/29] xen/PCI: Don't use deprecated function pci_scan_bus_parented() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 04/29] PCI: Remove deprecated pci_scan_bus_parented() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 05/29] PCI: Combine PCI domain and bus number in u32 arg Yijing Wang
2015-03-06  9:33 ` [PATCH v5 06/29] PCI: Pass PCI domain number combined with root bus number Yijing Wang
2015-03-06  9:33 ` Yijing Wang [this message]
2015-03-06  9:33 ` [PATCH v5 08/29] PCI: Separate pci_host_bridge creation out of pci_create_root_bus() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 09/29] PCI: Introduce pci_host_bridge_list to manage host bridges Yijing Wang
2015-03-06  9:33 ` [PATCH v5 10/29] PCI: Save sysdata in pci_host_bridge drvdata Yijing Wang
2015-03-06  9:33 ` [PATCH v5 11/29] PCI: Introduce pci_host_bridge_ops to support host specific operations Yijing Wang
2015-03-06  9:33 ` [PATCH v5 12/29] PCI: Introduce new scan function pci_scan_host_bridge() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 13/29] x86/PCI: Refine pci_acpi_scan_root() with generic pci_host_bridge Yijing Wang
2015-03-06  9:33 ` [PATCH v5 14/29] ia64/PCI: " Yijing Wang
2015-03-06  9:33 ` [PATCH v5 15/29] powerpc/pci: Rename pcibios_root_bridge_prepare() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 16/29] powerpc/pci: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-06 14:19   ` Rob Herring
2015-03-09  2:47     ` Yijing Wang
2015-03-06  9:33 ` [PATCH v5 17/29] PCI: Remove weak pcibios_root_bridge_prepare() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 18/29] sparc/PCI: Claim bus resources before pci_bus_add_devices() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 19/29] sparc/PCI: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-06  9:33 ` [PATCH v5 20/29] PCI: Introduce pci_bus_child_max_busnr() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 21/29] parisc/PCI: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-06  9:33 ` [PATCH v5 22/29] PCI/mvebu: Use pci_common_init_dev() to simplify code Yijing Wang
2015-03-06  9:33 ` [PATCH v5 23/29] PCI/tegra: Remove redundant tegra_pcie_scan_bus() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 24/29] PCI/designware: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-06  9:33 ` [PATCH v5 25/29] PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 26/29] PCI: Rename __pci_create_root_bus() to pci_create_root_bus() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 27/29] PCI: Export find_pci_host_bridge() and rename to pci_find_host_bridge() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 28/29] PCI: Remove platform specific pci_domain_nr() Yijing Wang
2015-03-06  9:33 ` [PATCH v5 29/29] PCI: Remove pci_bus_assign_domain_nr() Yijing Wang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1425634426-437-8-git-send-email-wangyijing@huawei.com \
    --to=wangyijing@huawei.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).