linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v3 00/37] ARM: davinci: modernize the irq support
@ 2019-02-12 10:37 Bartosz Golaszewski
  2019-02-12 10:37 ` [PATCH v3 01/37] input: davinci_keyscan: remove unnecessary includes Bartosz Golaszewski
                   ` (36 more replies)
  0 siblings, 37 replies; 43+ messages in thread
From: Bartosz Golaszewski @ 2019-02-12 10:37 UTC (permalink / raw)
  To: Sekhar Nori, Kevin Hilman, Thomas Gleixner, Jason Cooper,
	Marc Zyngier, David Lechner
  Cc: Bartosz Golaszewski, linux-kernel, linux-arm-kernel

From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

This series ports the davinci platform to using SPARSE_IRQ, cleans up
the irqchip drivers and moves them over to drivers/irqchip.

The series can be logically split into five parts. The first patch
preemptively fixes a problem in an input driver that would have caused
problems later. Patches (2-9) aim at introducing support for SPARSE_IRQ.
They contain a couple changes required for that functionality and do some
cleanup at the end.

Third part (10-22) makes the aintc driver suitable for drivers/irqchip
and eventually moves it over there.

Part 4 (23-36) does the same for the cp-intc driver.

Last patch removes unnecessary code.

The series has been tested on da850-lcdk (for cp-intc) and
dm365-evm (for aintc).

v1 -> v2:
- made commit messages readable without reading the subject line first
- collected David's Reviewed-by tags for patches that haven been
  significantly modified since v1
- added handling of spurious interrupts in cp-intc
- added comments explaining the irq handlers (C versions translated from
  assembly)
- dropped the patches removing the hardware interrupt numbers from
  the priority tables
- don't remove irqs.h, make it a local header instead
- rearranged the patches in order not to remove the code added
  by earlier ones
- renamed d*_init_irqs to d*_init_irq to fit the name of the relevant
  callback in machine info struct
- fixed license identifiers where needed
- added comments to config structures for irqchip drivers
- fixed all off-by-one errors in resource sizes
- clarified the comments on the weird handling of IRQ_TINT1_TINT34 as level
  irq and added missing calls to irq_set_handler() to dm3* SoCs
- fixed one function that was missing a correct prefix in cp_intc
- return value variables should be called ret not rv
- added a patch converting calls to _raw_readl/writel() to their _relaxed
  counterparts
- fixed the commit message prefix in patches that belong to the irqchip
  subsystem

v2 -> v3:
- added a patch preventing a build problem in davinci_keyscan driver
- converted another usage of 'int rv' to 'int ret'
- don't use __raw_readl/writel() in new patches, but leave patches converting
  previous uses
- drop a stray newline in usb.c when removing irqs.h
- when unifying the error handling: use specific messages instead of WARN_ON()
- do the above for aintc as well
- add patches adding calls to request_mem_region() to both drivers

Bartosz Golaszewski (37):
  input: davinci_keyscan: remove unnecessary includes
  ARM: davinci: remove intc_host_map from davinci_soc_info struct
  ARM: davinci: aintc: use irq domain
  ARM: davinci: select GENERIC_IRQ_MULTI_HANDLER
  ARM: davinci: remove davinci_intc_type
  ARM: davinci: pull davinci_intc_base into the respective intc drivers
  ARM: davinci: wrap HW interrupt numbers with a macro
  ARM: davinci: select SPARSE_IRQ
  ARM: davinci: make irqs.h a local header
  ARM: davinci: aintc: drop GPL license boilerplate
  ARM: davinci: aintc: wrap davinci_irq_init() with a helper
  ARM: davinci: aintc: use a common prefix for symbols in the driver
  ARM: davinci: aintc: drop the 00 prefix from register offsets
  ARM: davinci: aintc: use readl/writel_relaxed()
  irqchip: davinci-aintc: add a new config structure
  ARM: davinci: aintc: use the new irqchip config structure in dm* SoCs
  ARM: davinci: aintc: use the new config structure
  ARM: davinci: aintc: unify error handling
  ARM: davinci: aintc: request memory region before remapping it
  ARM: davinci: aintc: move timer-specific irq_set_handler() out of
    irq.c
  ARM: davinci: aintc: remove unnecessary includes
  irqchip: davinci-aintc: move the driver to drivers/irqchip
  ARM: davinci: cp-intc: remove cp_intc.h
  ARM: davinci: cp-intc: add a wrapper around cp_intc_init()
  irqchip: davinci-cp-intc: add a new config structure
  ARM: davinci: cp-intc: add the new config structures for da8xx SoCs
  ARM: davinci: cp-intc: use a common prefix for all symbols
  ARM: davinci: cp-intc: convert all hex numbers to lowercase
  ARM: davinci: cp-intc: use the new-style config structure
  ARM: davinci: cp-intc: request the memory region before remapping it
  ARM: davinci: cp-intc: improve coding style
  ARM: davinci: cp-intc: unify error handling
  ARM: davinci: cp-intc: use readl/writel_relaxed()
  ARM: davinci: cp-intc: drop GPL license boilerplate
  ARM: davinci: cp-intc: remove redundant comments
  irqchip: davinci-cp-intc: move the driver to drivers/irqchip
  ARM: davinci: remove intc related fields from davinci_soc_info

 arch/arm/Kconfig                              |   2 +
 arch/arm/mach-davinci/Kconfig                 |  19 +-
 arch/arm/mach-davinci/Makefile                |   3 -
 arch/arm/mach-davinci/asp.h                   |   8 +-
 arch/arm/mach-davinci/board-da830-evm.c       |   5 +-
 arch/arm/mach-davinci/board-da850-evm.c       |   5 +-
 arch/arm/mach-davinci/board-dm355-evm.c       |   2 +-
 arch/arm/mach-davinci/board-dm355-leopard.c   |   2 +-
 arch/arm/mach-davinci/board-dm365-evm.c       |   2 +-
 arch/arm/mach-davinci/board-dm644x-evm.c      |   8 +-
 arch/arm/mach-davinci/board-dm646x-evm.c      |   7 +-
 arch/arm/mach-davinci/board-mityomapl138.c    |   3 +-
 arch/arm/mach-davinci/board-neuros-osd2.c     |   2 +-
 arch/arm/mach-davinci/board-omapl138-hawk.c   |   3 +-
 arch/arm/mach-davinci/board-sffsdr.c          |   2 +-
 arch/arm/mach-davinci/common.c                |   3 -
 arch/arm/mach-davinci/cp_intc.c               | 215 ---------------
 arch/arm/mach-davinci/cp_intc.h               |  57 ----
 arch/arm/mach-davinci/da830.c                 | 128 ++-------
 arch/arm/mach-davinci/da850.c                 | 154 ++---------
 arch/arm/mach-davinci/davinci.h               |   4 +
 arch/arm/mach-davinci/devices-da8xx.c         | 147 +++++-----
 arch/arm/mach-davinci/devices.c               |  40 +--
 arch/arm/mach-davinci/dm355.c                 |  86 +++---
 arch/arm/mach-davinci/dm365.c                 | 110 +++++---
 arch/arm/mach-davinci/dm644x.c                |  76 +++--
 arch/arm/mach-davinci/dm646x.c                |  90 +++---
 arch/arm/mach-davinci/include/mach/common.h   |  14 +-
 arch/arm/mach-davinci/include/mach/da8xx.h    |   2 +
 .../mach-davinci/include/mach/entry-macro.S   |  39 ---
 arch/arm/mach-davinci/irq.c                   | 117 --------
 .../mach-davinci/{include/mach => }/irqs.h    |   4 -
 arch/arm/mach-davinci/usb-da8xx.c             |   9 +-
 arch/arm/mach-davinci/usb.c                   |  13 +-
 drivers/input/keyboard/davinci_keyscan.c      |   4 -
 drivers/irqchip/Kconfig                       |  10 +
 drivers/irqchip/Makefile                      |   2 +
 drivers/irqchip/irq-davinci-aintc.c           | 163 +++++++++++
 drivers/irqchip/irq-davinci-cp-intc.c         | 260 ++++++++++++++++++
 include/linux/irqchip/irq-davinci-aintc.h     |  27 ++
 include/linux/irqchip/irq-davinci-cp-intc.h   |  25 ++
 41 files changed, 912 insertions(+), 960 deletions(-)
 delete mode 100644 arch/arm/mach-davinci/cp_intc.c
 delete mode 100644 arch/arm/mach-davinci/cp_intc.h
 delete mode 100644 arch/arm/mach-davinci/include/mach/entry-macro.S
 delete mode 100644 arch/arm/mach-davinci/irq.c
 rename arch/arm/mach-davinci/{include/mach => }/irqs.h (98%)
 create mode 100644 drivers/irqchip/irq-davinci-aintc.c
 create mode 100644 drivers/irqchip/irq-davinci-cp-intc.c
 create mode 100644 include/linux/irqchip/irq-davinci-aintc.h
 create mode 100644 include/linux/irqchip/irq-davinci-cp-intc.h

-- 
2.20.1


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply	[flat|nested] 43+ messages in thread

end of thread, other threads:[~2019-02-14 14:10 UTC | newest]

Thread overview: 43+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-02-12 10:37 [PATCH v3 00/37] ARM: davinci: modernize the irq support Bartosz Golaszewski
2019-02-12 10:37 ` [PATCH v3 01/37] input: davinci_keyscan: remove unnecessary includes Bartosz Golaszewski
2019-02-14 14:09   ` Sekhar Nori
2019-02-12 10:38 ` [PATCH v3 02/37] ARM: davinci: remove intc_host_map from davinci_soc_info struct Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 03/37] ARM: davinci: aintc: use irq domain Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 04/37] ARM: davinci: select GENERIC_IRQ_MULTI_HANDLER Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 05/37] ARM: davinci: remove davinci_intc_type Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 06/37] ARM: davinci: pull davinci_intc_base into the respective intc drivers Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 07/37] ARM: davinci: wrap HW interrupt numbers with a macro Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 08/37] ARM: davinci: select SPARSE_IRQ Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 09/37] ARM: davinci: make irqs.h a local header Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 10/37] ARM: davinci: aintc: drop GPL license boilerplate Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 11/37] ARM: davinci: aintc: wrap davinci_irq_init() with a helper Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 12/37] ARM: davinci: aintc: use a common prefix for symbols in the driver Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 13/37] ARM: davinci: aintc: drop the 00 prefix from register offsets Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 14/37] ARM: davinci: aintc: use readl/writel_relaxed() Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 15/37] irqchip: davinci-aintc: add a new config structure Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 16/37] ARM: davinci: aintc: use the new irqchip config structure in dm* SoCs Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 17/37] ARM: davinci: aintc: use the new config structure Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 18/37] ARM: davinci: aintc: unify error handling Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 19/37] ARM: davinci: aintc: request memory region before remapping it Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 20/37] ARM: davinci: aintc: move timer-specific irq_set_handler() out of irq.c Bartosz Golaszewski
2019-02-14 10:57   ` Marc Zyngier
2019-02-14 12:44     ` Sekhar Nori
2019-02-14 12:56       ` Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 21/37] ARM: davinci: aintc: remove unnecessary includes Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 22/37] irqchip: davinci-aintc: move the driver to drivers/irqchip Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 23/37] ARM: davinci: cp-intc: remove cp_intc.h Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 24/37] ARM: davinci: cp-intc: add a wrapper around cp_intc_init() Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 25/37] irqchip: davinci-cp-intc: add a new config structure Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 26/37] ARM: davinci: cp-intc: add the new config structures for da8xx SoCs Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 27/37] ARM: davinci: cp-intc: use a common prefix for all symbols Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 28/37] ARM: davinci: cp-intc: convert all hex numbers to lowercase Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 29/37] ARM: davinci: cp-intc: use the new-style config structure Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 30/37] ARM: davinci: cp-intc: request the memory region before remapping it Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 31/37] ARM: davinci: cp-intc: improve coding style Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 32/37] ARM: davinci: cp-intc: unify error handling Bartosz Golaszewski
2019-02-14 11:11   ` Marc Zyngier
2019-02-12 10:38 ` [PATCH v3 33/37] ARM: davinci: cp-intc: use readl/writel_relaxed() Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 34/37] ARM: davinci: cp-intc: drop GPL license boilerplate Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 35/37] ARM: davinci: cp-intc: remove redundant comments Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 36/37] irqchip: davinci-cp-intc: move the driver to drivers/irqchip Bartosz Golaszewski
2019-02-12 10:38 ` [PATCH v3 37/37] ARM: davinci: remove intc related fields from davinci_soc_info Bartosz Golaszewski

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).