linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/2] arm64: memory: VA_START fixups
@ 2019-08-14 13:28 Mark Rutland
  2019-08-14 13:28 ` [PATCH 1/2] arm64: memory: fix flipped VA space fallout Mark Rutland
                   ` (2 more replies)
  0 siblings, 3 replies; 6+ messages in thread
From: Mark Rutland @ 2019-08-14 13:28 UTC (permalink / raw)
  To: linux-arm-kernel; +Cc: mark.rutland, catalin.marinas, will, steve.capper

Hi all,

These patches address my concerns with the new VA_START semantic as I
spotted while reviewing Will's 52-bit VA cleanup. The first patch
corrects the newly broken usage of VA_START, and the second renames
VA_START to PAGE_END to make the new semantic clearer.

Both patches are based on the arm64 for-next/52-bit-kva branch, and I've
given a 52-bit VA configuration a build+boot test (on HW without 52-bit
VA support).

Thanks,
Mark.

Mark Rutland (2):
  arm64: memory: fix flipped VA space fallout
  arm64: memory: rename VA_START to PAGE_END

 arch/arm64/include/asm/memory.h  | 20 ++++++++++----------
 arch/arm64/include/asm/pgtable.h |  4 ++--
 arch/arm64/kernel/hibernate.c    |  2 +-
 arch/arm64/mm/dump.c             |  8 ++++----
 arch/arm64/mm/fault.c            |  2 +-
 arch/arm64/mm/kasan_init.c       |  2 +-
 arch/arm64/mm/mmu.c              |  4 ++--
 7 files changed, 21 insertions(+), 21 deletions(-)

-- 
2.11.0


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2019-08-14 14:52 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-08-14 13:28 [PATCH 0/2] arm64: memory: VA_START fixups Mark Rutland
2019-08-14 13:28 ` [PATCH 1/2] arm64: memory: fix flipped VA space fallout Mark Rutland
2019-08-14 14:51   ` Steve Capper
2019-08-14 13:28 ` [PATCH 2/2] arm64: memory: rename VA_START to PAGE_END Mark Rutland
2019-08-14 14:51   ` Steve Capper
2019-08-14 14:51 ` [PATCH 0/2] arm64: memory: VA_START fixups Steve Capper

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).