linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Syed Nayyar Waris <syednwaris@gmail.com>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Cc: Bartosz Golaszewski <bgolaszewski@baylibre.com>,
	 William Breathitt Gray <vilhelm.gray@gmail.com>,
	Michal Simek <michal.simek@xilinx.com>,
	 Arnd Bergmann <arnd@arndb.de>,
	Robert Richter <rrichter@marvell.com>,
	 Linus Walleij <linus.walleij@linaro.org>,
	Masahiro Yamada <yamada.masahiro@socionext.com>,
	 Andrew Morton <akpm@linux-foundation.org>,
	"Zhang, Rui" <rui.zhang@intel.com>,
	 Daniel Lezcano <daniel.lezcano@linaro.org>,
	Amit Kucheria <amit.kucheria@verdurent.com>,
	 Linux-Arch <linux-arch@vger.kernel.org>,
	 "open list:GPIO SUBSYSTEM" <linux-gpio@vger.kernel.org>,
	 Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	 linux-arm Mailing List <linux-arm-kernel@lists.infradead.org>,
	Linux PM <linux-pm@vger.kernel.org>
Subject: Re: [PATCH v3 3/3] gpio: xilinx: Utilize generic bitmap_get_value and _set_value
Date: Fri, 2 Apr 2021 15:37:26 +0530	[thread overview]
Message-ID: <CACG_h5qV2g7GUKtktBydxfx2Z-o3_6Tssj_+Dt-xZxYKVo9YMw@mail.gmail.com> (raw)
In-Reply-To: <YGHxNFXAjcg4PfnE@smile.fi.intel.com>

On Mon, Mar 29, 2021 at 8:54 PM Andy Shevchenko
<andriy.shevchenko@linux.intel.com> wrote:
>
> On Sat, Mar 06, 2021 at 07:36:30PM +0530, Syed Nayyar Waris wrote:
> > This patch reimplements the xgpio_set_multiple() function in
> > drivers/gpio/gpio-xilinx.c to use the new generic functions:
> > bitmap_get_value() and bitmap_set_value(). The code is now simpler
> > to read and understand. Moreover, instead of looping for each bit
> > in xgpio_set_multiple() function, now we can check each channel at
> > a time and save cycles.
>
> ...
>
> > +     u32 *const state = chip->gpio_state;
>
> Looking at this... What's the point of the const here?
>
> Am I right that this tells: pointer is a const, while the data underneath
> can be modified?

Yes you are right and the data underneath can be modified.
I have removed the 'const' in v4

>
> > +     unsigned int *const width = chip->gpio_width;
>
> Ditto.
>
> Putting const:s here and there for sake of the const is not good practice.
> It makes code harder to read.

Okay.

>
> --
> With Best Regards,
> Andy Shevchenko
>
>

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

      parent reply	other threads:[~2021-04-02 10:18 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-06 14:01 [PATCH v3 0/3] Introduce the for_each_set_nbits macro Syed Nayyar Waris
2021-03-06 14:03 ` [PATCH v3 1/3] gpiolib: " Syed Nayyar Waris
2021-03-06 14:05 ` [PATCH v3 2/3] gpio: thunderx: Utilize " Syed Nayyar Waris
2021-03-06 14:06 ` [PATCH v3 3/3] gpio: xilinx: Utilize generic bitmap_get_value and _set_value Syed Nayyar Waris
2021-03-08  7:13   ` Michal Simek
2021-03-26 17:27     ` Bartosz Golaszewski
2021-03-31 15:26       ` Srinivas Neeli
2021-04-01 11:15         ` Syed Nayyar Waris
2021-04-01 12:51           ` Bartosz Golaszewski
2021-03-26 17:57   ` Andy Shevchenko
2021-04-02  9:40     ` Syed Nayyar Waris
2021-03-26 18:02   ` Andy Shevchenko
2021-03-26 22:12     ` Syed Nayyar Waris
     [not found]       ` <CAHp75VfDZbJjCOEGdHc=-D6W8_7m2=CinXj-itwn6hvoVqdWYQ@mail.gmail.com>
2021-03-27 12:02         ` William Breathitt Gray
2021-03-27 16:35           ` Andy Shevchenko
2021-04-01 17:50             ` Syed Nayyar Waris
2021-03-29 15:24   ` Andy Shevchenko
2021-04-01 17:47     ` Syed Nayyar Waris
2021-04-02 10:07     ` Syed Nayyar Waris [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CACG_h5qV2g7GUKtktBydxfx2Z-o3_6Tssj_+Dt-xZxYKVo9YMw@mail.gmail.com \
    --to=syednwaris@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=amit.kucheria@verdurent.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=arnd@arndb.de \
    --cc=bgolaszewski@baylibre.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=michal.simek@xilinx.com \
    --cc=rrichter@marvell.com \
    --cc=rui.zhang@intel.com \
    --cc=vilhelm.gray@gmail.com \
    --cc=yamada.masahiro@socionext.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).