linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: silviupopescu1990@gmail.com (Silviu Popescu)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH] mach_omap2: use PTR_RET instead of IS_ERR + PTR_ERR
Date: Thu, 21 Mar 2013 20:33:01 +0200	[thread overview]
Message-ID: <CAPWTe+JYEZJ5Zn6Dt9mmr38raXdM8wc1eWFro2a4Czy-eCzSpQ@mail.gmail.com> (raw)
In-Reply-To: <5149FFDF.6050501@ti.com>

On Wed, Mar 20, 2013 at 8:28 PM, Jon Hunter <jon-hunter@ti.com> wrote:
>
> On 03/12/2013 06:05 AM, Russell King - ARM Linux wrote:
>> On Tue, Mar 12, 2013 at 09:58:29AM +0200, Silviu-Mihai Popescu wrote:
>>> This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase
>>> readability.
>>>
>>> Signed-off-by: Silviu-Mihai Popescu <silviupopescu1990@gmail.com>
>>> ---
>>>  arch/arm/mach-omap2/devices.c |    4 ++--
>>>  arch/arm/mach-omap2/fb.c      |    5 +----
>>>  arch/arm/mach-omap2/gpmc.c    |    2 +-
>>>  arch/arm/mach-omap2/pmu.c     |    5 +----
>>>  4 files changed, 5 insertions(+), 11 deletions(-)
>>>
>>> diff --git a/arch/arm/mach-omap2/devices.c b/arch/arm/mach-omap2/devices.c
>>> index 1ec7f05..2a0816e 100644
>>> --- a/arch/arm/mach-omap2/devices.c
>>> +++ b/arch/arm/mach-omap2/devices.c
>>> @@ -66,7 +66,7 @@ static int __init omap3_l3_init(void)
>>>
>>>      WARN(IS_ERR(pdev), "could not build omap_device for %s\n", oh_name);
>>>
>>> -    return IS_ERR(pdev) ? PTR_ERR(pdev) : 0;
>>> +    return PTR_RET(pdev);
>>
>> This is incorrect.
>>
>> The return value will be tested for < 0.  Kernel pointers in general are
>> all above 3GB, and so are all "< 0".
>>
>> I'm afraid none of these changes stuff is an improvement - they all
>> introduce bugs.
>
> Sorry I am now not sure I follow you here. Someone just pointed out to
> me that PTR_RET() is defined as ...
>
> static inline int __must_check PTR_RET(const void *ptr)
> {
>         if (IS_ERR(ptr))
>                 return PTR_ERR(ptr);
>         else
>                 return 0;
> }
>
> So the above change appears to be equivalent. Is there something that is
> wrong with the current implementation that needs to be fixed?


As the patch message says, it's just for readability purposes.
I used make coccicheck and it suggested this minor change.

--
Silviu Popescu

  reply	other threads:[~2013-03-21 18:33 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-03-12  7:58 [PATCH] mach_omap2: use PTR_RET instead of IS_ERR + PTR_ERR Silviu-Mihai Popescu
2013-03-12 11:05 ` Russell King - ARM Linux
2013-03-20 18:28   ` Jon Hunter
2013-03-21 18:33     ` Silviu Popescu [this message]
2013-03-22 16:36     ` Russell King - ARM Linux
2013-03-22 18:39       ` Jon Hunter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAPWTe+JYEZJ5Zn6Dt9mmr38raXdM8wc1eWFro2a4Czy-eCzSpQ@mail.gmail.com \
    --to=silviupopescu1990@gmail.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).