linux-arm-msm.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Bjorn Andersson <bjorn.andersson@linaro.org>
To: AngeloGioacchino Del Regno  <angelogioacchino.delregno@somainline.org>
Cc: agross@kernel.org, robh+dt@kernel.org,
	linux-arm-msm@vger.kernel.org, devicetree@vger.kernel.org,
	linux-kernel@vger.kernel.org, konrad.dybcio@somainline.org,
	marijn.suijten@somainline.org, martin.botka@somainline.org,
	~postmarketos/upstreaming@lists.sr.ht,
	phone-devel@vger.kernel.org, paul.bouchara@somainline.org
Subject: Re: [PATCH 1/7] arm64: dts: qcom: Introduce support for MSM8998 Sony Yoshino platform
Date: Tue, 7 Sep 2021 06:04:31 -0700	[thread overview]
Message-ID: <YTdjX2/XGZYQQRDW@ripper> (raw)
In-Reply-To: <20210903180924.1006044-1-angelogioacchino.delregno@somainline.org>

On Fri 03 Sep 11:09 PDT 2021, AngeloGioacchino Del Regno wrote:

> This commit introduces support for the Sony Yoshino platform, using
> the MSM8998 SoC, including:
> - Sony Xperia XZ1 (codename Poplar),
> - Sony Xperia XZ1 Compact (codename Lilac),
> - Sony Xperia XZ Premium (codename Maple).
> 

Nice!

> diff --git a/arch/arm64/boot/dts/qcom/msm8998-sony-xperia-yoshino.dtsi b/arch/arm64/boot/dts/qcom/msm8998-sony-xperia-yoshino.dtsi
[..]
> +	vph_pwr: vph-pwr-regulator {
> +		compatible = "regulator-fixed";
> +		regulator-name = "vph_pwr";
> +		regulator-always-on;
> +		regulator-boot-on;
> +	};
> +
> +	gpio_keys {

Please don't use '_' in node names.

> +		compatible = "gpio-keys";
> +		input-name = "gpio-keys";
> +		label = "Side buttons";
> +		#address-cells = <1>;
> +		#size-cells = <0>;
> +		pinctrl-names = "default";
> +		pinctrl-0 = <&vol_down_pin_a>, <&cam_focus_pin_a>,
> +			    <&cam_snapshot_pin_a>;
> +		vol-down {
> +			label = "Volume Down";
> +			gpios = <&pm8998_gpio 5 GPIO_ACTIVE_LOW>;
> +			linux,input-type = <1>;
> +			linux,code = <KEY_VOLUMEDOWN>;
> +			gpio-key,wakeup;
> +			debounce-interval = <15>;
> +		};
> +
> +		camera-snapshot {
> +			label = "Camera Snapshot";
> +			gpios = <&pm8998_gpio 7 GPIO_ACTIVE_LOW>;
> +			linux,input-type = <1>;
> +			linux,code = <KEY_CAMERA>;
> +			debounce-interval = <15>;
> +		};
> +
> +		camera-focus {
> +			label = "Camera Focus";
> +			gpios = <&pm8998_gpio 8 GPIO_ACTIVE_LOW>;
> +			linux,input-type = <1>;
> +			linux,code = <KEY_CAMERA_FOCUS>;
> +			debounce-interval = <15>;
> +		};
> +	};
> +
> +	gpio_hall_sensor {

Ditto.

> +		compatible = "gpio-keys";
> +		input-name = "hall-sensors";
> +		label = "Hall sensors";
> +		#address-cells = <1>;
> +		#size-cells = <0>;
> +		pinctrl-names = "default";
> +		pinctrl-0 = <&hall_sensor0_default>;
> +
> +		hall_sensor0 {

And here...

> +			label = "Cover Hall Sensor";
> +			gpios = <&tlmm 124 GPIO_ACTIVE_LOW>;
> +			linux,input-type = <EV_SW>;
> +			linux,code = <SW_LID>;
> +			gpio-key,wakeup;
> +			debounce-interval = <30>;
> +		};
> +	};
> +
> +	reserved-memory {
> +		#address-cells = <2>;
> +		#size-cells = <2>;
> +		ranges;
> +
> +		hyp_mem: memory@85800000 {
> +			reg = <0x0 0x85800000 0x0 0x3700000>;
> +			no-map;
> +		};
> +
> +		cont_splash_mem: cont-splash-region@9d400000 {

Is there any reason for not just naming this "memory"?

> +			reg = <0x0 0x9d400000 0x0 0x2400000>;
> +			no-map;
> +		};
> +
> +		zap_shader_region: gpu@f6400000 {

This is also just "memory" here.

> +			compatible = "shared-dma-pool";
> +			reg = <0x0 0xf6400000 0x0 0x2000>;
> +			no-map;
> +		};
> +
[..]
> +&rpm_requests {
> +	pm8998-regulators {
> +		compatible = "qcom,rpm-pm8998-regulators";
> +
[..]
> +		vreg_lvs1a_1p8: lvs1 { };
> +		vreg_lvs2a_1p8: lvs2 { };
> +

Blank line.

> +	};
> +
> +	pmi8998-regulators {
> +		compatible = "qcom,rpm-pmi8998-regulators";
> +
> +		vdd_bob-supply = <&vph_pwr>;
> +
> +		vreg_bob: bob {
> +			regulator-min-microvolt = <3312000>;
> +			regulator-max-microvolt = <3600000>;
> +		};
> +	};
> +};
> +
> +&sdhc2 {
> +	status = "okay";
> +	cd-gpios = <&tlmm 95 GPIO_ACTIVE_HIGH>;
> +
> +	vmmc-supply = <&vreg_l21a_2p95>;
> +	vqmmc-supply = <&vreg_l13a_2p95>;
> +
> +	pinctrl-names = "default", "sleep";
> +	pinctrl-0 = <&sdc2_clk_on  &sdc2_cmd_on  &sdc2_data_on  &sdc2_cd_on>;
> +	pinctrl-1 = <&sdc2_clk_off &sdc2_cmd_off &sdc2_data_off &sdc2_cd_off>;

How about grouping these various pins as "sdc2_default_state" and
"sdc2_sleep_state"?

> +};
> +
Regards,
Bjorn

  parent reply	other threads:[~2021-09-07 13:03 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-09-03 18:09 [PATCH 1/7] arm64: dts: qcom: Introduce support for MSM8998 Sony Yoshino platform AngeloGioacchino Del Regno
2021-09-03 18:09 ` [PATCH 2/7] arm64: dts: qcom: msm8998-xperia: Add RMI4 touchscreen support AngeloGioacchino Del Regno
2021-09-07 13:41   ` Bjorn Andersson
2021-09-09 11:25     ` AngeloGioacchino Del Regno
2021-09-03 18:09 ` [PATCH 3/7] arm64: dts: qcom: msm8998-xperia: Add support for wcn3990 Bluetooth AngeloGioacchino Del Regno
2021-09-07 13:42   ` Bjorn Andersson
2021-09-09 13:19   ` Dmitry Baryshkov
2021-09-09 18:03     ` AngeloGioacchino Del Regno
2021-09-03 18:09 ` [PATCH 4/7] arm64: dts: qcom: msm8998-xperia: Add support for gpio vibrator AngeloGioacchino Del Regno
2021-09-03 18:09 ` [PATCH 5/7] arm64: dts: qcom: msm8998-xperia: Configure display boost regulators AngeloGioacchino Del Regno
2021-09-03 18:09 ` [PATCH 6/7] arm64: dts: qcom: msm8998-xperia: Add camera regulators AngeloGioacchino Del Regno
2021-09-03 18:09 ` [PATCH 7/7] arm64: dts: qcom: msm8998-xperia: Add audio clock and its pin AngeloGioacchino Del Regno
2021-09-07 13:47   ` Bjorn Andersson
2021-09-09 10:57     ` AngeloGioacchino Del Regno
2021-09-07 11:40 ` [PATCH 1/7] arm64: dts: qcom: Introduce support for MSM8998 Sony Yoshino platform kernel test robot
2021-09-07 13:04 ` Bjorn Andersson [this message]
2021-09-09 10:40   ` AngeloGioacchino Del Regno

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YTdjX2/XGZYQQRDW@ripper \
    --to=bjorn.andersson@linaro.org \
    --cc=agross@kernel.org \
    --cc=angelogioacchino.delregno@somainline.org \
    --cc=devicetree@vger.kernel.org \
    --cc=konrad.dybcio@somainline.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marijn.suijten@somainline.org \
    --cc=martin.botka@somainline.org \
    --cc=paul.bouchara@somainline.org \
    --cc=phone-devel@vger.kernel.org \
    --cc=robh+dt@kernel.org \
    --cc=~postmarketos/upstreaming@lists.sr.ht \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).