linux-audit.redhat.com archive mirror
 help / color / mirror / Atom feed
From: Richard Guy Briggs <rgb@redhat.com>
To: Paul Moore <paul@paul-moore.com>
Cc: Linux-Audit Mailing List <linux-audit@redhat.com>
Subject: Re: [PATCH v4 1/3] audit: replace magic audit syscall class numbers with macros
Date: Fri, 1 Oct 2021 15:53:06 -0400	[thread overview]
Message-ID: <20211001195306.GC3977594@madcap2.tricolour.ca> (raw)
In-Reply-To: <CAHC9VhS83sZRxu_S7zERJCb2fnobMSvqY6OZypZr6=4GzZa0KQ@mail.gmail.com>

On 2021-09-30 16:38, Paul Moore wrote:
> On Thu, Aug 5, 2021 at 6:01 PM Paul Moore <paul@paul-moore.com> wrote:
> > On Wed, May 19, 2021 at 4:01 PM Richard Guy Briggs <rgb@redhat.com> wrote:
> > > Replace audit syscall class magic numbers with macros.
> > >
> > > This required putting the macros into new header file
> > > include/linux/auditsc_classmacros.h since the syscall macros were
> > > included for both 64 bit and 32 bit in any compat code, causing
> > > redefinition warnings.
> > >
> > > Signed-off-by: Richard Guy Briggs <rgb@redhat.com>
> > > Link: https://lore.kernel.org/r/2300b1083a32aade7ae7efb95826e8f3f260b1df.1621363275.git.rgb@redhat.com
> > > ---
> > >  MAINTAINERS                         |  1 +
> > >  arch/alpha/kernel/audit.c           |  8 ++++----
> > >  arch/ia64/kernel/audit.c            |  8 ++++----
> > >  arch/parisc/kernel/audit.c          |  8 ++++----
> > >  arch/parisc/kernel/compat_audit.c   |  9 +++++----
> > >  arch/powerpc/kernel/audit.c         | 10 +++++-----
> > >  arch/powerpc/kernel/compat_audit.c  | 11 ++++++-----
> > >  arch/s390/kernel/audit.c            | 10 +++++-----
> > >  arch/s390/kernel/compat_audit.c     | 11 ++++++-----
> > >  arch/sparc/kernel/audit.c           | 10 +++++-----
> > >  arch/sparc/kernel/compat_audit.c    | 11 ++++++-----
> > >  arch/x86/ia32/audit.c               | 11 ++++++-----
> > >  arch/x86/kernel/audit_64.c          |  8 ++++----
> > >  include/linux/audit.h               |  1 +
> > >  include/linux/auditsc_classmacros.h | 23 +++++++++++++++++++++++
> > >  kernel/auditsc.c                    | 12 ++++++------
> > >  lib/audit.c                         | 10 +++++-----
> > >  lib/compat_audit.c                  | 11 ++++++-----
> > >  18 files changed, 102 insertions(+), 71 deletions(-)
> > >  create mode 100644 include/linux/auditsc_classmacros.h
> >
> > ...
> >
> > > diff --git a/include/linux/auditsc_classmacros.h b/include/linux/auditsc_classmacros.h
> > > new file mode 100644
> > > index 000000000000..18757d270961
> > > --- /dev/null
> > > +++ b/include/linux/auditsc_classmacros.h
> > > @@ -0,0 +1,23 @@
> > > +/* SPDX-License-Identifier: GPL-2.0-or-later */
> > > +/* auditsc_classmacros.h -- Auditing support syscall macros
> > > + *
> > > + * Copyright 2021 Red Hat Inc., Durham, North Carolina.
> > > + * All Rights Reserved.
> > > + *
> > > + * Author: Richard Guy Briggs <rgb@redhat.com>
> > > + */
> > > +#ifndef _LINUX_AUDITSCM_H_
> > > +#define _LINUX_AUDITSCM_H_
> > > +
> > > +enum auditsc_class_t {
> > > +       AUDITSC_NATIVE = 0,
> > > +       AUDITSC_COMPAT,
> > > +       AUDITSC_OPEN,
> > > +       AUDITSC_OPENAT,
> > > +       AUDITSC_SOCKETCALL,
> > > +       AUDITSC_EXECVE,
> > > +
> > > +       AUDITSC_NVALS /* count */
> > > +};
> > > +
> > > +#endif
> >
> > My apologies Richard, for some reason I had it in my mind that this
> > series was waiting on you to answer a question and/or respin; however,
> > now that I'm clearing my patch queues looking for any stragglers I see
> > that isn't the case.  Looking over the patchset I think it looks okay
> > to me, my only concern is that "auditsc_classmacros.h" is an awfully
> > specific header file name and could prove to be annoying if we want to
> > add to it in the future.  What do you think about something like
> > "audit_arch.h" instead?
> >
> > If that change is okay with you I can go ahead and do the rename while
> > I'm merging the patches, I'll consider it penance for letting this
> > patchset sit for so long :/
> 
> [NOTE: trimmed the To/CC line as it is excessive for a ping like this]
> 
> Going through the patch queue and I see this never got a response, or
> rather none that hit my inbox.  Richard?

Hmmm, sorry about that, delay my fault this time.  I don't have a strong
opinion about it, but prefer the original, or auditsc_arch.h at least.

> paul moore

- RGB

--
Richard Guy Briggs <rgb@redhat.com>
Sr. S/W Engineer, Kernel Security, Base Operating Systems
Remote, Ottawa, Red Hat Canada
IRC: rgb, SunRaycer
Voice: +1.647.777.2635, Internal: (81) 32635

--
Linux-audit mailing list
Linux-audit@redhat.com
https://listman.redhat.com/mailman/listinfo/linux-audit


  reply	other threads:[~2021-10-01 19:53 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-19 20:00 [PATCH v4 0/3] audit: add support for openat2 Richard Guy Briggs
2021-05-19 20:00 ` [PATCH v4 1/3] audit: replace magic audit syscall class numbers with macros Richard Guy Briggs
2021-05-20  7:50   ` Christian Brauner
2021-08-05 22:01   ` Paul Moore
2021-09-30 20:38     ` Paul Moore
2021-10-01 19:53       ` Richard Guy Briggs [this message]
2021-10-01 20:34         ` Paul Moore
2021-10-04 15:34           ` Paul Moore
2021-05-19 20:00 ` [PATCH v4 2/3] audit: add support for the openat2 syscall Richard Guy Briggs
2021-05-20  7:58   ` Christian Brauner
2021-05-24 23:04     ` Paul Moore
2022-02-09  3:44   ` Jeff Mahoney
2022-02-09 15:57     ` Paul Moore
2022-02-09 21:18       ` Paul Moore
2022-02-09 22:13         ` Richard Guy Briggs
2022-02-09 22:31           ` Paul Moore
2022-02-09 21:40       ` Richard Guy Briggs
2022-02-09 22:29         ` Paul Moore
2021-05-19 20:00 ` [PATCH v4 3/3] audit: add OPENAT2 record to list how Richard Guy Briggs
2021-05-20  8:03   ` Christian Brauner
2021-05-24 23:08     ` Paul Moore
2021-05-25 15:00       ` Richard Guy Briggs
2021-10-04 16:08   ` Paul Moore
2021-10-04 18:27     ` Richard Guy Briggs
2021-10-21 19:00       ` Steve Grubb
2021-10-21 19:44         ` Richard Guy Briggs

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20211001195306.GC3977594@madcap2.tricolour.ca \
    --to=rgb@redhat.com \
    --cc=linux-audit@redhat.com \
    --cc=paul@paul-moore.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).