linux-block.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] block: fix userspace documentation reference for del_gendisk()
@ 2021-04-26 18:50 Luis Chamberlain
  2021-04-26 20:08 ` Bart Van Assche
  0 siblings, 1 reply; 2+ messages in thread
From: Luis Chamberlain @ 2021-04-26 18:50 UTC (permalink / raw)
  To: axboe
  Cc: bvanassche, ming.lei, hch, jack, linux-block, linux-kernel,
	Luis Chamberlain

Commit b5bd357cf8b ("block: add docs for gendisk / request_queue refcount
helpers") has a typo where it references drivers for del_gendisk() when we
instead meant userspace, as the reference is to the userspace experience.
This fixes this.

Signed-off-by: Luis Chamberlain <mcgrof@kernel.org>
---
 block/genhd.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/block/genhd.c b/block/genhd.c
index 39ca97b0edc6..e077adfcd1a2 100644
--- a/block/genhd.c
+++ b/block/genhd.c
@@ -594,8 +594,8 @@ EXPORT_SYMBOL(device_add_disk_no_queue_reg);
  * with put_disk(), which should be called after del_gendisk(), if
  * __device_add_disk() was used.
  *
- * Drivers exist which depend on the release of the gendisk to be synchronous,
- * it should not be deferred.
+ * Userspace software may depend on the release of the gendisk to be
+ * synchronous, it should not be deferred.
  *
  * Context: can sleep
  */
-- 
2.29.2


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH v2] block: fix userspace documentation reference for del_gendisk()
  2021-04-26 18:50 [PATCH v2] block: fix userspace documentation reference for del_gendisk() Luis Chamberlain
@ 2021-04-26 20:08 ` Bart Van Assche
  0 siblings, 0 replies; 2+ messages in thread
From: Bart Van Assche @ 2021-04-26 20:08 UTC (permalink / raw)
  To: Luis Chamberlain, axboe; +Cc: ming.lei, hch, jack, linux-block, linux-kernel

On 4/26/21 11:50 AM, Luis Chamberlain wrote:
> Commit b5bd357cf8b ("block: add docs for gendisk / request_queue refcount
> helpers") has a typo where it references drivers for del_gendisk() when we
> instead meant userspace, as the reference is to the userspace experience.
> This fixes this.

Thanks!

Reviewed-by: Bart Van Assche <bvanassche@acm.org>

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-04-26 20:08 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-26 18:50 [PATCH v2] block: fix userspace documentation reference for del_gendisk() Luis Chamberlain
2021-04-26 20:08 ` Bart Van Assche

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).