linux-block.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-11-26 10:47:47 to 2020-11-30 02:47:21 UTC [more...]

[PATCH v4 0/9] Rework runtime suspend and SPI domain validation
 2020-11-30  2:46 UTC  (9+ messages)
` [PATCH v4 1/9] block: Fix a race in the runtime power management code
` [PATCH v4 2/9] block: Introduce BLK_MQ_REQ_PM
` [PATCH v4 3/9] ide: Do not set the RQF_PREEMPT flag for sense requests
` [PATCH v4 4/9] ide: Mark power management requests with RQF_PM instead of RQF_PREEMPT
` [PATCH v4 5/9] scsi: Do not wait for a request in scsi_eh_lock_door()
` [PATCH v4 6/9] scsi_transport_spi: Set RQF_PM for domain validation commands
` [PATCH v4 7/9] scsi: Only process PM requests if rpm_status != RPM_ACTIVE
` [PATCH v4 8/9] block: Remove RQF_PREEMPT and BLK_MQ_REQ_PREEMPT

[PATCH 0/3] blk-mq/nvme-loop: use nvme-loop's lock class for addressing lockdep false positive warning
 2020-11-30  2:36 UTC  (2+ messages)

[PATCH] block: wbt: Remove unnecessary invoking of wbt_update_limits in wbt_init
 2020-11-30  2:20 UTC 

[PATCH 0/3] cleanups/fix for blk_mq_get_tag()
 2020-11-30  1:36 UTC  (4+ messages)
` [PATCH 1/3] blk-mq: use right tag offset after wait
` [PATCH 2/3] blk-mq: deduplicate blk_mq_get_tag() bits
` [PATCH 3/3] blk-mq: idiomatic use of WARN_ON_ONCE

split hard read-only vs read-only policy v2
 2020-11-30  1:23 UTC  (7+ messages)
` [PATCH 1/4] block: add a hard-readonly flag to struct gendisk
` [PATCH 2/4] rbd: remove the ->set_read_only method
` [PATCH 3/4] nvme: allow revalidate to set a namespace read-only
` [PATCH 4/4] dm: use bdev_read_only to check if a device is read-only

[PATCH 0/9] nvmet: add genblk ZBD backend
 2020-11-30  0:21 UTC  (10+ messages)
` [PATCH 2/9] nvmet: add ZNS support for bdev-ns
` [PATCH 6/9] nvmet: add cns-cs-ns in id-ctrl for ZNS bdev

[PATCH 1/2] ALSA: ppc: drop if block with always false condition
 2020-11-29 17:31 UTC  (10+ messages)
` [PATCH 2/2] powerpc/ps3: make system bus's remove and shutdown callbacks return void

[RFC PATCH] blk-iocost: Optimize the ioc_refreash_vrate() function
 2020-11-29  2:37 UTC 

merge struct block_device and struct hd_struct v4
 2020-11-28 16:15 UTC  (46+ messages)
` [PATCH 01/45] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats
` [PATCH 02/45] filemap: consistently use ->f_mapping over ->i_mapping
` [PATCH 03/45] fs: remove get_super_thawed and get_super_exclusive_thawed
` [PATCH 04/45] fs: simplify freeze_bdev/thaw_bdev
` [PATCH 05/45] mtip32xx: remove the call to fsync_bdev on removal
` [PATCH 06/45] zram: do not call set_blocksize
` [PATCH 07/45] loop: "
` [PATCH 08/45] dm: simplify flush_bio initialization in __send_empty_flush
` [PATCH 09/45] dm: remove the block_device reference in struct mapped_device
` [PATCH 10/45] block: remove a duplicate __disk_get_part prototype
` [PATCH 11/45] block: remove a superflous check in blkpg_do_ioctl
` [PATCH 12/45] block: add a bdev_kobj helper
` [PATCH 13/45] block: use disk_part_iter_exit in disk_part_iter_next
` [PATCH 14/45] block: use put_device in put_disk
` [PATCH 15/45] block: change the hash used for looking up block devices
` [PATCH 16/45] block: switch bdgrab to use igrab
` [PATCH 17/45] init: refactor name_to_dev_t
` [PATCH 18/45] init: refactor devt_from_partuuid
` [PATCH 19/45] init: cleanup match_dev_by_uuid and match_dev_by_label
` [PATCH 20/45] block: refactor __blkdev_put
` [PATCH 21/45] block: refactor blkdev_get
` [PATCH 22/45] block: move bdput() to the callers of __blkdev_get
` [PATCH 23/45] block: opencode devcgroup_inode_permission
` [PATCH 24/45] block: remove i_bdev
` [PATCH 25/45] block: simplify bdev/disk lookup in blkdev_get
` [PATCH 26/45] block: remove ->bd_contains
` [PATCH 27/45] block: simplify the block device claiming interface
` [PATCH 28/45] block: simplify part_to_disk
` [PATCH 29/45] block: initialize struct block_device in bdev_alloc
` [PATCH 30/45] block: remove the nr_sects field in struct hd_struct
` [PATCH 31/45] block: move disk stat accounting to struct block_device
` [PATCH 32/45] block: move the start_sect field "
` [PATCH 33/45] block: move the partition_meta_info "
` [PATCH 34/45] block: move holder_dir "
` [PATCH 35/45] block: move make_it_fail "
` [PATCH 36/45] block: move the policy field "
` [PATCH 37/45] block: allocate struct hd_struct as part of struct bdev_inode
` [PATCH 38/45] block: switch partition lookup to use struct block_device
` [PATCH 39/45] block: remove the partno field from struct hd_struct
` [PATCH 40/45] block: pass a block_device to blk_alloc_devt
` [PATCH 41/45] block: pass a block_device to invalidate_partition
` [PATCH 42/45] block: switch disk_part_iter_* to use a struct block_device
` [PATCH 43/45] f2fs: remove a few bd_part checks
` [PATCH 44/45] block: merge struct block_device and struct hd_struct
` [PATCH 45/45] block: stop using bdget_disk for partition 0

[GIT PULL] Block fix for 5.10-rc
 2020-11-27 21:22 UTC  (2+ messages)

merge struct block_device and struct hd_struct v3
 2020-11-27 17:30 UTC  (89+ messages)
` [PATCH 01/44] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats
` [PATCH 02/44] filemap: consistently use ->f_mapping over ->i_mapping
` [PATCH 03/44] fs: remove get_super_thawed and get_super_exclusive_thawed
` [PATCH 04/44] fs: simplify freeze_bdev/thaw_bdev
` [PATCH 05/44] mtip32xx: remove the call to fsync_bdev on removal
` [PATCH 06/44] zram: do not call set_blocksize
` [PATCH 07/44] loop: "
` [PATCH 08/44] dm: simplify flush_bio initialization in __send_empty_flush
` [PATCH 09/44] dm: remove the block_device reference in struct mapped_device
` [PATCH 10/44] block: remove a duplicate __disk_get_part prototype
` [PATCH 11/44] block: remove a superflous check in blkpg_do_ioctl
` [PATCH 12/44] block: add a bdev_kobj helper
` [PATCH 13/44] block: use disk_part_iter_exit in disk_part_iter_next
` [PATCH 14/44] block: use put_device in put_disk
` [PATCH 15/44] block: change the hash used for looking up block devices
` [PATCH 16/44] init: refactor name_to_dev_t
` [PATCH 17/44] init: refactor devt_from_partuuid
` [PATCH 18/44] init: cleanup match_dev_by_uuid and match_dev_by_label
` [PATCH 19/44] block: refactor __blkdev_put
` [PATCH 20/44] block: refactor blkdev_get
` [PATCH 21/44] block: move bdput() to the callers of __blkdev_get
` [PATCH 22/44] block: opencode devcgroup_inode_permission
` [PATCH 23/44] block: remove i_bdev
` [PATCH 24/44] block: simplify bdev/disk lookup in blkdev_get
` [PATCH 25/44] block: remove ->bd_contains
` [PATCH 26/44] block: simplify the block device claiming interface
` [PATCH 27/44] block: simplify part_to_disk
` [PATCH 28/44] block: initialize struct block_device in bdev_alloc
` [PATCH 29/44] block: remove the nr_sects field in struct hd_struct
` [PATCH 30/44] block: move disk stat accounting to struct block_device
` [PATCH 31/44] block: move the start_sect field "
` [PATCH 32/44] block: move the partition_meta_info "
` [PATCH 33/44] block: move holder_dir "
` [PATCH 34/44] block: move make_it_fail "
` [PATCH 35/44] block: move the policy field "
` [PATCH 36/44] block: allocate struct hd_struct as part of struct bdev_inode
` [PATCH 37/44] block: switch partition lookup to use struct block_device
` [PATCH 38/44] block: remove the partno field from struct hd_struct
` [PATCH 39/44] block: pass a block_device to blk_alloc_devt
` [PATCH 40/44] block: pass a block_device to invalidate_partition
` [PATCH 41/44] block: switch disk_part_iter_* to use a struct block_device
` [PATCH 42/44] f2fs: remove a few bd_part checks
` [PATCH 43/44] block: merge struct block_device and struct hd_struct
` [PATCH 44/44] block: stop using bdget_disk for partition 0

[PATCH 01/29] iov_iter: Switch to using a table of operations
 2020-11-27 17:14 UTC  (8+ messages)
    ` [PATCH 00/29] RFC: iov_iter: Switch to using an ops table

[PATCH] block/rnbd: Adding name to the Contributors List
 2020-11-27 12:54 UTC  (2+ messages)

[PATCH] blk-mq: Make running from the wrong CPU less scary
 2020-11-27  2:40 UTC  (2+ messages)

[PATCH v2 for-next 0/4] optimise sbitmap deferred clear
 2020-11-27  2:06 UTC  (5+ messages)
` [PATCH v2 2/4] sbitmap: remove swap_lock

[PATCH] block: fix a unsigned integer overflow which could bypass check
 2020-11-27  1:29 UTC 

[PATCH 000/141] Fix fall-through warnings for Clang
 2020-11-26 17:05 UTC  (18+ messages)

[PATCH V1] block: Fix use-after-free while iterating over requests
 2020-11-26 16:49 UTC  (3+ messages)

[PATCH V3 blktests 0/5] nvmeof-mp/srp/nvme-rdma misc fix and enhancement
 2020-11-26 16:31 UTC  (7+ messages)
` [PATCH V3 blktests 3/5] nvmeof-mp/012, srp/012: fix the scheduler list
` [PATCH V3 blktests 4/5] common/rc: _have_iproute2 fix for "ip -V" change
` [PATCH V3 blktests 5/5] common/multipath-over-rdma: allow to set use_siw

[PATCH] block/rnbd: server: Fix error return code in rnbd_srv_create_dev_sysfs()
 2020-11-26 14:04 UTC  (2+ messages)

[PATCH 0/2] optimise bvec/bio iteration
 2020-11-26 12:32 UTC  (4+ messages)
` [PATCH 2/2] bio: optimise bvec iteration

[PATCH v5 0/2] fix inaccurate io_ticks
 2020-11-26 11:23 UTC  (8+ messages)

[PATCH for-next 0/8] update for rnbd
 2020-11-26 10:47 UTC  (7+ messages)
` [PATCH for-next 2/8] block/rnbd-clt: support mapping two devices with the same name from different servers
` [PATCH for-next 3/8] Documentation/ABI/rnbd-clt: fix typo in sysfs-class-rnbd-client
` [PATCH for-next 5/8] block/rnbd-srv: close a mapped device from server side
` [PATCH for-next 6/8] Documentation/ABI/rnbd-srv: add document for force_close
` [PATCH for-next 7/8] block/rnbd: call kobject_put in the failure path
` [PATCH for-next 8/8] block/rnbd-clt: Dynamically alloc buffer for pathname & blk_symlink_name


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).