linux-block.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/5] blk-crypto cleanups
@ 2021-09-13  1:31 Eric Biggers
  2021-09-13  1:31 ` [PATCH 1/5] blk-crypto-fallback: properly prefix function and struct names Eric Biggers
                   ` (4 more replies)
  0 siblings, 5 replies; 17+ messages in thread
From: Eric Biggers @ 2021-09-13  1:31 UTC (permalink / raw)
  To: linux-block; +Cc: linux-mmc, linux-scsi, dm-devel, Satya Tangirala

This series renames struct blk_keyslot_manager to struct
blk_crypto_profile, as it is misnamed; it doesn't always manage
keyslots.  It's much more logical to think of it as the
"blk-crypto profile" of a device, similar to blk_integrity_profile.

This series also improves the inline-encryption.rst documentation file,
and cleans up blk-crypto-fallback a bit.

This series applies to v5.15-rc1.

Eric Biggers (5):
  blk-crypto-fallback: properly prefix function and struct names
  blk-crypto-fallback: consolidate static variables
  blk-crypto: rename keyslot-manager files to blk-crypto-profile
  blk-crypto: rename blk_keyslot_manager to blk_crypto_profile
  blk-crypto: update inline encryption documentation

 Documentation/block/inline-encryption.rst | 439 ++++++++--------
 block/Makefile                            |   2 +-
 block/blk-crypto-fallback.c               | 330 ++++++------
 block/blk-crypto-profile.c                | 564 +++++++++++++++++++++
 block/blk-crypto.c                        |  27 +-
 block/blk-integrity.c                     |   2 +-
 block/keyslot-manager.c                   | 578 ----------------------
 drivers/md/dm-core.h                      |   4 +-
 drivers/md/dm-table.c                     | 168 +++----
 drivers/md/dm.c                           |  10 +-
 drivers/mmc/core/crypto.c                 |  11 +-
 drivers/mmc/host/cqhci-crypto.c           |  33 +-
 drivers/scsi/ufs/ufshcd-crypto.c          |  32 +-
 drivers/scsi/ufs/ufshcd-crypto.h          |   9 +-
 drivers/scsi/ufs/ufshcd.c                 |   2 +-
 drivers/scsi/ufs/ufshcd.h                 |   6 +-
 include/linux/blk-crypto-profile.h        | 166 +++++++
 include/linux/blkdev.h                    |  18 +-
 include/linux/device-mapper.h             |   4 +-
 include/linux/keyslot-manager.h           | 120 -----
 include/linux/mmc/host.h                  |   4 +-
 21 files changed, 1310 insertions(+), 1219 deletions(-)
 create mode 100644 block/blk-crypto-profile.c
 delete mode 100644 block/keyslot-manager.c
 create mode 100644 include/linux/blk-crypto-profile.h
 delete mode 100644 include/linux/keyslot-manager.h

-- 
2.33.0


^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2021-09-16 17:44 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-13  1:31 [PATCH 0/5] blk-crypto cleanups Eric Biggers
2021-09-13  1:31 ` [PATCH 1/5] blk-crypto-fallback: properly prefix function and struct names Eric Biggers
2021-09-15  7:36   ` Christoph Hellwig
2021-09-13  1:31 ` [PATCH 2/5] blk-crypto-fallback: consolidate static variables Eric Biggers
2021-09-15  7:39   ` Christoph Hellwig
2021-09-15 17:50     ` Eric Biggers
2021-09-16  7:39       ` Christoph Hellwig
2021-09-16 17:28         ` Eric Biggers
2021-09-13  1:31 ` [PATCH 3/5] blk-crypto: rename keyslot-manager files to blk-crypto-profile Eric Biggers
2021-09-14  9:04   ` Ulf Hansson
2021-09-15  7:45   ` Christoph Hellwig
2021-09-15 17:40     ` Eric Biggers
2021-09-16  7:42       ` Christoph Hellwig
2021-09-13  1:31 ` [PATCH 4/5] blk-crypto: rename blk_keyslot_manager to blk_crypto_profile Eric Biggers
2021-09-14  9:04   ` Ulf Hansson
2021-09-14 21:52   ` Eric Biggers
2021-09-13  1:31 ` [PATCH 5/5] blk-crypto: update inline encryption documentation Eric Biggers

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).