From: "Martin K. Petersen" <martin.petersen@oracle.com>
To: Christoph Hellwig <hch@lst.de>
Cc: "Martin K. Petersen" <martin.petersen@oracle.com>,
"Jens Axboe" <axboe@kernel.dk>,
"FUJITA Tomonori" <fujita.tomonori@lab.ntt.co.jp>,
"Doug Gilbert" <dgilbert@interlog.com>,
"Kai Mäkisara" <Kai.Makisara@kolumbus.fi>,
linux-block@vger.kernel.org, linux-scsi@vger.kernel.org
Subject: Re: [PATCH 19/24] scsi: rename CONFIG_BLK_SCSI_REQUEST to CONFIG_SCSI_COMMON
Date: Thu, 22 Jul 2021 13:51:28 -0400 [thread overview]
Message-ID: <yq1zguew84u.fsf@ca-mkp.ca.oracle.com> (raw)
In-Reply-To: <20210712054816.4147559-20-hch@lst.de> (Christoph Hellwig's message of "Mon, 12 Jul 2021 07:48:11 +0200")
Christoph,
> CONFIG_BLK_SCSI_REQUEST is rather misnamed now as it just enabled
> building a small amount of code shared by the scsi initiator, target
> and consumers of the scsi_request passthrough API. Rename it and also
> allow building it as a module.
Build now fails. Needs:
diff --git a/drivers/scsi/scsi_common.c b/drivers/scsi/scsi_common.c
index 8aac4e5e8c4c..4fb16e70dddf 100644
--- a/drivers/scsi/scsi_common.c
+++ b/drivers/scsi/scsi_common.c
@@ -7,9 +7,12 @@
#include <linux/kernel.h>
#include <linux/string.h>
#include <linux/errno.h>
+#include <linux/module.h>
#include <asm/unaligned.h>
#include <scsi/scsi_common.h>
+MODULE_LICENSE("GPL v2");
+
--
Martin K. Petersen Oracle Linux Engineering
next prev parent reply other threads:[~2021-07-22 17:51 UTC|newest]
Thread overview: 45+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-07-12 5:47 cleanup SCSI ioctl support Christoph Hellwig
2021-07-12 5:47 ` [PATCH 01/24] bsg: remove support for SCSI_IOCTL_SEND_COMMAND Christoph Hellwig
2021-07-22 17:31 ` Bart Van Assche
2021-07-22 19:05 ` Christoph Hellwig
2021-07-12 5:47 ` [PATCH 02/24] sr: consolidate compat ioctl handling Christoph Hellwig
2021-07-12 5:47 ` [PATCH 03/24] sd: " Christoph Hellwig
2021-07-12 5:47 ` [PATCH 04/24] ch: " Christoph Hellwig
2021-07-12 5:47 ` [PATCH 05/24] cg: " Christoph Hellwig
2021-07-12 5:47 ` [PATCH 06/24] scsi: remove scsi_compat_ioctl Christoph Hellwig
2021-07-12 5:47 ` [PATCH 07/24] st: simplify ioctl handling Christoph Hellwig
2021-07-12 5:48 ` [PATCH 08/24] cdrom: remove the call to scsi_cmd_blk_ioctl from cdrom_ioctl Christoph Hellwig
2021-07-12 5:48 ` [PATCH 09/24] scsi_ioctl: remove scsi_cmd_blk_ioctl Christoph Hellwig
2021-07-12 5:48 ` [PATCH 10/24] scsi_ioctl: remove scsi_verify_blk_ioctl Christoph Hellwig
2021-07-12 5:48 ` [PATCH 11/24] scsi: call scsi_cmd_ioctl from scsi_ioctl Christoph Hellwig
2021-07-12 5:48 ` [PATCH 12/24] block: add a queue_max_sectors_bytes helper Christoph Hellwig
2021-07-22 17:37 ` Bart Van Assche
2021-07-22 19:08 ` Christoph Hellwig
2021-07-22 18:00 ` Martin K. Petersen
2021-07-22 19:10 ` Christoph Hellwig
2021-07-12 5:48 ` [PATCH 13/24] bsg: decouple from scsi_cmd_ioctl Christoph Hellwig
2021-07-12 5:48 ` [PATCH 14/24] bsg: move bsg_scsi_ops to drivers/scsi/ Christoph Hellwig
2021-07-22 18:03 ` Martin K. Petersen
2021-07-22 19:11 ` Christoph Hellwig
2021-07-12 5:48 ` [PATCH 15/24] scsi_ioctl: remove scsi_req_init Christoph Hellwig
2021-07-12 5:48 ` [PATCH 16/24] scsi_ioctl: move scsi_command_size_tbl to scsi_common.c Christoph Hellwig
2021-07-12 5:48 ` [PATCH 17/24] scsi_ioctl: simplify SCSI passthrough permission checking Christoph Hellwig
2021-07-22 17:47 ` Bart Van Assche
2021-07-22 19:12 ` Christoph Hellwig
2021-07-12 5:48 ` [PATCH 18/24] scsi_ioctl: move all "block layer" SCSI ioctl handling to drivers/scsi Christoph Hellwig
2021-07-22 18:06 ` Martin K. Petersen
2021-07-22 19:16 ` Christoph Hellwig
2021-07-12 5:48 ` [PATCH 19/24] scsi: rename CONFIG_BLK_SCSI_REQUEST to CONFIG_SCSI_COMMON Christoph Hellwig
2021-07-22 17:51 ` Martin K. Petersen [this message]
2021-07-22 19:17 ` Christoph Hellwig
2021-07-12 5:48 ` [PATCH 20/24] scsi: remove a very misleading comment Christoph Hellwig
2021-07-22 17:52 ` Bart Van Assche
2021-07-22 19:21 ` Christoph Hellwig
2021-07-12 5:48 ` [PATCH 21/24] scsi: consolidate the START STOP UNIT handling Christoph Hellwig
2021-07-22 18:44 ` Bart Van Assche
2021-07-22 19:20 ` Christoph Hellwig
2021-07-12 5:48 ` [PATCH 22/24] scsi: factor SCSI_IOCTL_GET_IDLUN handling into a helper Christoph Hellwig
2021-07-12 5:48 ` [PATCH 23/24] scsi: factor SG_IO " Christoph Hellwig
2021-07-12 5:48 ` [PATCH 24/24] scsi: unexport sg_scsi_ioctl Christoph Hellwig
2021-07-21 5:38 ` cleanup SCSI ioctl support Christoph Hellwig
2021-07-24 7:20 cleanup SCSI ioctl support v2 Christoph Hellwig
2021-07-24 7:20 ` [PATCH 19/24] scsi: rename CONFIG_BLK_SCSI_REQUEST to CONFIG_SCSI_COMMON Christoph Hellwig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=yq1zguew84u.fsf@ca-mkp.ca.oracle.com \
--to=martin.petersen@oracle.com \
--cc=Kai.Makisara@kolumbus.fi \
--cc=axboe@kernel.dk \
--cc=dgilbert@interlog.com \
--cc=fujita.tomonori@lab.ntt.co.jp \
--cc=hch@lst.de \
--cc=linux-block@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).