Linux-Bluetooth Archive on lore.kernel.org
 help / color / Atom feed
* Bluetooth V. 5.50: "error updating services: Connection refused";, for unknown reason. This worked in v. 5.43
       [not found] ` <515577254.15611.1565603370379@bluewin.ch>
@ 2019-08-14 18:49   ` hans.w.kramer
  0 siblings, 0 replies; only message in thread
From: hans.w.kramer @ 2019-08-14 18:49 UTC (permalink / raw)
  To: linux-bluetooth

Hi, 

I have the following problem with a bluetooth audio device (Cambridge Audio One ) in v. 5.50 which i do not have in v. 5.43.

Attempting to connect to XX:XX:XX:XX:XX:XX
[CHG] Device XX:XX:XX:XX:XX:XX Connected: yes
[CHG] Device XX:XX:XX:XX:XX:XX UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device XX:XX:XX:XX:XX:XX UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device XX:XX:XX:XX:XX:XX UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device XX:XX:XX:XX:XX:XX UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device XX:XX:XX:XX:XX:XX UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device XX:XX:XX:XX:XX:XX ServicesResolved: yes
Failed to connect: org.bluez.Error.Failed
[CHG] Device XX:XX:XX:XX:XX:XX ServicesResolved: no
[CHG] Device XX:XX:XX:XX:XX:XX Connected: no

Another bluetooth audio device (JBL GO) works ok in 5.43 and 5.50.

The following two btmon traces are available upon request:

1. V. 5.50, NOK: "cambridge_hcitrace.txt", OS Raspbian Buster Lite, Linux raspberrypi 4.19.57+ #1244 Thu Jul 4 18:42:50 BST 2019 armv6l GNU/Linux (77.7 KB)
2. V. 5.43, OK:  "stretch_cambridge_hcitrace.txt", OS Raspbian Stretch, Linux raspberrypi 4.14.98+ #1200 Tue Feb 12 20:11:02 GMT 2019 armv6l GNU/Linux (86.8 KB)

Note especially: "cambridge_hcitrace.txt", line 476: "Reason: Remote User Terminated Connection (0x13)".
There is no obvious reason, why this should occur. Timeout problem in the kernel?

Regards

Hans

PS: Almost the same happens with an up-to-date Fedora 30 (Bluetooth 5.50, Linux 5.2.6-200.fc30.x86_64 #1 SMP Mon Aug 5 13:20:47 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux)




^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <519900441.7067.1565432065454@bluewin.ch>
     [not found] ` <515577254.15611.1565603370379@bluewin.ch>
2019-08-14 18:49   ` Bluetooth V. 5.50: "error updating services: Connection refused";, for unknown reason. This worked in v. 5.43 hans.w.kramer

Linux-Bluetooth Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/linux-bluetooth/0 linux-bluetooth/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linux-bluetooth linux-bluetooth/ https://lore.kernel.org/linux-bluetooth \
		linux-bluetooth@vger.kernel.org linux-bluetooth@archiver.kernel.org
	public-inbox-index linux-bluetooth


Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.linux-bluetooth


AGPL code for this site: git clone https://public-inbox.org/ public-inbox